Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 8285 Просмотров

при настройке "Общих настроек" вылетает ошибка 

JFTP::write: Bad response
Возникла ошибка! Не могу открыть конфигурационный файл на запись!

на файле configuration.php стоит 777

что не так??
*

cor_ar

  • Захожу иногда
  • 137
  • 27 / 1
Re: Вот такая вот ошибка JFTP::write: Bad response
« Ответ #1 : 07.08.2009, 11:57:14 »
если мне нужно изменить что -то там, я качаю его, меняю что нужно и заново заливаю, ставлю права. Проблем никаких

Re: Вот такая вот ошибка JFTP::write: Bad response
« Ответ #2 : 07.08.2009, 12:22:12 »
если мне нужно изменить что -то там, я качаю его, меняю что нужно и заново заливаю, ставлю права. Проблем никаких
если мне нужно изменить что -то там, я качаю его, меняю что нужно и заново заливаю, ставлю права. Проблем никаких
если мне нужно изменить что -то там, я качаю его, меняю что нужно и заново заливаю, ставлю права. Проблем никаких
если мне нужно изменить что -то там, я качаю его, меняю что нужно и заново заливаю, ставлю права. Проблем никаких

а теперь еще раз и по подробней!! кого, куду качаете что меняете и куда потом заливаете?
*

cor_ar

  • Захожу иногда
  • 137
  • 27 / 1
Re: Вот такая вот ошибка JFTP::write: Bad response
« Ответ #3 : 07.08.2009, 12:31:25 »
Качаю по фтп на комп файл configuration.php
Открываю, меняю в нем что надо - сохраняю, и заливаю назад.
Главное, в конце, не забыть права выставить
*

vitash

  • Захожу иногда
  • 63
  • 5 / 0
  • """"""::::::""""""
Re: Вот такая вот ошибка JFTP::write: Bad response
« Ответ #4 : 01.02.2011, 11:15:03 »
JFTP::write: Bad response
Возникла ошибка! Не могу открыть конфигурационный файл на запись!
на файле configuration.php стоит 777
что не так??
В конфигурационном файле прописать правильный путь к фтп, в админке в поле FTP корень.
Например: /www/сайт.net.ua

Re: Вот такая вот ошибка JFTP::write: Bad response
« Ответ #5 : 13.02.2011, 16:38:46 »
www.Rasulov.org:
Ошибка: JFTP::write: Bad response
Причина: в файле configuration.php неверно указан параметр ftp_root (права на файл configuration.php менять на 777 не нужно! все будет работать и при стандартных правах 644)
Решение: нужно узнать правильный ftp путь и указать его в файле configuration.php.
Узнать правильный путь ftp можно открыв один из браузеров, например Mozilla Firefox или Google Chrome
и ввести в адресную строку ваш ftp адрес, например ftp://ftp.MySite.ru. Браузер попросит ввести логин и пароль,
после чего покажет содержимое. Перейдите по ftp в каталог где расположен файл configuration.php
Например: ftp://ftp.MySite.ru/www/htdocs/
/www/htdocs - правильный ftp путь

Удачи!
« Последнее редактирование: 13.02.2011, 16:44:40 от Vremin »
*

Roma-Proger

  • Новичок
  • 2
  • 0 / 0
Re: Вот такая вот ошибка JFTP::write: Bad response
« Ответ #6 : 15.03.2012, 21:43:18 »
В конфигурационном файле прописать правильный путь к фтп, в админке в поле FTP корень.
Например: /www/сайт.net.ua
а где именно прописываются права в этом файле и как?
*

criat

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Re: Вот такая вот ошибка JFTP::write: Bad response
« Ответ #7 : 28.08.2012, 18:02:42 »
Roma-Proger просто возьми и отключи FTP в админке сайта, все равно она никогда не работает, и будет тебе счастье.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

simpleform2 ошибка ajax error в Google chrome

Автор safronoff343

Ответов: 1
Просмотров: 4914
Последний ответ 05.06.2020, 20:36:42
от safronoff343
Ошибка #1050 при переносе базы данных на хостинг

Автор Ksen

Ответов: 7
Просмотров: 29334
Последний ответ 16.03.2020, 17:47:29
от Petrovich
При попытке войти в админку 404 ошибка компонента

Автор omezik

Ответов: 4
Просмотров: 8547
Последний ответ 31.08.2019, 22:41:46
от Taatshi
Ошибка в компоненте CKForms

Автор Vas80

Ответов: 9
Просмотров: 4067
Последний ответ 22.04.2019, 13:34:48
от sivers
Ошибка Fatal error: Allowed memory size of 73400320 bytes exhausted

Автор Andre109

Ответов: 1
Просмотров: 4323
Последний ответ 03.12.2018, 01:29:56
от voland