0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 5722 Просмотров
*

spin

  • Новичок
  • 3
  • 0 / 0
RSGallery2 2.1.0 Beta
весь сайт и БД - UTF8
если заводить галлерею с админки, то кириллица отображается правильно, если с лица сайта - кириллица слетает.
Причем "кракозябры" отображаются уже в самой базе, т.е. проблема НЕ при выводе, а именно при постинге.
Все остальные материалы, рассылка и т.д. со стороны лица постятся нормально.
В чем может быть трабл?
*

spin

  • Новичок
  • 3
  • 0 / 0
проблема решена.
файл \components\com_rsgallery2\lib\mygalleries\mygalleries.php

строки:
Цитировать
   $catname1       = htmlentities(rsgInstance::getVar( 'catname1'  , null), ENT_QUOTES);
   $description    = htmlentities(rsgInstance::getVar( 'description'  , null), ENT_QUOTES);
меняем на:
Цитировать
   $catname1       = htmlspecialchars(rsgInstance::getVar( 'catname1'  , null));
   $description    = htmlspecialchars(rsgInstance::getVar( 'description'  , null));

Та же самая проблема, только галлерея - Ignite Gallery.
Что изменить в файле ignitegallery.php?
В этом файле строки:
Цитировать
$catname1       = htmlentities(rsgInstance::getVar( 'catname1'  , null), ENT_QUOTES);
$description    = htmlentities(rsgInstance::getVar( 'description'  , null), ENT_QUOTES);
отсутствуют.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Название категорий отображаются вопросами

Автор Maxafon

Ответов: 4
Просмотров: 7877
Последний ответ 06.09.2009, 22:07:03
от haf
Как создать ссылку на категорию галлереи?

Автор Composter

Ответов: 3
Просмотров: 5255
Последний ответ 19.12.2007, 15:39:24
от tsesl