Не подсвечивается активный пункт меню.

  • 15 Ответов
  • 5942 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Оффлайн Loh

Друзья,  помогите с таким вопросом.
Мой сайт прекрасно работал энное количество времени. Всегда подсвечивался тот пункт меню на котором находишься. Но недавно я заметил, что эта подсветка перестала работать. Т.е. заходишь например на главную страницу - подсвечено пункт меню "главная"- все ОК, но потом нажимаешь другой пункт меню, а подсвечена остается "главная", хотя материал открыт соответствующий нажатому пункту меню, и так по остальным пунктам >:(.
Недавно установил на свой сайт счетчики: liveinternet, rambler top 100, top mail.ru, spylog, hotlog через PHP Module. Не знаю что и думать... Может из-за счетчиков? Подскажите как неполадку устранить.

*

Оффлайн beliyadm

  • ********
  • 8447
  • [+]1590 / [-]63
  • Пол: Мужской
  • Севастополь == Россия
    • Просмотр профиля
    • записки нетрезвого кодера
отключите кеширование для модуля меню
Все истины, которые я хочу вам изложить, — бесстыдная ложь.
Записки нетрезвого кодера || -=Joomla FAQ=- || -=все плохо=- || skype: beliyadm_pb

*

Оффлайн Loh

Огромное тебе спасибо, добрый человек,- все работает :D +1. А раньше, наверное, работало потому, что плагин кеширования был отключен.

*

Оффлайн beliyadm

  • ********
  • 8447
  • [+]1590 / [-]63
  • Пол: Мужской
  • Севастополь == Россия
    • Просмотр профиля
    • записки нетрезвого кодера
А раньше, наверное, работало потому, что плагин кеширования был отключен.
именно так, кеширование мешает работе модуля меню, отключает подсветку активного пункта
Все истины, которые я хочу вам изложить, — бесстыдная ложь.
Записки нетрезвого кодера || -=Joomla FAQ=- || -=все плохо=- || skype: beliyadm_pb

*

Оффлайн gartus

Привет
Только что поставил Joomla 1.5.15 и сразу же столкнулся с точно такой же проблемой: какую бы страницу не открывал, все время подсвечено только меню Home. Кэширование для меню отключил, но это не помогло. Кто-нибудь знает в чем может быть проблема?

*

Оффлайн beliyadm

  • ********
  • 8447
  • [+]1590 / [-]63
  • Пол: Мужской
  • Севастополь == Россия
    • Просмотр профиля
    • записки нетрезвого кодера
Кэширование для меню отключил, но это не помогло.
точно для модуля меню кеширование отключено? В таком случае даже при включенном кеше всего сайта все должно работать корректно, иных вариантов не встречал
Все истины, которые я хочу вам изложить, — бесстыдная ложь.
Записки нетрезвого кодера || -=Joomla FAQ=- || -=все плохо=- || skype: beliyadm_pb

*

Оффлайн gartus

точно для модуля меню кеширование отключено? В таком случае даже при включенном кеше всего сайта все должно работать корректно, иных вариантов не встречал
Да, выключено, в глобальных настройках тоже выключено, плагин "System - Cache" тоже неактивный. Уже и Joomla переустанавливал, а всеравно то же самое.


[вложение удалено Администратором]

*

Оффлайн beliyadm

  • ********
  • 8447
  • [+]1590 / [-]63
  • Пол: Мужской
  • Севастополь == Россия
    • Просмотр профиля
    • записки нетрезвого кодера
то есть кеш на сайте выключен вообще?
весьма и весьма странно, проверьте, что остальные настройки у вас идентичны скриншоту и попробуйте с ними поиграть (параметры выделения)


Если сайт в сети - неплохо бы на него ссылочку, посмотреть живьем
Все истины, которые я хочу вам изложить, — бесстыдная ложь.
Записки нетрезвого кодера || -=Joomla FAQ=- || -=все плохо=- || skype: beliyadm_pb

*

Оффлайн gartus

то есть кеш на сайте выключен вообще?
весьма и весьма странно, проверьте, что остальные настройки у вас идентичны скриншоту и попробуйте с ними поиграть (параметры выделения)
Если сайт в сети - неплохо бы на него ссылочку, посмотреть живьем
Ну в глобальных настройках Joomla кэш выключен
Сайт тут: http://test.otherscience.com
Настройки пробовал менять, не помогает, пробовал и другое меню ставить (суперфиш), но проблема остается

*

Alukret

всем привет!)
впервые на этом форуме, но чувствую, что надолго)
в общем у меня на сайте верхняя горизонтальная менюшка раньше подсвечивалась разными цветами. было настроено в управлении шаблоном разные цвета для itemcolor1 2 3 etc. в общем были все цвета радуги..
а теперь, я не знаю, может я отключил какой-то модуль, или не знаю, но теперь вся подсветка только красного цвета..
и ещё, раньше на сайте ссылки выделялись синим - теперь тоже красным. и заголовки тоже покраснели.
не знаю было ли это раньше, но у меня при входе в менеджер моего шаблона справа перед настройками пишет
The parameter file /templates/yoo_waybeyond/params.ini is unwritable!
хотя файл этот лежит на хостинге и с ним всё ок (при изменении настроек файл меняет значения)
в общем если кто поможет - буду премного благодарен) потому что я вообще себя чувствую жёстким чайником в этих делах^^
« Последнее редактирование: 11.01.2010, 10:42:49 от Alukret »

*

Оффлайн elph

beliyadm = ))))

всем привет!)
впервые на этом форуме, но чувствую, что надолго)
в общем у меня на сайте верхняя горизонтальная менюшка раньше подсвечивалась разными цветами. было настроено в управлении шаблоном разные цвета для itemcolor1 2 3 etc. в общем были все цвета радуги..
а теперь, я не знаю, может я отключил какой-то модуль, или не знаю, но теперь вся подсветка только красного цвета..
и ещё, раньше на сайте ссылки выделялись синим - теперь тоже красным. и заголовки тоже покраснели.
не знаю было ли это раньше, но у меня при входе в менеджер моего шаблона справа перед настройками пишет
The parameter file /templates/yoo_waybeyond/params.ini is unwritable!
хотя файл этот лежит на хостинге и с ним всё ок (при изменении настроек файл меняет значения)
в общем если кто поможет - буду премного благодарен) потому что я вообще себя чувствую жёстким чайником в этих делах^^

Настрой правильно сортировку менюшки!(Сортировка:)
там есть баг, и оно тупит когда ты добавляешь новое меню(категорию,раздел и т.п.)-оно почему-то сбивается .Например главная стает по порядку аж 35 а форум например 21, а ты в настройках каждого меню выставь правильно(хотя хватит и одной главной или любой первой по порядку поставить)

извините за оффтоп: "главная стает по порядку аж 35 а форум например 21"(это так для примера я навел).А если реально, то там сразу видно что в списке меню один или несколько элементов менюшки стают где-то 99999!вот здесь и есть баг!

*

bonsayspb

Здравствуйте!! Выручайте... :o
столкнулся с похожей проблемой на сайте http://инфо-бухгалтер-спб.рф
стоит Joomla 1.5.24 в главном меню не фиксируется активный пункт учебный центр и о компании.. остальные пункты фиксируются.. кэш отключен. ставил шаблон rt_solarsentinel_j15 с его прибамбасами..

*

Оффлайн kostake

а как напротив сделать, чтобы при кэшировании mod_mainmenu работали активные пункты меню? Готов за реализацию заплатить 500 руб, кто решит данную проблему на моём проекте.

В Joomle 3.5 в настройках модуля главного меню выберите в пункте "Базовый пункт меню" из выпадающего меню вариант "Текущий". Теперь все выбранные пункты меню будут выделяться цветом.