0 Пользователей и 1 Гость просматривают эту тему.
  • 15 Ответов
  • 18519 Просмотров
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Зафигачил сайт. Работал с компонентом. И только в конце приступил к статьям. Удивился. Никак не отображаются. Все перепробовал. Есессно опубликованы.
При этом компонент (интернет магазин)  работает и в главное меню я его заусунул.
Куда смотреть?
Заранее спасибо!
*

beliyadm

  • Легенда
  • 9126
  • 1632 / 64
  • Севастополь == Россия
в админке статьи сохраняются и опубликованы и доступны гостям? В меню ссылка на какой-либо тип отображения контента создана?

P.S. переходите на 1.5, 1.0 версия уже год как мертва
Все истины, которые я хочу вам изложить, — бесстыдная ложь.
Записки нетрезвого кодера || -=Joomla FAQ=- || -=все плохо=- || skype: beliyadm_pb
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Да конечно сохраняются. Редактируются. Все ок.
Гостей нет.
Последний вопрос не понял. Делал в меню ссылку на стат материал, блог разделов и категорий, на главную 10 статей добавлял.

На 1.5 с радостью. но никак не могу найти шаблон магазина. Вернее нашел, но установить не могу. Чет там до.ера файлов.
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Поставил час рядом чистую ту же версию (что и использовал) - так там тоже не отображаются статьи. Причем уже заранее установленные с галочками публикации на главной.
P.S. Просто заново делать сайт неохота.
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
То же самое!
Виндовз XP. Денвер. Перепробовал все версии Joomla - везде одно и то же - не удается вывести в меню ничего. В админке все создается и сохраняется.
Что за?
*

beliyadm

  • Легенда
  • 9126
  • 1632 / 64
  • Севастополь == Россия
Опишите последовательно действия по созданию материала и созданию ссылки в меню на него
Все истины, которые я хочу вам изложить, — бесстыдная ложь.
Записки нетрезвого кодера || -=Joomla FAQ=- || -=все плохо=- || skype: beliyadm_pb
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Если брать J1.5.8
Материалы - Менеджер материалов - Создать
Делаю статью или с указанием раздела или без указания - рез-тат одинаков будет.
Создав без раздела - пытаюсь нажать на крестик напротив статьи (На главной) что бы опубликовать на главной. Не нажимается.
Главного пункта в главном меню вообще нет. Там пусто. (установка Joomla чистая, ниче не делал).
Пробую создать пункт в меню - выбираю категорию, даю название, нажимаю сохранить - выкидывает в менеждер главного меня где опять по-прежнему пусто.
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Бляха муха. Перезагрузил виндовз и все заработало!
Однако пункты в меню никакие не добавляются.
« Последнее редактирование: 17.02.2010, 09:18:56 от Oleg56 »
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Памагите кто-нибудь!
Не создаются пункты меню в 1.5 Joomla
А в 1.0 пункты создаются, но в них не отображаются статьи.
*

Oleg56

  • Осваиваюсь на форуме
  • 25
  • 0 / 0
Ошибки которые показываются в главном меню на сайте:
Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in Z:\home\konfis\www\libraries\joomla\cache\handler\callback.php on line 99

Ошибки которые показываются в разделе главного меню в админке:
Warning: Parameter 4 to JHTMLMenu::treerecurse() expected to be a reference, value given in Z:\home\konfis\www\libraries\joomla\html\html.php on line 87

Warning: array_slice() expects parameter 1 to be array, null given in Z:\home\konfis\www\administrator\components\com_menus\models\list.php on line 143

Warning: Invalid argument supplied for foreach() in Z:\home\konfis\www\administrator\components\com_menus\models\list.php on line 147

Warning: Invalid argument supplied for foreach() in Z:\home\konfis\www\administrator\components\com_menus\views\list\view.php on line 65
*

Plumbum77

  • Новичок
  • 4
  • 0 / 0
Ошибки которые показываются в главном меню на сайте:
Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in Z:\home\konfis\www\libraries\joomla\cache\handler\callback.php on line 99

Ошибки которые показываются в разделе главного меню в админке:
Warning: Parameter 4 to JHTMLMenu::treerecurse() expected to be a reference, value given in Z:\home\konfis\www\libraries\joomla\html\html.php on line 87

Warning: array_slice() expects parameter 1 to be array, null given in Z:\home\konfis\www\administrator\components\com_menus\models\list.php on line 143

Warning: Invalid argument supplied for foreach() in Z:\home\konfis\www\administrator\components\com_menus\models\list.php on line 147

Warning: Invalid argument supplied for foreach() in Z:\home\konfis\www\administrator\components\com_menus\views\list\view.php on line 65


такая же петрушка, плюс к этому отображается на самом сайте эта ошибка в пунктах меню... Что делать!


Разобрался, оказывается обновить надо было. Обновление тут  http://joomlapro.ru/component/attachments/download/359
« Последнее редактирование: 12.03.2010, 17:12:09 от Plumbum77 »
*

zogg

  • Новичок
  • 13
  • 0 / 0
Поставил час рядом чистую ту же версию (что и использовал) - так там тоже не отображаются статьи. Причем уже заранее установленные с галочками публикации на главной.
P.S. Просто заново делать сайт неохота.

Столкнулся с такой проблемой на работающем сайте - всё перерыл, ночь практически не спал..
Проблема оказалась в совместимости Joomla и версии PHP на сервере. После обновления до 5.3 статьи перестали отображаться.
Решение нашлось:
Открываем /includes/Cache/Lite/Function.php и в строке 74 меняем:
Код
$arguments = func_get_args();
на
Код
$arguments = func_get_args();
$numargs = func_num_args();
for($i=1; $i < $numargs; $i++){
$arguments[$i] = &$arguments[$i];
}

У меня всё заработало :)

Брат, спасибо.
Похоже провайдер тоже "пошутил" с переходом на новую версию PHP и пропало отображение всего контента. Твоя рекомендация очень сильно помогла.
Еще раз спасибо.
*

oliksun

  • Новичок
  • 17
  • 0 / 0
и у меня такая же ерунда.. проблема в том, что у меня не 1.0. версия... а новая. в октябре 2010 качала.. новее не было.. сейчас там еще что-то появилось...
так я уже опасаюсь у меня там Vurtuemart ... если заново опять что-то устанавливать - опять все эти настройки... и товары загружать.
не сказать, что мне очень нужны статьи.. но вообще-то элементарно доставка - условия работы.. несколько статей опубликовать..
все ихх стандартно создавала, а их нет.. того, файла , про который пишут, у меня нет.. видимо из-за разницы в версиях.
PHP проверила. была младше 5.3. версии... поставила 5.3... вылезло несколько ошибок тут же.. вернула на версию 5.2.
 !
может мне кто-нибудь помочь с этими статьями ? чтоб они отображалисьна сайте.
готова к материальному вознаграждению, понимаю, что всем хочется подарков ))
*

Flatson

  • Новичок
  • 1
  • 0 / 0
Столкнулся с такой проблемой на работающем сайте - всё перерыл, ночь практически не спал..
Проблема оказалась в совместимости Joomla и версии PHP на сервере. После обновления до 5.3 статьи перестали отображаться.
Решение нашлось:
Открываем /includes/Cache/Lite/Function.php и в строке 74 меняем:

Зарегистрировался на форуме только для того, чтобы сказать СПАСИБО за предложенное решение. Три бессонные ночи, три дня у монитора с выпученными глазами, четверо суток нерабочего сайта... всё это закончилось на данном сообщении. СПАСИБО!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Восстановление пункта меню админки в Joomla 1.0.15

Автор Vicom

Ответов: 0
Просмотров: 2765
Последний ответ 15.07.2017, 11:36:04
от Vicom
Как убрать цикличиские ссылки Joomla 1.0?

Автор p4o1

Ответов: 3
Просмотров: 1678
Последний ответ 12.03.2016, 11:18:40
от SeBun
сколько стоит обновить Joomla 1 на Joomla 3* нужна помощь

Автор zvi

Ответов: 10
Просмотров: 1957
Последний ответ 16.02.2016, 11:12:47
от zvi
Миграция с Joomla 1.0.x на Joomla 1.5.x (mtwmigrator)

Автор spot

Ответов: 358
Просмотров: 220239
Последний ответ 30.04.2015, 01:55:48
от Aleks_El_Dia
Joomla и TopServer 2.1

Автор frimen

Ответов: 3
Просмотров: 8734
Последний ответ 25.02.2015, 20:28:30
от m1