0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 2342 Просмотров
*

Joomlist

  • Новичок
  • 10
  • 0 / 0
Баннеры не работают
« : 13.03.2010, 10:31:50 »
Здравствуйте!

Столкнулся с неожиданным сюрпризом от баннеров:
при клике на них отправляют не на адрес внесенный в Click URL в настройках баннера, а по адресу сайт/index.php/component/banners/click/11.html и появляется пустая страница с сообщением "HTTP 500 внутренняя ошибка сервера".

либо "Fatal error: Call to a member function click() on a non-object in C:\xampp\htdocs\joomla\components\com_banners\controller.php on line 35"
если запускать на локальном сервере

При этом все остальное работает нормально.

Как включить баннеры?
*

VovaAtom

  • Новичок
  • 14
  • 3 / 0
  • Киииборги ... они ... запаланили всю планету!
Re: Баннеры не работают
« Ответ #1 : 02.06.2010, 15:04:18 »
Такая же проблема!
Народ, помогайте  !

Обнаружилось внезапно, ничего не добавлял и не изменял на сайте.

Симптом: при клике на баннер происходит переход по ссылке вида <url сайта>/component/banners/click/41 , но при этом открывается главная страница сайта. И так с любой страницы сайта. Баннер закачан в images/banners, задан URL, в окошке Код баннера: ничего нет. Вобщем как обычно и причем раньше (1-2 месяца назад) все работало.
Так же было замечено, что счетчик кликов по баннеру ничего не считает! Создал новый баннер и покликал по нему - рузультат 0 - 0.00% Нажатий

Пробовал:
1. Обновил J1.5.14 до J1.5.18 - без результатно
2. Залить в components/com_banners и modules/mod_banners то же содержимое, но из дистрибутива J1.5.18 - не помогло
3. Очистить все таблицы в БД, касающиеся баннеров и, удалив все модули баннеров , группы, клиенты и тд из админки, создать все заново и опубликовать - не помогло
4. Загрузить сайт без .htaccess и с дефаултным .htaccess - не помогло

Может это лом?  :o

ПС. Забыл добавить. На этом же хостинге, есть еще два сайта на Joomla, но там баннеры работают отлично и подобных симптомов нет.
« Последнее редактирование: 02.06.2010, 15:08:54 от VovaAtom »
*

Aventurier

  • Захожу иногда
  • 129
  • 16 / 0
Re: Баннеры не работают
« Ответ #2 : 30.11.2012, 19:30:22 »
Пишу ответ, конечно, поздно, но надеюсь поможет кому-то, кто мучался как я в поисках ответа на проблему. Если у вас включен компонент Artio JoomSEF - проблема может быть в нем. Найдите там раздел Manage SEF URLs и поищиите, нет ли ссылок, которые заканчиваются просто на banners или на banners/ и перепишите их со своим окончанием.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не работают кнопки сохранить\применить

Автор dizpers

Ответов: 15
Просмотров: 13241
Последний ответ 10.03.2015, 08:11:07
от karlant
Баннеры не отображаются в модуле mod_banners на хосте.

Автор Roman Petrenko

Ответов: 19
Просмотров: 10496
Последний ответ 31.01.2015, 16:15:02
от drema71
Как поставить баннеры горизонтально в пределах одного блока?

Автор game2r

Ответов: 1
Просмотров: 2167
Последний ответ 10.05.2014, 15:58:07
от darkghost
Не работают кнопки админки Joomla.

Автор Mopsusha

Ответов: 11
Просмотров: 5983
Последний ответ 03.12.2012, 19:14:16
от skinny
Сайт в Google Chrome глючит. Другие сайты работают без проблем.

Автор Adrian1111

Ответов: 4
Просмотров: 1171
Последний ответ 28.11.2012, 11:32:22
от Adrian1111