0 Пользователей и 1 Гость просматривают эту тему.
  • 9 Ответов
  • 5589 Просмотров
*

vallpower

  • Новичок
  • 4
  • 0
Icetheme Automag. Проблема.
« : 02.04.2010, 21:09:55 »
Уважаемые форумчане.

После установки шаблона от IceTheme - Automag появляется следующая ошибка при заходе на сайт:

Warning: IcemodMainMenuHelper::require_once(/home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/legacy.php) [icemodmainmenuhelper.require-once]: failed to open stream: No such file or directory in /home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/helper.php on line 139

Fatal error: IcemodMainMenuHelper::require_once() [function.require]: Failed opening required '/home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/legacy.php' (include_path='.') in /home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/helper.php on line 139


Дело в том, что файла Legacy.php  в искомой папке вообще нет ни в одном из 3 скачанных архивах шаблона.
Что только не перепробовал, все ответы которые нашел в сети - ничего не помогает.

Может кто сможет помочь?
Заранее спасибо.
*

dolgik

  • Захожу иногда
  • 15
  • 1
Re: Icetheme Automag. Проблема.
« Ответ #1 : 18.05.2010, 22:59:57 »
Уважаемые форумчане.

После установки шаблона от IceTheme - Automag появляется следующая ошибка при заходе на сайт:

Warning: IcemodMainMenuHelper::require_once(/home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/legacy.php) [icemodmainmenuhelper.require-once]: failed to open stream: No such file or directory in /home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/helper.php on line 139

Fatal error: IcemodMainMenuHelper::require_once() [function.require]: Failed opening required '/home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/legacy.php' (include_path='.') in /home/autoukr/data/www/avtochasti.com.ua/templates/it_automag/html/mod_mainmenu/helper.php on line 139


Дело в том, что файла Legacy.php  в искомой папке вообще нет ни в одном из 3 скачанных архивах шаблона.
Что только не перепробовал, все ответы которые нашел в сети - ничего не помогает.

Может кто сможет помочь?
Заранее спасибо.


у меня тоже самое , проблему пока не решил
но у меня у друга работает.
подозреваю, что возможно слишком длинный путь к файлам. Завтра проверю
« Последнее редактирование: 18.05.2010, 23:03:45 от dolgik »
*

dolgik

  • Захожу иногда
  • 15
  • 1
Re: Icetheme Automag. Проблема.
« Ответ #2 : 19.05.2010, 16:15:24 »
 Узнал у знакомого ,  у него все работает на хостинге, на локалке он даже не пробовал.
*

dolgik

  • Захожу иногда
  • 15
  • 1
Re: Icetheme Automag. Проблема.
« Ответ #3 : 19.05.2010, 17:02:05 »
Нашел решение!
Joomla 1.5.17 (думаю не критично), но обязательно устанавливать без демо-данных(критично). И все заработало!
*

maddock

  • Новичок
  • 6
  • 0
Re: Icetheme Automag. Проблема.
« Ответ #4 : 17.11.2010, 10:37:38 »
все на самом деле проще, можно сделать чтоб работало и на последних версиях Joomla. при распаковке шаблона пройдитесь с поиском по каталогам на наличие файла legacy.php он не помню где засел но он есть и копируйте его в templates/it_automag/html/mod_mainmenu/legacy.php
*

Gann

  • Новичок
  • 9
  • 0
Re: Icetheme Automag. Проблема.
« Ответ #5 : 21.11.2010, 14:52:10 »
Здравствуйте. Может знает кто. Я установила шаблон от Ice Theme. И при попытке его вывести пишут Fatal error: Call to undefined function mb_ereg() in Z:\home\localhost\www\TheStore2\templates\it_thestore2\html\mod_mainmenu\helper.php on line 298. Отключаю мод Mainmenu- страница загружается, но без меню разумеется. Что мне делать? Сама я ничего не понимаю в этих закорючках, помогите пожалуйста[img]:-)
*

MisterR.

  • Захожу иногда
  • 21
  • 0
Re: Icetheme Automag. Проблема.
« Ответ #6 : 10.02.2011, 22:46:29 »
все на самом деле проще, можно сделать чтоб работало и на последних версиях Joomla. при распаковке шаблона пройдитесь с поиском по каталогам на наличие файла legacy.php он не помню где засел но он есть и копируйте его в templates/it_automag/html/mod_mainmenu/legacy.php

Скопировал из папки moduls и все заработало:)
*

Loh

  • Осваиваюсь на форуме
  • 91
  • 0
Re: Icetheme Automag. Проблема.
« Ответ #7 : 23.08.2012, 22:12:37 »
Нашел файл Legacy.php вставил в нужную папку, как здесь описано, и получил новую ошибку:

Fatal error: Cannot redeclare class plgSystemLegacy in Z:\home\...\www\templates\it_automag\html\mod_mainmenu\legacy.php on line 403

Эта строчка пустая, только фигурная скобка }

Подскажите как исправить, пожалуйста.
*

AlterEgo

  • Осваиваюсь на форуме
  • 171
  • 66
Re: Icetheme Automag. Проблема.
« Ответ #8 : 24.08.2012, 19:22:46 »
1. В настройках меню, выберите стиль меню "список(list)". Использование данного стиля не предусматривает подключение файла legacy.php.
2. Если не помогло, то включить системный плагин "Система - Поддержка старых расширений (Legacy)".
3. Проверить обновления шаблона. На форуме Icetheme поднималась данная тема.
*

tiraz

  • Осваиваюсь на форуме
  • 60
  • 1
  • Правильное тиражирование CD DVD
Re: Icetheme Automag. Проблема
« Ответ #9 : 24.04.2017, 13:23:38 »
Добавлю в версии Joomla 3
Файл на денвере подключался через require_once "/modules/slideshow.php"); и работал слайдер как положено
На хостинге не отображался, в логах ошибка PHP Fatal error: require_once
Подключил как посоветовали серез: require(dirname(__FILE__)."/modules/slideshow.php");
Заработало! Всем спасибо.
Дизайн + Joomla
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема при переносе Joomla на xampp

Автор sbabaev

Ответов: 6
Просмотров: 5355
Последний ответ 28.07.2017, 09:06:10
от pro100skill
[Решено] Проблема с авторизацией Invalid Token

Автор treX

Ответов: 99
Просмотров: 64252
Последний ответ 15.05.2017, 01:31:27
от k0st1k
Вопрос при переходе на https/ Проблема с внутренними ссылками

Автор krot

Ответов: 3
Просмотров: 243
Последний ответ 24.01.2017, 21:51:19
от ProtectYourSite
Проблема с модулем simpleform2 - ошибка AJAX error

Автор Larisa

Ответов: 27
Просмотров: 8173
Последний ответ 22.11.2016, 14:59:44
от DemoNF
Проблема с кодировкой utf-8

Автор Battlemouse

Ответов: 2
Просмотров: 648
Последний ответ 17.05.2016, 12:22:04
от sergant055