0 Пользователей и 1 Гость просматривают эту тему.
  • 25 Ответов
  • 3552 Просмотров
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
при попытке регистрации сайт выдает "Сначала Вам необходимо авторизоваться"
вход уже зарегистрированных пользователей возможен.
Функции "забыли пароль" и "забыли логин" работают.
не работает тока регистрация.

joomla 1.5.20
стандартный плагин и модуль Joomla

сайт http://www.top100on-line.ru/
« Последнее редактирование: 03.08.2010, 00:54:46 от 4webspot »
*

iluho

  • Давно я тут
  • 605
  • 50 / 4
  • Гламурный КабанчеГ
попробуйте удалить модуль регистрации и установить его заново
Милый и порядочный! Верьте мне во всем!
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
попробуйте удалить модуль регистрации и установить его заново
пробовал не помогает. ставил даже сторонние модули и плагины ничего не работает.
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
перезалил папки  из 1.5.9 сом юзер,
теперь после попытки зарегатся если еще раз нажать кнопку регистрация в выкинувшемся поле то вылетет форма регистрации. короче я так понял что он вместо регистрации вход выполняет почему то
*

jem777

  • Завсегдатай
  • 1632
  • 118 / 2
Если на сайте используется модуль для вставки php-кода типа mod_php или custom_code - попробуйте отключить и проверить.
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
перезалил папки  из 1.5.9 сом юзер,
теперь после попытки зарегатся если еще раз нажать кнопку регистрация в выкинувшемся поле то вылетет форма регистрации. короче я так понял что он вместо регистрации вход выполняет почему то

этот шаг тольго усугубит поиск ошибок, т.к. версия 1.5.9 дырява как сыр. верните родную папку 20-ки на место, включите в админке на Максимум доклад ошибок и проверьте, не будут ли в ответ на попытки регистрации выскакивать какие-либо предупреждения или ошибки. если да, сообщите их нам здесь.
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
усе вернул на места. в логах ошибок ничего нет.  вместо вывода формы регистрации он тупо пытается войти на сайт.
*

Lex

  • Завсегдатай
  • 1615
  • 274 / 1
В шаблоне каталог HTML/mod_login/ есть?
Жизнь заставила учиться.
В личке на вопросы не отвечаю.
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
Если на сайте используется модуль для вставки php-кода типа mod_php или custom_code - попробуйте отключить и проверить.
на сайте есть mod_php отключил все модули. проверил не работает регистрация, или нужно совсем удалить этот модуль? у меня он используется совместно со вставкой в  материал.
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
В шаблоне каталог HTML/mod_login/ есть?
шаблон  go_vista там такого каталога нет. там нет даже каталога HTML, есть такие: CSS, images, js, но на 1.5.9 все нормально работало на этом шаблоне.
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
все работает
не знаю как у вас а у меня при нажатии на надпись в модуле зарегистрироваться выдает "Сначала Вам необходимо авторизоваться"
ссылка которую вы даете форму выкидывает но почему то надпись зарегистрироваться не туда перекидывает нас. а сюда
http://www.top100on-line.ru/index.php?option=com_user&view=login&return=aHR0cDovL3d3dy50b3AxMDBvbi1saW5lLnJ1L3BvbHpvdmF0ZWwvMi5odG1s
*

Lex

  • Завсегдатай
  • 1615
  • 274 / 1
Тогда открывай modules\mod_login\tmpl\default.php и выкладывай строки с 64 по 69
Жизнь заставила учиться.
В личке на вопросы не отвечаю.
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
строки с 64 по 69 modules\mod_login\tmpl\default.php
Код
	if ($usersConfig->get('allowUserRegistration')) : ?>
<li>
<a href="<?php echo JRoute::_( 'index.php?option=com_user&view=register' ); ?>">
<?php echo JText::_('REGISTER'); ?></a>
</li>
<?php endif; ?>
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
вот я думаю а не JoomSEF  у меня глючит так??
а то у меня в логе эррор
вот эта строка почти везде
Код
www.top100on-line.ru [Mon Aug 02 20:36:43 2010] [error] [client 89.223.24.140] PHP Notice:  Array to string conversion in /home/t/top100onli/public_html/components/com_sef/joomsef.php on line 62
*

SmokerMan

  • Гуру
  • 5293
  • 719 / 26
вот я думаю а не JoomSEF  у меня глючит так??
а то у меня в логе эррор
вот эта строка почти везде
это SEF.
А насчет того либо в шаблоне лежит этот default.php. Либо есть пункт меню ведущий на регистрацию и у него права стоят "только для авторизованных"
*

Lex

  • Завсегдатай
  • 1615
  • 274 / 1
провидец?  :o
Дак ясен пень. Осталось выяснить почему в коде ссылка правильная, а на сайте нет.
Попробуй
<?php echo JText::_('REGISTER'); ?>
Сделать так
<?php /*echo JText::_('REGISTER');*/ ?>

Жизнь заставила учиться.
В личке на вопросы не отвечаю.
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
это SEF.
А насчет того либо в шаблоне лежит этот default.php. Либо есть пункт меню ведущий на регистрацию и у него права стоят "только для авторизованных"
можно поподробнее как это исправить? а то я тупо удалю SEF и заново его поставлю.
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
возможно корень проблемы в Вашем SEF-беспорядке. некоторые ссылки заHTML-ены, некоторые выходят как .php, а ссылка на регистрацию вообще не заSEF-ена. странная архитектура.

кроме того, у Вас явно установлен мост для работы с отдельно стоящим форумом. возможно он и конфликтует с 20-кой.

я бы рекомендовал откатиться назад к конфигурации, которую Вы работали до обновления, установить копию сайта в тестовую поддиректорию и там протестировать обновление.
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
Дак ясен пень. Осталось выяснить почему в коде ссылка правильная, а на сайте нет.
Попробуй
<?php echo JText::_('REGISTER'); ?>
Сделать так
<?php /*echo JText::_('REGISTER');*/ ?>



пропала ссылка "зарегистрироваться"
*

Lex

  • Завсегдатай
  • 1615
  • 274 / 1
Во теперь видно, что модуль выводится именно этим default.php. Значит скорее всего SEF.
Верни код обратно.
Жизнь заставила учиться.
В личке на вопросы не отвечаю.
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
вернул код обратно.
блин неохота так обратно откатывать и тестить, но если уж... надо то....
может нафиг SEF удалить и поставить  заново ....
*

Lex

  • Завсегдатай
  • 1615
  • 274 / 1
Ну о JoomSEF я понятия не имею. Посмотри в нем. Ссылку index.php?option=com_user=&view=register он почему-то преобразует
в http://www.top100on-line.ru/polzovatel/2.html. А это как я понимаю ссылка на профиль пользователя.
Жизнь заставила учиться.
В личке на вопросы не отвечаю.
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
да проблема была в AtrioJoomSEF  удалил его сразу все заработало. сейчас попробую найти новую версию AtrioJoomSEF и нормально его настроить.
*

lok

  • Захожу иногда
  • 60
  • 1 / 0
Огромное ВАМ спасибо. сам бы фиг нашел ошибку.  *DRINK*
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не воспроизводится видео на сайте

Автор VPN

Ответов: 0
Просмотров: 273
Последний ответ 06.04.2018, 10:15:11
от VPN
Ошибка после восстановления сайта из резервной копии

Автор Роман1974

Ответов: 9
Просмотров: 6033
Последний ответ 18.05.2017, 15:15:40
от Igoritaly
[Решено] Как обновить Joomla 1.5 (версии, способы обновления и т.д.)

Автор Danka

Ответов: 45
Просмотров: 183276
Последний ответ 06.04.2017, 12:14:12
от SeBun
Роблемы после ручного обновления сайта

Автор dron

Ответов: 4
Просмотров: 506
Последний ответ 12.03.2017, 15:02:20
от dron
Искаженные ссылки на сайте

Автор maxo127

Ответов: 4
Просмотров: 791
Последний ответ 19.12.2016, 19:34:42
от maxo127