Новости Joomla

Вышли релизы безопасности Joomla 6.1.4 и Joomla 5.4.9

Релиз безопасности Joomla 6.1.4 и Joomla 5.4.9

Проект Joomla! рад сообщить о выходе Joomla 6.1.4 и Joomla 5.4.9. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 2389 Просмотров

Устанавливаю компонент (Resources), назначаю одно из полей - picture - Используется как при просмотре списка материалов, так и внутри материала. Некоторое время все ок - закачиваются изображения, создаются уменьшенные и все отображается. Потом - (!) никаких настроек не менялось (!) - БАЦ - изображения перестают отображаться, а при добавлении новой записи или когда я в старые хочу добавить изображение - возникает ошибка 403 - couldn't upload thr file. Права на папки куда закачиваются фотки - 0777, ftp в глобальных настройках есть.
Такая штука возникает не впервые. В первый раз пришлось сносить компонент, все плагины, все таблицы из MySQL, потом установить компонент заново - помогло. Через полсуток (15 записей) - снова та же фигня. Подскажите, как можно решить. Очень нужно! !
*

Peter09

  • Захожу иногда
  • 103
  • 8 / 0
файлы могут не зкачиваться по нескольким причинам:
- ошибка в коде, проверил в нескольких наших тестовых проектах, описанной вами проблемы нет.
- недостаточно места на диске, т.е. предел доступного диского просторанства достигнут.
- недостаточно прав и PHP скриптов для закачки файлов на сервер.

исчезают картинки: если не изменились настройки сервера (уменьшено количество опертивной помяти доступной для PHP, к примеру) или картинки были перенесены в дургую папку, или изменили Secure Directory в конфигурации Resources.

Без просмотра конкретного проекта с проблемой достаточно сложно выявить причину. Не забывайте, что вы всегда можете обратится в тех. поддержку на сайте mightyextensions.com
там вы можете оставить доступ к проекту для более детальной проверки.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

ошибка после переноса с денвера на хостинг

Автор july84

Ответов: 8
Просмотров: 7752
Последний ответ 21.06.2013, 12:05:38
от cex263
Ошибка при синхронизации/установке: MightyExtensions WebService Response Error: Get feed content Rec

Автор Pompej

Ответов: 4
Просмотров: 3004
Последний ответ 20.09.2011, 12:31:09
от SanyaBerkut
Ошибка mavikThumbnails

Автор Shadow

Ответов: 2
Просмотров: 3105
Последний ответ 02.08.2011, 12:12:04
от Shadow
ошибка (неработают флоплеер и h1ghl1gh JS

Автор Havchik

Ответов: 5
Просмотров: 3480
Последний ответ 20.05.2011, 14:08:13
от Mighty
Поле "Picture"

Автор herr

Ответов: 7
Просмотров: 3191
Последний ответ 04.05.2011, 23:25:30
от herr