0 Пользователей и 1 Гость просматривают эту тему.
  • 11 Ответов
  • 5467 Просмотров

Поставил на сайт swmenufree3.0. Классный компанент. Одно но, в Опере (пробывал разные версии): не работает submenu. Т.е. при наведении на определённый пункт в менюшке должна выезжать субменюшка (т.е. подпункты меню)... В IE, Mozila - всё работает нормально - подменю выезжает, а в Оpere не работает.
Вот посмотрите: http://mobile-files.by/index.php
запустите сайт сначало в IE а потом в Опере и посмотрите менюшку (вертикальные аранжевые кнопки).
*

one_more

  • Захожу иногда
  • 139
  • 87 / 3
  • there is no spoon
Re: swmenufree3.0: в Опере не работает submenu
« Ответ #1 : 25.03.2006, 23:14:11 »
http://joomlaforum.ru/index.php/topic,910.msg4542.html#msg4542
А вообще-то, Вам лучше обратиться сюда и громка потопать ногами :)
« Последнее редактирование: 25.03.2006, 23:16:36 от lamer »
Errare humanum est

Re: swmenufree3.0: в Опере не работает submenu
« Ответ #2 : 26.03.2006, 05:00:24 »
Решение проблеммы я там так и не нашёл... :(
Не хочется ничего передеывать, в смысле сносить компанент swmenu. Он так классно лёг... Тем более другого подходящего я не нашёл (мне нужен, такой, что бы использовать графику в меню).

А то что я в Оперу обращусь - на это никто не прореагирует
*

one_more

  • Захожу иногда
  • 139
  • 87 / 3
  • there is no spoon
Re: swmenufree3.0: в Опере не работает submenu
« Ответ #3 : 26.03.2006, 10:45:16 »
Решение проблемы в том, чтобы написать свой браузер, который будет адекватно работать с javascript и назвать его "Опера" :) Боюсь только, владельцы "бренда" такого рвения не одобрят.
Короче: это проблема БРАУЗЕРА и "настройка" меню тут мало что изменит. Разве что, userxp нас порадует своим DHTML меню, нормально работающим и в Опере в том числе.
Если у него, конечно, энтузизизма хватит :)
Errare humanum est
*

userxp

  • Живу я здесь
  • 2019
  • 403 / 6
  • Злой и ужасный бармалей
Re: swmenufree3.0: в Опере не работает submenu
« Ответ #4 : 26.03.2006, 12:08:22 »
Разве что, userxp нас порадует своим DHTML меню, нормально работающим и в Опере в том числе.
Если у него, конечно, энтузизизма хватит
хм..., спасибо, что напомнил.
Как правильно задавать вопрос службе технической поддержки  yes!
SGA CM 7.2.0 RC0 KANG Build GWK74 + s95allinonescript + CWM 5.0.2.6 + Modem XWKT3

Re: swmenufree3.0: в Опере не работает submenu
« Ответ #5 : 26.03.2006, 16:10:47 »
userxp, а что вы собираетесь разработать новое меню?
*

userxp

  • Живу я здесь
  • 2019
  • 403 / 6
  • Злой и ужасный бармалей
Re: swmenufree3.0: в Опере не работает submenu
« Ответ #6 : 26.03.2006, 16:34:04 »
а его нечего разрабатывать - оно есть.
но есть и проблемы.
особенно с оперой :(
Как правильно задавать вопрос службе технической поддержки  yes!
SGA CM 7.2.0 RC0 KANG Build GWK74 + s95allinonescript + CWM 5.0.2.6 + Modem XWKT3

Re: swmenufree3.0: в Опере не работает submenu
« Ответ #7 : 26.03.2006, 19:29:09 »
а, ну тогда, не пойдёт...
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: swmenufree3.0: в Опере не работает submenu
« Ответ #8 : 14.07.2006, 12:49:17 »
Ситуация такая:

Joomla 1.0.10
SWMenuFree 3.7
Opera 9

В Опере не работает нормально субменю и вообще почти не чего не работает. Всё это можно было отнести на то, что Опера не умеет нормально работать с Java Script, но если в Опере в настройках поставить: «Представляться Интернет Эксплорером», то работает почти всё, кроме прозрачности менюшек. Возможно в коде SWMenuFree 3.7, где-то есть запрос к браузеру, типа если ты Опера, то у нас тут нет ни каких выпадающих меню и так далее, а если Эксплорер, то вот тебе вся красота. Может кто знает, где и что подправить?
*

PREMIER

  • Захожу иногда
  • 164
  • 5 / 0
  • Самое важное — это мир во всём мире!
Re: swmenufree3.0: в Опере не работает submenu
« Ответ #9 : 15.07.2006, 02:51:35 »
Сам немного поковырялся, что-то не нашёл, ну чего не кто не знает? А замена SWmenu есть, чтобы можно было бы сделать тоже самое или даже больше.
*

a3market

  • Осваиваюсь на форуме
  • 17
  • 0 / 0
Re: swmenufree3.0: в Опере не работает submenu
« Ответ #10 : 21.01.2010, 16:06:56 »
решение проблемы не нашлось? прошло уже 3 года, неужели ничего?

Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Некорректно работает увеличение изображения в Mobilejoomla

Автор SVOLOCH

Ответов: 13
Просмотров: 548
Последний ответ 10.10.2018, 21:38:48
от SVOLOCH
Extra News Plugin не корректно работает в Joomla 3.7.5

Автор kosopuzik

Ответов: 0
Просмотров: 576
Последний ответ 15.09.2017, 23:13:13
от kosopuzik
Akeeba после перехода на https не работает

Автор saifa

Ответов: 3
Просмотров: 666
Последний ответ 25.05.2017, 19:50:54
от Septdir
JEvents: не работает плагин загрузки изображений, удалается iframe

Автор Kumelis

Ответов: 0
Просмотров: 674
Последний ответ 24.12.2016, 00:43:41
от Kumelis
Не работает $session->set()

Автор shurakana

Ответов: 6
Просмотров: 684
Последний ответ 22.11.2016, 02:11:51
от shurakana