Крупнейшая биржа рекламы в Телеграм
0 Пользователей и 1 Гость просматривают эту тему.
  • 23 Ответов
  • 7058 Просмотров
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Устанавливаю VirtueMart 1.1.3 на Joomla 1.5.
Установка вручную, потом автоматически все модули и плагины.
Когда пытаюсь просмотреть шаблон, выдает ошибку

Warning: require_once(/administrator/components/com_virtuemart/global.php) [function.require-once]: failed to open stream: No such file or directory in S:\home\oriflame\www\components\com_virtuemart\virtuemart_parser.php on line 74

Fatal error: require_once() [function.require]: Failed opening required '/administrator/components/com_virtuemart/global.php' (include_path='.;/usr/local/php5/PEAR') in S:\home\oriflame\www\components\com_virtuemart\virtuemart_parser.php on line 74



С чем это может быть связано?


*

icom

  • Давно я тут
  • 822
  • 199 / 4
Re: Проблемы с VirtueMart после установки
« Ответ #1 : 21.01.2011, 20:37:49 »
откройте components\com_virtuemart\virtuemart_parser.php на строке 74 и вместо
require_once( ADMINPATH . 'global.php' );
вставьте
require_once( 'S:\home\oriflame\www\administrator\components\com_virtuemart\global.php' );

и лучше устанавливайте VirtueMart 1.1.6
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #2 : 21.01.2011, 20:48:33 »
Меняю на 1.1.6
Меняю на
require_once( 'S:\home\oriflame\www\administrator\components\com_virtuemart\global.php' );

теперь высвечивает


Warning: require_once(/administrator/components/com_virtuemart/classes/mainframe.class.php) [function.require-once]: failed to open stream: No such file or directory in S:\home\oriflame\www\administrator\components\com_virtuemart\global.php on line 37

Fatal error: require_once() [function.require]: Failed opening required '/administrator/components/com_virtuemart/classes/mainframe.class.php' (include_path='.;/usr/local/php5/PEAR') in S:\home\oriflame\www\administrator\components\com_virtuemart\global.php on line 37
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #3 : 21.01.2011, 21:02:00 »
Тадам!
Система понятна, придется редактировать вручную файл global.php(((
*

icom

  • Давно я тут
  • 822
  • 199 / 4
Re: Проблемы с VirtueMart после установки
« Ответ #4 : 21.01.2011, 21:08:51 »
да нет
откройте administrator\components\com_virtuemart\virtuemart.cfg.php и после
global $mosConfig_absolute_path,$mosConfig_live_site;
вставьте
$mosConfig_absolute_path = 'S:\home\oriflame\www';
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #5 : 21.01.2011, 21:14:02 »
в этой строке есть еще $mosConfig_secret;
с ним что делать?
*

icom

  • Давно я тут
  • 822
  • 199 / 4
Re: Проблемы с VirtueMart после установки
« Ответ #6 : 21.01.2011, 21:16:22 »
пусть будет
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #7 : 21.01.2011, 21:18:40 »

Parse error: syntax error, unexpected '=', expecting ',' or ';' in S:\home\oriflame\www\administrator\components\com_virtuemart\virtuemart.cfg.php on line 20
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #8 : 21.01.2011, 21:19:48 »
присваивать не хочет
*

icom

  • Давно я тут
  • 822
  • 199 / 4
Re: Проблемы с VirtueMart после установки
« Ответ #9 : 21.01.2011, 21:22:17 »
покажи строку 20
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #10 : 21.01.2011, 21:23:35 »
global $mosConfig_absolute_path = 'S:\home\oriflame\www', $mosConfig_secret ;
*

icom

  • Давно я тут
  • 822
  • 199 / 4
Re: Проблемы с VirtueMart после установки
« Ответ #11 : 21.01.2011, 21:26:27 »
да нет, после global ...неважно что сдесь...; и с новой строки
$mosConfig_absolute_path = 'S:\home\oriflame\www';
*

brown1990

  • Осваиваюсь на форуме
  • 11
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #12 : 21.01.2011, 21:30:28 »
Спасибущееееееее спасибо!


*

mailman

  • Новичок
  • 2
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #13 : 17.02.2011, 13:10:14 »
А у меня такая вот ошибка:

Warning: require_once(G:\home\sait\www\modules\mod_ice_vmcart/../components/com_virtuemart/virtuemart_parser.php) [function.require-once]: failed to open stream: No such file or directory in G:\home\sait\www\modules\mod_ice_vmcart\mod_ice_vmcart.php on line 22

Fatal error: require_once() [function.require]: Failed opening required 'G:\home\sait\www\modules\mod_ice_vmcart/../components/com_virtuemart/virtuemart_parser.php' (include_path='.;/usr/local/php5/PEAR') in G:\home\sait\www\modules\mod_ice_vmcart\mod_ice_vmcart.php on line 22

Может кто поможет? :)
*

mailman

  • Новичок
  • 2
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #14 : 17.02.2011, 13:11:28 »
шаблон IT TheStore 3
*

icom

  • Давно я тут
  • 822
  • 199 / 4
Re: Проблемы с VirtueMart после установки
« Ответ #15 : 17.02.2011, 16:10:04 »
у вас не установлен модуль ice_vmcart, после установки ошибка должна исчезнуть

Re: Проблемы с VirtueMart после установки
« Ответ #16 : 03.03.2011, 08:10:27 »
Здравствуйте! у меня такая проблемка. шаблон it_thestore3, VirtueMart 1.1.7, при его измененийй и установки галереи хочу перейти а он мне ошибку такого типа выдает

Warning: require_once(/administrator/components/com_virtuemart/global.php) [function.require-once]: failed to open stream: No such file or directory in B:\home\magaz\www\components\com_virtuemart\virtuemart_parser.php on line 74

Fatal error: require_once() [function.require]: Failed opening required '/administrator/components/com_virtuemart/global.php' (include_path='.;/usr/local/php5/PEAR') in B:\home\magaz\www\components\com_virtuemart\virtuemart_parser.php on line 74

что с ней делать уже не пойму.

Пробовал ставить как написано выше в php5 фаил не помогло. Делаю его в Денвере.

А когда отключаешь vm_cart все начинает работать. переходить в галерею и тд..
« Последнее редактирование: 03.03.2011, 08:53:49 от galant »
*

pyh

  • Захожу иногда
  • 117
  • 11 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #17 : 21.04.2011, 17:19:32 »
j 1.5.21 шаблон it_healthcare, VirtueMart 1.1.8

ставлю вирт, набиваю несколько товаров - все ок
вспоминаю про модуль :) устанавливаю, включаю -

Код
Warning: require_once(/administrator/components/com_virtuemart/global.php) [function.require-once]: failed to open stream: No such file or directory in /home/u92/a/components/com_virtuemart/virtuemart_parser.php on line 74

Fatal error: require_once() [function.require]: Failed opening required '/administrator/components/com_virtuemart/global.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/u92/a/components/com_virtuemart/virtuemart_parser.php on line 74

перепробовал все приведенные выше способы - не помогает.

без модулей все работает нормально, только включаю какой-то модуль все.

шо с этим делать ?
*

pyh

  • Захожу иногда
  • 117
  • 11 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #18 : 21.04.2011, 17:24:41 »
В вопросе заключался ответ - конфликт с модулем mod_ice_menu

у кого шаблоны от IT пробуйте отключать модули
*

lara77775

  • Новичок
  • 6
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #19 : 17.12.2011, 20:25:31 »
Тадам!
Система понятна, придется редактировать вручную файл global.php(((

все решилось включение плагина Legacy   , воспользовалась советом  http://www.jeromeesperanza.com/web-development/web-developer-blog-articles/39-joomla-web-developer-and-development-articles/47-virtuemart-error-componentscomvirtuemartvirtuemartparserphp-on-line-74
*

Meteor

  • Новичок
  • 1
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #20 : 24.02.2012, 18:42:30 »
Так же включил плагин Legacy и все заработало.
« Последнее редактирование: 24.02.2012, 19:00:30 от Meteor »
*

Larsrpg

  • Новичок
  • 1
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #21 : 26.08.2013, 10:42:00 »
Подскажите У меня вот такая ситуация возникла после копирования сайта!
Warning: require_once(ADMINPATHglobal.php) [function.require-once]: failed to open stream: No such file or directory in /home/elitdver/public_html/components/com_virtuemart/virtuemart_parser.php on line 76

Fatal error: require_once() [function.require]: Failed opening required 'ADMINPATHglobal.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/elitdver/public_html/components/com_virtuemart/virtuemart_parser.php on line 76
*

kowcheg

  • Новичок
  • 2
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #22 : 26.08.2013, 10:48:43 »
друзья помогите  я установил VirtueMart 1.1.3 на Joomla 1.5. но у меня проблема в регистрации пользователей пишет ошибку 404 что делать ума не приложу уже сносил и устанавливал Joomla несколько раз а эффекта нет. Обращался на хостинг они говорят это не наша вина. Подскажите пожалуйста что делать!
*

kowcheg

  • Новичок
  • 2
  • 0 / 0
Re: Проблемы с VirtueMart после установки
« Ответ #23 : 26.08.2013, 10:51:28 »
причем не работает именно регистрационная форма "виртуал марта" а Joomlaвская форма нормально регистрирует.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Количество просмотров товара VirtueMart Существует?

Автор grishin

Ответов: 38
Просмотров: 7131
Последний ответ 22.08.2020, 08:44:29
от rsn
Не выводит списком Настраиваемое поле в VirtueMart 5.0

Автор ЛюдмилаМир

Ответов: 2
Просмотров: 298
Последний ответ 25.08.2019, 16:27:04
от ЛюдмилаМир
Joomla VirtueMart помощь в переводе

Автор akkord31

Ответов: 0
Просмотров: 248
Последний ответ 21.05.2019, 09:14:02
от akkord31
Миграция с Joomla 1.5 на 3 с VirtueMart 1.1.9 stable на свежую. Кто поможет?

Автор Гриша-Десантник

Ответов: 7
Просмотров: 398
Последний ответ 23.04.2019, 10:22:25
от draff
Переход на https VirtueMart 1.1.4 проблемы с фото

Автор Sergey1984

Ответов: 4
Просмотров: 494
Последний ответ 25.10.2018, 20:56:54
от Sergey1984