0 Пользователей и 1 Гость просматривают эту тему.
  • 5 Ответов
  • 1129 Просмотров
*

Шама

  • Новичок
  • 6
  • 0 / 0
Обращаюсь к Богам веб строительства >:(
Проблема в следующем. Залила на хостинг сайт. Все естественно в кодировке UTF-8. Но ситуация усложняется тем, что админка на русском, а сайт на французском. Обычные буквы из кирилицы и латиницы я вижу, а вот вместо é и à, ну и подобных им ?. Пока у меня мыслей нет, сижу в тупняке, что делать не соображу:(
*

Mihanja80

  • Завсегдатай
  • 1918
  • 167 / 4
  • Всю жизнь учусь...
а французская локализация установлена? А что показывает когда на русском все и когда на французском?
Посмотрите в базе данных кодировку всех таблиц. Посмотрите в базе данных, вполне вероятно что уже в базе данных у Вас все в знаках вопроса...
Как делали импорт->экспорт базы данных, откройте дамп базы данных в блокноте и посмотрите, корректно ли там сохранены французские буквы. ;)

>Обращаюсь к Богам веб строительства
А бубен взяли?
Я с мобильного, в основном...
*

Шама

  • Новичок
  • 6
  • 0 / 0
Вот, про французскую локализацию я сейчас сижу и думаю, ее я не ставила.  Сделала все стандартно по привычке, мне и ни к чему было, что буквы там есть странные... На локалке все было в порядке. Читалось абсолютно все. Дамп уже был в UTF-8. Выставила  сопоставление UTF-8 general_ci.
И да в дампе уже ? :( Мозг закипел.... Выход то хоть есть какой-нибудь?
И я туплю, откуда бы мне взять файлик французской локализации?
*

Шама

  • Новичок
  • 6
  • 0 / 0
Добавила языковой пакет, выставила по умолчанию сайт на френче. Вопросы никуда не исчезли...
*

Mihanja80

  • Завсегдатай
  • 1918
  • 167 / 4
  • Всю жизнь учусь...
ну так если дамп криво сделали то уже никто и не поможет. Нужно дамп делать заново и сразу проверять кодировку, нет ли внутри знаков вопроса. Дамп делайте в архив *.zip
Я с мобильного, в основном...
*

Шама

  • Новичок
  • 6
  • 0 / 0
Спасибо! Сейчас перезалью, посмотрю чего получится. В конце концов, ночь впереди долгая. Поправлю в ручную:)))
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

проблема с установкой 1.5\1.7\2.5

Автор izya_ppp

Ответов: 12
Просмотров: 1741
Последний ответ 17.08.2017, 15:13:51
от dmitry_stas
Проблема! Переадресация при открытии страницы админки

Автор KiLLaTiV

Ответов: 8
Просмотров: 932
Последний ответ 14.03.2017, 09:22:17
от flyingspook
При переносе на новый сервер - проблема с относительными путями

Автор dum

Ответов: 1
Просмотров: 847
Последний ответ 20.08.2015, 14:53:23
от SeBun
Проблема при переносе сайта!

Автор geral

Ответов: 7
Просмотров: 4313
Последний ответ 03.01.2015, 22:55:22
от Silence
Проблема с сылками при переносе Joomla с одного локального ПК на другой

Автор mik-dandi

Ответов: 2
Просмотров: 832
Последний ответ 11.07.2014, 06:18:50
от mik-dandi