0 Пользователей и 1 Гость просматривают эту тему.
  • 17 Ответов
  • 5176 Просмотров
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Не нашел ответа на форуме и в FAQ, поэтому задаю свой вопрос в отдельном топике.
Была похожая тема о проблемах с русским текстом в заголовках, но у меня, судя по всему, другой случай.

Стоит Joomla 1.0.12 Lavra Edition.

Смотрю на страницы сайта в браузере - вроде-бы все нормально.
Открываю исходный код страницы, и вижу, что тело всех материалов (как обычных, так и статичных) прописано в виде ANSI-кодов символов вместо русских букв.

Что примечательно, заголовки прописаны нормальным текстом, а вот непосредственно само тело статей - в ANSI-кодах:
Код
<h3>Краткие новости</h3>
<table class="contentpaneopen">
<tr>
<td valign="top" colspan="2">
Joomla! 1.0 - '&#1048;&#1089;&#1087;&#1099;&#1090;&#1072;&#1081;&#1090;&#1077;
&#1089;&#1074;&#1086;&#1073;&#1086;&#1076;&#1091;'!. &#1045;&#1097;&#1077;
&#1085;&#1080;&#1082;&#1086;&#1075;&#1076;&#1072; &#1085;&#1077;
&#1073;&#1099;&#1083;&#1086; &#1089;&#1090;&#1086;&#1083;&#1100;
&#1087;&#1088;&#1086;&#1089;&#1090;&#1086;&#1075;&#1086;
&#1089;&#1087;&#1086;&#1089;&#1086;&#1073;&#1072;
&#1089;&#1086;&#1079;&#1076;&#1072;&#1090;&#1100;
...
</td>
</tr>
</table>

При этом в хедере страницы четко прописано:
Код
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251" />

В итоге страница весит гораздо больше, чем ей положено, да и вообще неправильно это как-то с любой точки зрения. Неизвестно, как на такой текст реагируют поисковики...

Сначала подумал, что, быть может, какие-то проблемы с выбранным мной шаблоном...
Поставил шаблон по-умолчанию (rhuk_solarflare_ii) - проблемы остались...

А теперь, уважаемые знатоки, вопрос :)
Как это исправить и заставить текст отображаться в обычной кирилице windows-1251 ?
Заранее благодарю за ответ.
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
А база данных в какой кодировке?
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
Дык "вроде как..." или точно :) . Ещё проверьте в базе кодировку таблицы jos_content и каждого из столбцов в ней. Это можно сделать с помощью phpMyAdmin, если хостер его предоставляет.
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Прилагаю к этому посту скрин с phpMyAdmin.
Если я все правильно понимаю, там везде выставлена кодировка win-1251.

[вложение удалено Администратором]
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Да, еще одно уточнение - все это происходит на Денвере. В сеть пока не выкладывал.
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
Так. А на закладке "Обзор" содержание таблицы читаемо? Особенно в поле "fulltext"?

И ещё, посмотрите на главной странице phpMyAdmin значения параметров: "MySQL-кодировка:" и "Сопоставление соединения с MySQL"? Должны быть "cp1251".

Так же проверьте значения системных параметров MySQL (Ссылка на главной странице phpMyAdmin). Там и у "значений сессии" и у "Глобальных значений" должно быть одно и то же значение:
character set client       cp1251
character set connection    cp1251
character set database    cp1251    
character set results    cp1251    
character set server    cp1251    
character set system    utf8    
character sets dir    \usr\local\mysql4/share/charsets
collation connection    cp1251_general_ci    
collation database    cp1251_general_ci    
collation server    cp1251_general_ci    

init connect       set names cp1251 
« Последнее редактирование: 10.08.2007, 18:31:47 от Greycat »
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Так. А на закладке "Обзор" содержание таблицы читаемо? Особенно в поле "fulltext"?

Да, на закладке "Обзор" во всех полях (title, title_alias, introtext, fulltext) - нормальный русский текст.
При нажатии на "Правку" любого из полей в поле редактирования также вижу нормальный русский текст.

Цитировать
И ещё, посмотрите на главной странице phpMyAdmin значения параметров: "MySQL-кодировка:" и "Сопоставление соединения с MySQL"?

MySQL-кодировка:  Windows Cyrillic (cp1251)
Сопоставление соединения с MySQL: cp1251_general_ci
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Так же проверьте значения системных параметров MySQL (Ссылка на главной странице phpMyAdmin). Там и у "значений сессии" и у "Глобальных значений" должно быть одно и то же значение:
character set client       cp1251
character set connection    cp1251
character set database    cp1251    
character set results    cp1251    
character set server    cp1251    
character set system    utf8    
character sets dir    \usr\local\mysql4/share/charsets
collation connection    cp1251_general_ci    
collation database    cp1251_general_ci    
collation server    cp1251_general_ci    

init connect       set names cp1251

В обоих столбцах напротив каждого из параметров именно те значения, которые Вы указали.
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Да уж, шайтан...
Ладно, буду потихоньку доделывать сайт, выложу в сеть - может, проблема исчезнет сама собой...
Пока буду доделывать - может еще кто-то что-то подскажет...

Greycat - в любом случае, большое спасибо за помощь!
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
Как вариант - поставьте XAMPP, перелейте туда базу и сайт. Может поможет... Удачи.
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
ОК, спасибо за совет.
Наверное, не буду экспериментировать с XAMPP-ом, Денвер меня в принципе устраивает, и никаких проблем до этого вроде не было...
Буду пробовать уже у хостера.
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Вот, наткнулся в топике про WysiwygPro:
Сейчас уже вышла WP 2.2.11 под Joomla 1.0.11, нет ли ее случаем?

У меня с 10-м WP почему-то в режиме просмотра HTML-кода страницы не отображаются русские символы у content-item'ов, вместо них вот такое #1089;#1077;#1085;#1090;#1103;#1073;#1088;#1103;, только там еще символ & перед # (&#...), если его поставить, то в броузере будет воспроизводиться слово 'сентября'. А в HTML - коде именно такая числовая последовательность (похоже на юникод) вместо привычных русских букв. Как это исправить не знаю, приходится пока отключать в конфиге wysiwygpro (с NO Wysiwyg Editor и с Tiny MCE такого не происходит).
Может кто сталкивался с подобной фичей и поделится советом, как это побороть ?

У меня тоже установлен WysiwygPro, но по умолчанию стоит редактор CodePress.
Отключил WysiwygPro вообще в мамботах, открываю текст в CodePress и пересохраняю его заново, чищу кэш, перезагружаю страницу - никакого эффекта, все то же самое...

Хотя, можно было сразу догадаться, что дело не в редакторе - ведь в базе данных нормальный текст...

Эх, не знаю на что и думать...
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
А попробуйте развернуть на том же Денвере другой сайт, заново. Из того же дистрибутива. если с ним будет всё ОК, значит дело не в сервере. Для верности базу создайте не автоматически, а предварительно вручную, что бы уж точно в cp1251 была.
« Последнее редактирование: 10.08.2007, 21:28:02 от Greycat »
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
*

ZHart

  • Захожу иногда
  • 332
  • 53 / 2
Создать базу предварительно вручную - это как?
Самостоятельно забить все поля и их значения?

P.S.: Прошу прощения за глупые вопросы, но работать с базами данных я пока умею только на очень примитивном уровне. Учусь :)
*

BigGun

  • Новичок
  • 15
  • 15 / 0
У меня эта хрень вылечилась вот так :

стоит Joomla Lavra Ed 1.0.12 + WysWygPro 2.2.10

в настройках мамбота WysiwygPro поменяй пункт "Escape Special Characters" с On на Off

мне помогло.
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
Создать базу предварительно вручную - это как?
Самостоятельно забить все поля и их значения?

Пардон, пропустил ответ. Создать вручную - означает, что нужно до запуска инсталлятора зайти в PhpMyAdmin и создать новую, пустую базу данных с помощью его инструментов. При этом нужно убедиться, что в поле кодировки выбрано "cp1251_general_ci". После этого можно устанавливать «Joomla!» как обычно, указав в соответствующем шаге заранее созданную базу данных.

[вложение удалено Администратором]
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Непонятный код ошибки DB function failed, не знаю что делать?

Автор Valiks

Ответов: 4
Просмотров: 2281
Последний ответ 28.09.2011, 14:39:45
от Valiks
Возможно ли в Joomla отображать материалы всех категорий одного раздела

Автор proparket

Ответов: 3
Просмотров: 9097
Последний ответ 16.06.2010, 21:42:12
от mgm
Поменять порядок title на всех страницах кроме главной

Автор gustav210

Ответов: 1
Просмотров: 2672
Последний ответ 03.05.2010, 12:22:50
от Vit
Количество материалов в категории. Как изменить и настроить?

Автор kasatik

Ответов: 4
Просмотров: 7861
Последний ответ 19.10.2008, 22:24:20
от smart
Не на всех страницах появляется меню

Автор Olegs

Ответов: 2
Просмотров: 2042
Последний ответ 03.09.2008, 18:48:55
от Olegs