PhocaGallery и Joomla 1.7 - решение проблемы с выкидыванием из админки

  • 18 Ответов
  • 14416 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

konservator

  • Осваиваюсь на форуме
  • ***
  • 63
  • 13
При выделении категории или изображений в админке галереи и нажатии кнопок управления (удалить, опубликовать, снять с публикации), компонент разлогинивает администратора, после чего приходится заново осуществлять вход. При этом пропадает верхнее меню и панель управления. Необходимо снова выходить из админки и заново входить!
Однако, дело не в компоненте или сырости Joomla - это перевод кривой у новых версий.

Нужно поправить /administrator/language/ru-RU/ru-RU.com_phocagallery.ini , поскольку отечественные товарищи упустили '%d' в выражениях типа:
COM_PHOCAGALLERY_N_ITEMS_DELETED="% элементов успешно удалено"
т.е. к знаку процента нужно еще букву 'd' приписать!


http://www.filedude.com/download/IKac8bcAsV79016f2a76  Исправленный файл русификации.

Спойлер
[свернуть]
« Последнее редактирование: 20.12.2011, 17:16:46 от konservator »

*

stalkervp

  • Осваиваюсь на форуме
  • ***
  • 44
  • 3

*

sheel

  • Новичок
  • *
  • 3
  • 0
konservator, спасибо Вам огромное. так замучила эта проблема,  не знала где искать решение
 :D

( к сожалению, не могу поменять Вам карму)

*

Raposo

  • Захожу иногда
  • **
  • 14
  • 1
У меня описаная проблема в Joomla 1.6 (галерея 3.0.0 RC4) и мне предложенное решение не помогло:(
Но это ещё пол-беды. Кроме всего у меня миниатюры перестали генерироваться и не могу удалить некоторые категории >:(
Пошёл искать не решал ли кто эти проблемы...

*

darkangel

  • Осваиваюсь на форуме
  • ***
  • 71
  • 2
Тоже долго ломал голову над этой проблемой.
Спасибо konservator-у за решение!

Так как ссылка на архив из первого поста погибла, кому нужно, перезалил исправленный вариант: http://ifolder.ru/29780072
Умное лицо - еще не признак ума! Все глупости на Земле делаются именно с этим выражением лица!

*

Roamer

  • Осваиваюсь на форуме
  • ***
  • 155
  • 3
странно... а мне не помогло... Скачал файл, установил. Как выбрасывало из админки, так и выбрасывает. Мало того, я в админку вообще войти не могу, пока Куки не удалю. В чем может быть проблема?

*

Roamer

  • Осваиваюсь на форуме
  • ***
  • 155
  • 3
darkangel вот ты пошутил! Выложил неисправленный файл! Прикрепляю к сообщению - добавил "d" к знаку процента.

[вложение удалено Администратором]

*

SatMan

  • Осваиваюсь на форуме
  • ***
  • 47
  • 0
странно... а мне не помогло... Скачал файл, установил. Как выбрасывало из админки, так и выбрасывает. Мало того, я в админку вообще войти не могу, пока Куки не удалю. В чем может быть проблема?

После замены файла надо в базе очистить таблицу jos_session. Префикс у тебя может быть другой, отличный от jos.

*

darkangel

  • Осваиваюсь на форуме
  • ***
  • 71
  • 2
darkangel вот ты пошутил! Выложил неисправленный файл! Прикрепляю к сообщению - добавил "d" к знаку процента.
Вероятно, это вы у себя там пошутили. Только что специально скачал архив со своей ссылки - все исправлено! Внимательно меняйие файлы! Не получается обычным установщиком, замените вручную.
По поводу удаления куков и входа в админку - проблема именно в этих файлах!
Удачи!
Умное лицо - еще не признак ума! Все глупости на Земле делаются именно с этим выражением лица!

*

Hot_Gomer

  • Давно я тут
  • ****
  • 296
  • 12
  • sudo su
Та же проблема с PhocaDownload - при удалении файла выкидывает из админки, но это не самое ужасное - ужасно то что при попытки войти повторно в админку выкидывает с ошибкой: У вас нет доступа к панели управления сайтом.
приходится чистить куки.
Joomla, Drupal, Ruby on Rails -
что может быть лучше?)

*

zvezdolet

  • Новичок
  • *
  • 1
  • 0
Спасибо konservator-у за решение!
Эта проблема меня просто достала, но теперь всё ок! Из админки не выкидывает и куки не чищу. У меня сайт на Joomla 2.5.4 я просто сохранил файл русификации компонента со своего сайта из папки /administrator/language/ru-RU/ru-RU.com_phocagallery.ini, добавил после знака % букву d в нужных местах, сохранил и закачал файл на место. В итоге всё работает! 

*

alekshavan

  • Осваиваюсь на форуме
  • ***
  • 48
  • 0
Был такой же глюк пришлось немного покапать так как где то в системе все равно был глюк. Но когда от бекапил сайт и по новому установил PhocaGallery исправленный Кг пакет, все норм работает всем спасибо друзья.

*

alekshavan

  • Осваиваюсь на форуме
  • ***
  • 48
  • 0
Объявилась такая же проблема с PhocaDownload кто может сказать где надо ставить   после знака % букву d в каких строчках Помогите пЛИЗ сайт уже на хосте

*

alekshavan

  • Осваиваюсь на форуме
  • ***
  • 48
  • 0
Объявилась такая же проблема с PhocaDownload кто может сказать где надо ставить   после знака % букву d в каких строчках Помогите пЛИЗ сайт уже на хосте
Проблема решена сделал все так же как и   PhocaGallery /administrator/language/ru-RU/ru-RU.com_phocagallery.ini  пролистать этот файл и найти  % добавить букву "d" чтоб получилось %d На всякий случай просмотрите корневой языковой файл /ваш сайт/language/ точно не помню там есть это или нет

*

Danlin

  • Захожу иногда
  • **
  • 17
  • 0
День добрый, все попробовала (из выше описанного) ничего не помогает((( нажимаю сохранить пишет: Fatal error: Allowed memory size of 52428800 bytes exhausted (tried to allocate 17280 bytes) in /home/kapelka/kapelka-sad.ru/docs/administrator/components/com_phocagallery/libraries/phocagallery/image/imagemagic.php on line 214
сайт уже на сервере(((
Все разобралась) две картинки не были облегчены)) спасибо!
« Последнее редактирование: 02.07.2012, 17:53:28 от Danlin »

*

polaris777

  • Захожу иногда
  • **
  • 14
  • 1
В украинской локализации та же проблема. Изменил файл uk-UA.com_phocagallery.ini - и все заработало! Спасибо!

*

Romanych

  • Осваиваюсь на форуме
  • ***
  • 97
  • 3
Также столкнулся с проблемой вылета с админки. очень прошу выложить "правильные" файлы русской а также украинской локализации. С меня плюс !

*

zavolgie

  • Новичок
  • *
  • 1
  • 0
Очевидно  недостаточно заменить в соответствующих местах % на %d .
В некоторых случаях все равно глючит.
Необходимо в других местах, например, <<COM_PHOCAGALLERY_ERROR_DELETE_CONTAIN_CAT="Категория(и): '%' не может быть удалена(ы)....... >>, заменить % на %s (именно s)
А в некоторых << COM_PHOCAGALLERY_GENERATING_FROM_THUMBNAIL_S="Создание %1$ из %2$ с миниатюрой(ми)">> заменить %1$ , %2$ соответственно на %1$s , %2$s
Короче я рассматривал англ. вариант и всё, что связанно со знаком % повторил в русск.варианте.
Вроде работает. Удачи.
« Последнее редактирование: 21.02.2014, 22:27:39 от zavolgie »

*

Benefactor

  • Осваиваюсь на форуме
  • ***
  • 157
  • 0
Спасибо большое! Проблема решена! Я что-то не могу понять, как такое знатное упущение до сих пор не решено на уровне разработчиков?
Системы гарантированного электроснабжения под ключ