Новости Joomla

Вышли релизы безопасности Joomla 6.1.4 и Joomla 5.4.9

Релиз безопасности Joomla 6.1.4 и Joomla 5.4.9

Проект Joomla! рад сообщить о выходе Joomla 6.1.4 и Joomla 5.4.9. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 1587 Просмотров
*

ArniXXX

  • Новичок
  • 4
  • 0 / 0
Всем день добрый, читал все темы и даже эту http://joomlaforum.ru/index.php/topic,178109.0.html

1. Сайт после переноса.
2. Веб сервер nginx, php 5.3.10. (Пробовал вариант Aapche + mod php).
3. Версия Joomla 1.5.25.
4. Модуль ЧПУ родной.
5. Вывод ошибок включен всеми вариантами.

Ошибка возникает в компоненте com_content. Проследил аж до класса class JView extends JObject. Метод .

Главная страница ,и вывод списка статей работает нормально. Но при переходе на саму страницу, получаем белый лист.

Спойлер
[свернуть]

Суть в том, что вызов этого метода останавливает полностью выполнение скрипта, вызов происходит из com_content не на прямую но, после return скрипт дальше не выполняется однозначно. Ни одной ошибки не выпадает вообще.

Очень прошу помочь разобраться.
« Последнее редактирование: 29.02.2012, 15:13:46 от ArniXXX »
*

ArniXXX

  • Новичок
  • 4
  • 0 / 0
Создал новую статью, и она открылась нормально, получается вопрос в том как привести в чувства остальные? Подскажите пожалуйста :)
*

ArniXXX

  • Новичок
  • 4
  • 0 / 0
Собственно говоря вопрос решил.

athena, вы писали мне в личку. Но у меня нет прав пользоваться лс.

Content - Artilce Suggestions,
Content - Joomla Extra News Plugin,
Content - MultiAds,
JoomLine VK Like,
Content - JoomSlide,
Content - Highslide,

Это список плагинов которые я отключил, и страница открылась. Который из них делал пакости не знаю, потому что включил обратно, а оно все равно работает.

UPD: причина установлена окончательно. Content - Joomla Extra News Plugin  - это был мой случай.

« Последнее редактирование: 03.03.2012, 00:09:52 от ArniXXX »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

simpleform2 ошибка ajax error в Google chrome

Автор safronoff343

Ответов: 1
Просмотров: 4915
Последний ответ 05.06.2020, 20:36:42
от safronoff343
Не работает страница XML выдает ошибку: This page contains the following errors

Автор vitaliywolf

Ответов: 20
Просмотров: 31721
Последний ответ 07.05.2020, 22:24:16
от sivers
Ошибка #1050 при переносе базы данных на хостинг

Автор Ksen

Ответов: 7
Просмотров: 29342
Последний ответ 16.03.2020, 17:47:29
от Petrovich
При попытке войти в админку 404 ошибка компонента

Автор omezik

Ответов: 4
Просмотров: 8815
Последний ответ 31.08.2019, 22:41:46
от Taatshi
Ошибка в компоненте CKForms

Автор Vas80

Ответов: 9
Просмотров: 4067
Последний ответ 22.04.2019, 13:34:48
от sivers