Крупнейшая биржа рекламы в Телеграм
0 Пользователей и 1 Гость просматривают эту тему.
  • 20 Ответов
  • 1555 Просмотров
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
Нужна ваша помощь...
Не могу разобраться почему при генерировании "Карты сайта" в XML
выдает ошибку:
This page contains the following errors:
error on line 1 at column 8: XML declaration allowed only at the start of the document
Below is a rendering of the page up to the first error.

Увидеть эту ошибку можно по ссылке:
https://cool-shop.com.ua/index.php?option=com_xmap&sitemap=1&view=xml

А вот PHP версия карты сайта нормально открывается:
https://cool-shop.com.ua/index.php?option=com_xmap&sitemap=1

На одном из форумов ранее говорилось, что может быть проблема из-за "пробела" в начале кода страницы...
Вот о чем я имею введу скидываю ссылку на скрин:
https://pastenow.ru/8VAIV
Но я не пойму как его убрать от туда, уже все перепробовал все равно пробел в начале кода страницы остается...

В чем может быть проблема подскажите пожалуйста? Как ее можно решить что бы работала XML страница?
*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
Код
<?xml

такая строка должна быть одна. у вас их почему-то две.
пробелов быть не должнл. перед формированием XML дайте команду:
Код
ob_clean();
для очистки всего, что успело вывестись (пробелы в вашем случае).
На связи в телеге @sivers
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
Код
<?xml

такая строка должна быть одна. у вас их почему-то две.
пробелов быть не должнл. перед формированием XML дайте команду:
Код
ob_clean();
для очистки всего, что успело вывестись (пробелы в вашем случае).


Эм... можно поподробней пожалуйста... куда именно я должен дать команду " ob_clean(); " ?

Саму генерацию делает компонент Xmap
*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
Саму генерацию делает компонент Xmap
Вот в него и попробуйте. Как во всех компонентах - скопируйте макет вывода в свой шаблон и подправьте
components/com_xmap/views/xml/tmpl/default_xsl.php
Чтоб проверить - можно и без копирования. Но потом при обновлении изменения будут затерты.
Чистить надо до первого полезного вывода данных. Т.е. в этом макете перед строчкой:
Код
echo '<?xml version="1.0" encoding="UTF-8"?>',"\n";
добавьте ob_clean();
На связи в телеге @sivers
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
У меня к сожалению на Joomla 1.5.28 с версией ХМap 1.2.14
нет такого пути... components/com_xmap/views/xml/tmpl/default_xsl.php
Скорей всего у вас версия 2.5 и выше...

У меня есть вот такие файлы:
https://pastenow.ru/8W6GU (ссылка на скриншот)

*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
Тогда Xmap.xml.php смотрите. У меня этого компонента нет - скачивал, чтоб посмотреть. Но выбрал под 3-ю, не досмотрел, что вопрос для Joomla 1.5
На связи в телеге @sivers
*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
К слову, у вас и на обычных страницах сайта есть лишние пробелы перед первым тегом. Проверьте основной шаблон (индекс шаблона) сайта - чаще всего это оттуда.
На связи в телеге @sivers
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
Я так и подумал что надо смотреть в файле Xmap.xml.php
Вчера добавил: $ob_clean();
перед:
        echo '<?xml version="1.0" encoding="UTF-8"?>',"\n";

после чего ошибка поменялась на вот такую:

This page contains the following errors:
error on line 1 at column 3: Extra content at the end of the document
Below is a rendering of the page up to the first error.
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
index.php Шаблон проверил в начале вроде нету пробелов:
вот скрин начала кода:
https://pastenow.ru/8WC1T
*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
index.php Шаблон проверил в начале вроде нету пробелов:
вот скрин начала кода:
да, тут все ок. значит какой-то плагин или модуль их делает. вывод ошибок включен? если отключить/включить, то все так же?
На связи в телеге @sivers
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
да, тут все ок. значит какой-то плагин или модуль их делает. вывод ошибок включен? если отключить/включить, то все так же?

Если включить отладку, то все страницы включая админку на белом фоне и с такой надписью:

Информация о профиле
Application afterLoad: 0.004 seconds, 0.31 MB
Application afterInitialise: 0.077 seconds, 1.66 MB
Application afterRoute: 0.416 seconds, 2.30 MB
Application afterDispatch: 3.278 seconds, 5.13 MB
Application afterRender: 3.731 seconds, 7.12 MB
Использование памяти
7499376

Пришлось через configuration.php - убирать включение отладки.
*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
Надо не отладку, а "максимальный"
На связи в телеге @sivers
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
Из корня сайта покажите
Ссылка на index.php из корня сайта:
https://cool-shop.com.ua/index.rar
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
Надо не отладку, а "максимальный"

На Joomla 1.5 такого нету как "максимальный"

Есть просто:
Отладка системы    Нет   Да
Отладка локализации    Нет   Да
*

draff

  • Живу я здесь
  • 4990
  • 347 / 7
Замените index.php на файл из архива Joomla 1.5 и проверьте .
Что вы там на подключали и для кого .
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
скачал Joomla 1.5.28 и заменил корневой index.php
на вид вроде ничего не изменилось.
Ошибка осталась прежней...
*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
Ищите проблемный плагин.

Как вариант - дописать в своем плагине костыль, который будет удалять начальные пробелы перед выводом страницы.
На связи в телеге @sivers
*

draff

  • Живу я здесь
  • 4990
  • 347 / 7
Ошибка осталась прежней
Ищите вирус/шелл в файлах сайта, судя по  index.php из корня сайта
*

vitaliywolf

  • Захожу иногда
  • 92
  • 0 / 1
Ищите вирус/шелл в файлах сайта, судя по  index.php из корня сайта
До всего этого вирусы ранее были... И вроде как успешно были удалены с помощью антивирусника imunifyAV через CPanel хостера.
*

sivers

  • Завсегдатай
  • 1521
  • 209 / 0
До всего этого вирусы ранее были... И вроде как успешно были удалены с помощью антивирусника imunifyAV через CPanel хостера.
С этого надо было начинать. Значит где-то мусор остался.
На связи в телеге @sivers
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Криво работает сайт и админ часть

Автор Odyssey

Ответов: 11
Просмотров: 666
Последний ответ 10.02.2019, 06:13:39
от Odyssey
не работает главная без index.php

Автор Mary Poppins

Ответов: 11
Просмотров: 6763
Последний ответ 11.12.2018, 18:28:30
от all_zer
не работает стандартный поиск Joomla 1.5.23

Автор Andrew1110

Ответов: 34
Просмотров: 11511
Последний ответ 11.02.2018, 10:31:42
от altvvc
НЕ работает панель в адинке

Автор Alex102

Ответов: 0
Просмотров: 628
Последний ответ 03.12.2017, 23:26:06
от Alex102
Не работает Reply-To

Автор tolian_27

Ответов: 1
Просмотров: 876
Последний ответ 18.02.2017, 01:51:11
от altvvc