Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 6 Ответов
  • 2538 Просмотров
*

Pepelr

  • Новичок
  • 9
  • 0 / 0

Подскажите в чем может быть беда?
PHP Version 5.2.17
Joomla! 1.7.2 Stable
Заранее спасибо.
*

nixsystem

  • Захожу иногда
  • 207
  • 10 / 0
Проблема в том что при добавлении в базу возникает дублирование ID о чем говорит строчка  "Suplicate entry "0" for key "PRIMARY""
Модуль com_advancedmodules пытается добавить в базу новую строку, с таким ID который уже есть в базе.
Выяснение причины почему модуль не проверяет какие ID уже использованы перед тем как записывать в базу - поможет решить проблему.
Копать в сторону com_advancedmodule.
*

Pepelr

  • Новичок
  • 9
  • 0 / 0
А это может быть из-за переноса сайта на другой хостинг?
И этот модуль com_advancedmodules - он стандартный? Или устанавливается отдельно?
*

nixsystem

  • Захожу иногда
  • 207
  • 10 / 0
В списке стандартных модулей Joomla 1.5 его нет точно. Насчет 1.7 - с уверенностью не скажу, не работал с ней.
По поводу того может ли это быть вызвано переходом на другой хостинг - теоретически может быть, возможно настройка на этом хостинге отличается от той что была на предыдущем, например настройки сопоставления таблиц. Более точно можно сказать только начав разбираться и докапываться что и к чему там.
*

Pepelr

  • Новичок
  • 9
  • 0 / 0
nixsystem, спасибо тебе большое!
Буду пробовать решить проблему...
*

oriol

  • Завсегдатай
  • 1042
  • 100 / 4
Цитировать
Требование
Расширенный менеджер модуль будет работать только правильно, если ваша установка соответствует следующим требованиям:
PHP 5.3 +
http://www.nonumber.nl/extensions/advancedmodulemanager#specs
*

Pepelr

  • Новичок
  • 9
  • 0 / 0
C помощью хостера, который в свою очередь отключил debug проблема была решена.
Всем спасибо!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как поменять основные цвета модуля

Автор aisedora21

Ответов: 7
Просмотров: 6671
Последний ответ 24.06.2021, 20:23:06
от Moysha
simpleform2 ошибка ajax error в Google chrome

Автор safronoff343

Ответов: 1
Просмотров: 4912
Последний ответ 05.06.2020, 20:36:42
от safronoff343
Не работает страница XML выдает ошибку: This page contains the following errors

Автор vitaliywolf

Ответов: 20
Просмотров: 30847
Последний ответ 07.05.2020, 22:24:16
от sivers
Ошибка #1050 при переносе базы данных на хостинг

Автор Ksen

Ответов: 7
Просмотров: 29332
Последний ответ 16.03.2020, 17:47:29
от Petrovich
При попытке войти в админку 404 ошибка компонента

Автор omezik

Ответов: 4
Просмотров: 8162
Последний ответ 31.08.2019, 22:41:46
от Taatshi