Основной курс по Joomla
0 Пользователей и 1 Гость просматривают эту тему.
  • 3 Ответов
  • 3252 Просмотров
*

worldmen

  • Осваиваюсь на форуме
  • ***
  • 138
  • 2
Установил готовый шаблон TheLodge (joomla 2.5) с уже гоавыми и установленными модулями.
Там уже есть слайд-шоу IceSlideShow. На моей локальной машине все работает хорошо (Денвер). Залил в интернет - все работает кроме слайд-шоу. А точнее не показывает сами картинки, а подписи к картинкам показывает. Т.е. что-то листает, но без картинок
Вот сайт argo-otel.com
Погуглил - находил, что путь к картинкам прописует не так как надо - добавляет домен и еще что-то. Порылся в фойлах, пока ничего не нашел.
*

worldmen

  • Осваиваюсь на форуме
  • ***
  • 138
  • 2
после написания нашел:
Идем в папку модуля и находим следующий файл:
/mod_iceslideshow/libs/groups/file/file.php
Где то в районе 37 строки вы должны увидеть следующий код:
Код
 $subbase = JURI::base(true);
И делаем замену:
Код
 $subbase = JURI::base(false);

Это удалит двойное упоминание домена в пути к изображению.
В результате работа модуля IceSlideShow должна восстановиться.
У меня получилось
*

worldmen

  • Осваиваюсь на форуме
  • ***
  • 138
  • 2
Опять проблемы с тем же слайдшоу. Был сбой, востановил из архивной копии. 
Не показываются картинки на сайте argo-otel.com
Ссылки на картинки стоят
.../images/sampledata/iceslideshow/image1.jpg а должно быть:
.../images/icethumbs/960x315/72/images/sampledata/iceslideshow/image1.jpg - вроде так.
т.е. не подставляется часть пути, если я прав(но картинки находились там)
--------
я тупо прописал пути к картинкам в /mod_iceslideshow/libs/groups/file/file.php
$path = 'images/icethumbs/960x315/72/images/sampledata/iceslideshow/';
« Последнее редактирование: 16.07.2012, 02:45:51 от worldmen »
*

resens

  • Осваиваюсь на форуме
  • ***
  • 78
  • -1
Спасибо тебе добрый человек! + тебе в репу)