0 Пользователей и 1 Гость просматривают эту тему.
  • 12 Ответов
  • 2495 Просмотров
*

Scorpionnn

  • Осваиваюсь на форуме
  • 27
  • 1 / 0
Доброго всем времени суток уважаемые джумловоды. Возник вопрос по настройке компонента CSVI версии 4.4
Как известно, CSVI умеет вгружать большие файлы частями дабы не нарваться на Bad Gateway ошибку... У компонента на этот счет есть две настройки - Lines per import и Time between imports (админка Joomla -> компоненты -> CSVI -> Settings -> Import settings). Проблема в том, что какие бы значения я не выставлял, настройки ну никак не хотят сохраняться. После нажатия на кнопочку Save настройки возвращаются в свое дефолтное состояние.
Подскажите как бороться с проблемой? Может где вручную в базе прописать эти параметры? Я так и не нашел :(

Заранее thx.
« Последнее редактирование: 04.12.2012, 11:37:33 от Scorpionnn »
*

capricorn

  • Завсегдатай
  • 1948
  • 118 / 3
Re: CSVI 4.4 - Проблема с настройками
« Ответ #1 : 01.12.2012, 12:11:46 »
Проверьте существование папок и права на на них (доступность на запись) в разделе About (это для версии 5, для 4 скорее всего все аналогично).

Если что-то отмечено красным - поменять права, либо создать папку вручную и установить права - обычно 755.

Все должно быть зеленым со статусом Writable.
*

Scorpionnn

  • Осваиваюсь на форуме
  • 27
  • 1 / 0
Re: CSVI 4.4 - Проблема с настройками
« Ответ #2 : 01.12.2012, 12:17:09 »
/docs/tmp    Writable      
/docs/tmp/com_csvi    Writable      
/docs/tmp/com_csvi/debug    Writable

Больше никакие папки не выводит.

Только не совсем понятно при чем тут эти папки? Это же темп. Вряд ли настройки будут храниться в темпе.
« Последнее редактирование: 01.12.2012, 12:22:43 от Scorpionnn »
*

capricorn

  • Завсегдатай
  • 1948
  • 118 / 3
Re: CSVI 4.4 - Проблема с настройками
« Ответ #3 : 01.12.2012, 13:09:01 »
Возможно не созданы все таблицы в БД.

Зайдите в админку как администратор, наберите в адресной строке http://Х/administrator/index.php?option=com_csvi&view=install, вместо Х подставив свой домен.

В появившемся окне нажмите - upgrade to 5.5.
*

capricorn

  • Завсегдатай
  • 1948
  • 118 / 3
Re: CSVI 4.4 - Проблема с настройками
« Ответ #4 : 01.12.2012, 13:30:29 »
В БД эти настройки хранятся в таблице ххххх_csvi_settings.

Должен выполняться запрос:

SELECT *
FROM `ххххх_csvi_settings`
LIMIT 0 , 30

Вместо ххххх подставьте свой префикс. Это для версии 5.5.
*

Scorpionnn

  • Осваиваюсь на форуме
  • 27
  • 1 / 0
Re: CSVI 4.4 - Проблема с настройками
« Ответ #5 : 01.12.2012, 14:34:25 »
На пятую обновиться не могу т.к. юзаю 4.4 free. Нажал обновить до 4.4 он подцепил какие-то файлы и написал что успешно обновлено. результат тот же.

В xxxxx_csvi_settings храниться только одна запись:
id    params
2    4.4
*

capricorn

  • Завсегдатай
  • 1948
  • 118 / 3
Re: CSVI 4.4 - Проблема с настройками
« Ответ #6 : 01.12.2012, 15:04:55 »
Нажмите тогда на Install. Сообщите, что получится после этого, будем дальше думать.
*

Scorpionnn

  • Осваиваюсь на форуме
  • 27
  • 1 / 0
Re: CSVI 4.4 - Проблема с настройками
« Ответ #7 : 01.12.2012, 15:09:41 »
То же самое остается. Я пробовал сносить и заново ставить даже.

P.S. Joomla 2.5.6, VirtueMart 2.0.12b
*

capricorn

  • Завсегдатай
  • 1948
  • 118 / 3
Re: CSVI 4.4 - Проблема с настройками
« Ответ #8 : 01.12.2012, 16:00:45 »
У вас почему-то нет второй строки c id=1 в таблице установок. В ней в поле params как раз и хранятся настройки. Примерно такие:

Код
{"import":{"import_nolines":"1000","import_wait":"5"},"site":{"hostname":"http:\/\/www.mydomain.ru"},"google_base":{"gb_title":"","gb_link":"","gb_description":""},"yandex":{"ya_name":"","ya_company":"","ya_link":"","ya_delivery_cost":"","ya_currency":"RUR","ya_currency_rate":"1","ya_currency_plus":"0"},"icecat":{"ice_username":"","ice_password":"","ice_advanced":"0","ice_lang":"INT","ice_index":"http:\/\/data.icecat.biz\/export\/freexml.int\/INT\/files.index.csv","ice_supplier":"http:\/\/data.icecat.biz\/export\/freexml.int\/INT\/supplier_mapping.xml"},"log":{"log_store":"1","log_max":"25","log_type":"all"},"debuglog":{"log_line_start":"1","log_line_end":"5"}}

Снесите еще раз компонент. Удалите вручную все таблицы csvi в базе. Проведите установку заново. В конце обязательно нажмите Install, введите имя домена. Должно получиться. Не получится - еще подумаем, посмотрим тогда записи из лога ошибок веб-сервера.
*

Scorpionnn

  • Осваиваюсь на форуме
  • 27
  • 1 / 0
Re: CSVI 4.4 - Проблема с настройками
« Ответ #9 : 04.12.2012, 11:36:07 »
Тупо вручную всавил запись в xxx_csvi_settings с id 1 и приведенным вами кодом через phpMyAdmin. Естессно поменял домен и нужные настройки. Теперь все подцепляется и сохраняются изменения через админку. Большое спасыбо. Вам +
*

capricorn

  • Завсегдатай
  • 1948
  • 118 / 3
RE: CSVI 4.4 - Проблема с настройками
« Ответ #10 : 04.12.2012, 12:52:28 »
Думаю, это подход неправильный - вручную вставлять.
Вы скорее всего после установки компонента не нажимаете на кнопку Install. Это обязательно нужно делать после того, как установщик Joomla установит компонент. Таким образом CSVI создает свои окончательные таблицы с данными.
Одну запись вы то вставили, но может есть и другие таблицы, где тоже что-то должно быть. Можете в дальнейшем столкнуться с другими проблемами.
Добейтесь нормальной установки компонента, чтобы потом не получилось так, что потеряете свои данные, когда окажется, что все равно нужно переустановить.
Почитайте форум CSVI и документацию.
*

Scorpionnn

  • Осваиваюсь на форуме
  • 27
  • 1 / 0
RE: CSVI 4.4 - Проблема с настройками
« Ответ #11 : 04.12.2012, 18:20:44 »
Дело в том, что все делал правильно, следуя инструкциям. И Install нажимал. Просто ну никак он не хотел создавать запись с настройками по какой-то причине. Сейчас уже проверил все на живом сайте. все работает. Вгружает по 500 строк, перерыв 5 секунд. Видимо компонент умеет только апдейтить запись настроек. Случай отсутствия таковой не предусмотрен. За данные не переживаю, есть бэкапы. Главное что сейчас все работает.
*

capricorn

  • Завсегдатай
  • 1948
  • 118 / 3
RE: CSVI 4.4 - Проблема с настройками
« Ответ #12 : 04.12.2012, 20:32:27 »
Возможно у вас на ПК стоит версия MySQL ниже 5-й. Попробуйте установить компонент на чистой Joomla 2.5 на хостинге.
Вот требования к нему.

CSVI 4.x

    PHP version 5.2 or higher
    MySQL version 5 or higher
    Apache 1.3 or higher
    Joomla 2.5 or higher
    GD 2.0 library if you want to automatic resize thumbnails
    Magic Quotes turned off

In case your system does not meet any of the requirements you will need to upgrade to the minimum version to be able to use CSVI.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

csvi Pro 7.3.0. Игнорирование существующих полей пи импорте товаров

Автор Viktor

Ответов: 2
Просмотров: 219
Последний ответ 13.12.2019, 22:44:43
от AlexB
CSVI импорт товаров - Ну никак.(РЕШЕНО!)

Автор vtrcmert

Ответов: 129
Просмотров: 42860
Последний ответ 13.09.2019, 16:05:21
от forlan
Импорт/экспорт данных через CSVI формат YML

Автор One

Ответов: 8
Просмотров: 2186
Последний ответ 26.07.2019, 16:23:19
от One
csvi pro как сделать экспорт multivariant полей в ввиде param name

Автор One

Ответов: 1
Просмотров: 286
Последний ответ 09.04.2019, 13:50:20
от khersonzmey
Ошибка импорта товаров через копмонент csvi

Автор TYMON

Ответов: 0
Просмотров: 494
Последний ответ 18.08.2018, 23:20:51
от TYMON