Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 9 Ответов
  • 7190 Просмотров
*

kogtehvost

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Помогите, пожалуйста, решить проблему!
При оформлении заказа с регистрацией зарегистрироваться не получается. Система намекает, что пользователь неправильно ввел капчу, хотя CAPTCHA при регистрации вообще не отображается. (первый скриншот)



Перебрасывает на страницу регистрации уже джумловской, сверху выдает сообщение "The words you typed did not match the ones displayed. Please try again." На странице джумловской регистрации уже отображается текст от CAPTCHA, но сама картинка - нет. (второй скриншот)



В настройках менеджера пользователей Joomla значение CAPTCHA стоит "По умолчанию", пробовал выбирать "ReCaptcha" и "Ни одного", чтобы вообще ее выключить при регистрации — эффект один и тот же: при регистрации капчу не видно, а ошибку эту выдает. Установка плагина "JoomShopping Captcha" тоже ничего не изменила.
Подскажите, пожалуйста, что мне с этим делать? Как заставить регистрацию работать либо без CAPTCHA, либо с капчей по человечески?
Joomla 3.0.2 + JoomShopping 4.3.0.1
Спасибо!
*

nevigen

  • Moderator
  • 10452
  • 863 / 25
  • http://n*****n.com
Joomla обновить, ЖШ тоже
шаблон дефолтный ЖШ ?
отключить капчу в настройках пользователей а не только в общих
Профессиональные / Бесплатные решения для JoomShopping
Не лечи бесплатно, ибо тот, кто лечится бесплатно, рано или поздно перестает ценить свое здоровье,
а тот, кто лечит бесплатно, рано или поздно перестает ценить результаты своего труда/ (с) Гиппократ?
Не ищите ответов, ищите решение !
*

dmitry_stas

  • Легенда
  • 13151
  • 1234 / 8
тот сервис реCAPTCHA, который используется в Joomla, перестал работать
Цитировать
отключить капчу в настройках пользователей а не только в общих
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

kogtehvost

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Проблема в том, что я не могу обновить ни Joomla, ни JoomShopping, иначе у меня слетит мой распрекрасный шаблон. Но вроде бы обе версии же достаточно стабильно должны работать, не смотря на то, что уже далеко не последние?
Выставил дефолтный шаблон JS и Beez в Joomla, включил в общих настройках и менеджере пользователей "ReCaptcha" - при регистрации ее по прежнему не видно, но сообщение выдает "Пустое значение CAPTCHA недопустимо."
Отключил капчу в общих и пользовательских настройках - после заполнения всех полей выдает и вовсе белый экран.
Хелп ми, пожалуйста!
*

nevigen

  • Moderator
  • 10452
  • 863 / 25
  • http://n*****n.com
сказано отключить рекапчу.
Профессиональные / Бесплатные решения для JoomShopping
Не лечи бесплатно, ибо тот, кто лечится бесплатно, рано или поздно перестает ценить свое здоровье,
а тот, кто лечит бесплатно, рано или поздно перестает ценить результаты своего труда/ (с) Гиппократ?
Не ищите ответов, ищите решение !
*

kogtehvost

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Я отключил ее в общих настройках, в настройках менеджера пользователей, плагин РеCAPTCHA снял с публикации. При регистрации, после заполнения полей и нажатия на кнопку "Регистрация" внизу — белый экран.
Хелп!
*

dmitry_stas

  • Легенда
  • 13151
  • 1234 / 8
включите показ ошибок в Joomla. по белому листу гадать еще хуже, чем по кофе
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

kogtehvost

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Мне стыдно, но не получается включить отображение ошибок! По прежнему вижу белый экран.
В админке в настройках сервера включил "Максимум" - ничего. Добавляю в .htaccess "php_value display_errors 1" - вообще сайт не открывается.
В шаблоне в самом верху прописал "php_value display_errors 1" - тоже ничего.
Хелп :(
*

ViktorMah

  • Захожу иногда
  • 252
  • 30 / 0
А, когда вносили изменения в файл .htaccess, не обратили внимание есть ли там ещё и такой файл error_log   ?
Обычно в нем записываются причины PHP Fatal error: и не только, что является отличной альтернативой php_value display_errors 1

П.С. - кто Вам сказал, что при обновлении Joomla у вас слетит шаблон?
хотя, если вы переделывали один из стандартных, возможно. но с этим можно бороться.
1- просто копируете папку шаблона на комп, спокойно обновляете Joomla.
2- а потом копируете папку шаблона с компа на сервер с заменой
« Последнее редактирование: 19.11.2013, 08:36:08 от ViktorMah »
*

kogtehvost

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Файлика error_log в корне не наблюдаю.
А Joomla я не могу обновить, так как использовал готовый шаблон, который версию 3.1 уже по какой-то причине не поддерживает. Как и последние версии JoomShopping. Полностью его переверстать нет возможности.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Ошибка при установке шаблона

Автор jimka

Ответов: 2
Просмотров: 2445
Последний ответ 23.08.2023, 15:22:52
от victorantoniak
Nevigen: Переадресация регистрации и авторизации на JoomShopping

Автор Satool

Ответов: 5
Просмотров: 1631
Последний ответ 19.07.2023, 14:21:48
от nevigen
Скидка без регистрации

Автор Simply

Ответов: 5
Просмотров: 1458
Последний ответ 04.04.2023, 23:52:47
от Simply
JoomShopping 5.1.1 ошибка Undefined constant "_JSHOP_ORDER_BY"

Автор webaster

Ответов: 6
Просмотров: 2109
Последний ответ 07.01.2023, 13:42:11
от kit2m2
Ошибка при правке данных клиента и попытке отправить письмо из заказа

Автор ecolora

Ответов: 40
Просмотров: 4327
Последний ответ 17.09.2022, 20:06:26
от marksetter