Нужна помощь с модулем

  • 7 Ответов
  • 1379 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

nikitkamakarov

  • Новичок
  • *
  • 4
  • 0
Нужна помощь с модулем
« : 16.10.2014, 14:47:39 »
Всем бодрого времени  суток!
Не знаю уже куда деваться. Весь интернет перерыл, но ничего подобного найти не смог.
Поэтому от отчаяния обращаюсь к вам.

Суть проблемы заключается в следующем.
Установил модуль NEWS PRO GK5, взятый с официального сайта GAVIKPRO. Там же я взял и шаблон gk_creativity.
Joomla показала, что модуль установился успешно! Но когда я открыл сам модуль, что его настройки увидел не очень приятную ситуацию.

Версия Joomla 3.3.0


Пробовал этот модуль для Joomla 2.5 и вроде очнулся. Но сайт после этого не загружается и выдаёт следующее:
Fatal error: Call to undefined method JUser::authorisedLevels() in /modules/mod_news_pro_gk5/data_sources/com_content/model.php on line 111
« Последнее редактирование: 16.10.2014, 17:51:51 от nikitkamakarov »

*

Taatshi

  • Support Team
  • *****
  • 4782
  • 452
Re: Нужна помощь с модулем
« Ответ #1 : 17.10.2014, 02:26:24 »
удалите. Поставьте тот, что подходит к версии движка.

в .htaccess добавьте строчку

AddDefaultCharset utf-8
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3  /  ОТЗЫВЫ 
Минимальная ставка за платные услуги 1000 рэ Связь: telegram - Taatshi, почта - Taatshi на яндексе.

*

zomby6888

  • Живу я здесь
  • ******
  • 1484
  • 167
Re: Нужна помощь с модулем
« Ответ #2 : 17.10.2014, 03:58:45 »
Если есть модуль для трешки то воспользуйтесь советом выше или можете попробовать заменить  JUser::authorisedLevels(); на JUser::getAuthorisedViewLevels(); на 111 строчке
интернет-блог: http://websiteprog.ru

*

nikitkamakarov

  • Новичок
  • *
  • 4
  • 0
Re: Нужна помощь с модулем
« Ответ #3 : 17.10.2014, 13:19:54 »
удалите. Поставьте тот, что подходит к версии движка.

в .htaccess добавьте строчку

AddDefaultCharset utf-8


Спасибо, большое! Текст стал читаемым. Но настроек модуля нету... БЕДА!

*

esazhin

  • Новичок
  • *
  • 1
  • 0
Re: Нужна помощь с модулем
« Ответ #4 : 03.05.2015, 23:35:38 »

Спасибо, большое! Текст стал читаемым. Но настроек модуля нету... БЕДА!
Я тоже очень долго мучался с этой проблемой. Нет настроек News Show Pro GK5 в админке. Перерыл весь рунет, но так и не нашел проблемы. Сейчас же проблему решил и специально зарегистрировался на форуме, чтобы поделиться решением.

Итак, для того, чтобы проблема исчезла заходим в файл /modules/mod_news_pro_gk5/mod_news_pro_gk5.xml
И после строки
Код
span.readonly { padding: 10px; font-family: Arial; font-size:13px !important; font-weight: normal !important; text-align: justify; color: #4d4d4d; line-height: 24px; }
добавляем следующие строки
Код
span.tooltip-content { display: none; }
.tip-text span.readonly { display: none; }
.tip-text span.tooltip-content { display: block; }
После этого в админке всё заработает  :D

*

artmaster

  • Осваиваюсь на форуме
  • ***
  • 36
  • 0
Re: Нужна помощь с модулем
« Ответ #5 : 10.10.2015, 20:09:54 »
блин вылезла такая же проблем .... совет выше не помог ...
Может знает кто ещё чего по этой проблеме


Изменил шаблон админки на другой  - заработало (но глючно!)

Проблему решил сменой браузера на Лису (в ней вся админка работает)
« Последнее редактирование: 10.10.2015, 21:10:37 от artmaster »

*

vipiusss

  • Профи
  • ********
  • 5513
  • 318
  • JoomlaNet
Re: Нужна помощь с модулем
« Ответ #6 : 10.10.2015, 22:05:49 »
хтесе меняйте, у вас там не оригинал
и права на папки, чтоб не лезло потом.
скачайте оригинал и замените.
Миграция, установка, обновление версий Joomla  |  Создание сайтов "под ключ"  |  Эксклюзивные заглушки "offline"  |  Работа с "напильником" над шаблонами и расширениями

*

Fleischwolf

  • Новичок
  • *
  • 1
  • 0
Re: Нужна помощь с модулем
« Ответ #7 : 15.11.2015, 16:13:39 »
блин вылезла такая же проблем .... совет выше не помог ...
Может знает кто ещё чего по этой проблеме
Изменил шаблон админки на другой  - заработало (но глючно!)
Проблему решил сменой браузера на Лису (в ней вся админка работает)

Я столкнулся с этой же проблемой в FF. Нашёл топик на форуме GavickPro, вот цитата разработчика:

Цитировать
You had no default language selected in VirtueMart. Without this language being set VM does not create tables for it and NSP is checking tables with the language selected in Joomla panel. I added English (United Kingdom) to multilanguage and module works fine now.

Иными словами:

1. Идём в настройки    VirtueMart –> Configuration
2. Смотрим в первую вкладку «Shop»
3. Смотрим в разделе «Language Settings» поле «Multilingual shop»
4. Добавляем в это поле язык «English (en-GB)»
5. Сохраняем изменения

Profit!