0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 4883 Просмотров
*

laskiy

  • Новичок
  • 22
  • 0 / 0
Помогите разобраться. Когда вставляешь ссылку в соцсети, то они не захватывают изображение. А еще пока использовал компонент sh404SEF еще и название алиасом выдавало. Сейчас временно отключил компонент, дак название вернулось к русскому. А картинки по прежнему не отображаются. Раньше все работало. Помимо данного компонента установил компонент Admin Tools и прошелся по всем кнопочкам. Что-то еще устанавливал, но что именно было установлено в этот период не помню, так как не следил за отображением в соцсетях.

Как выглядели ссылки раньше и как выглядят сейчас:
Спойлер
[свернуть]

Вот сайт:
http://piteronline.tv

Что я изменил я не знаю, но вроде уже все что можно откатить назад — откатил. У меня подозрение, что проблема кроется где-то в базе данных, но так ли это или нет — не знаю.
Подскажите, где искать решение.
« Последнее редактирование: 14.11.2014, 10:10:33 от b2z »
*

zikkuratvk

  • Глобальный модератор
  • 4368
  • 310 / 2
  • Разрабатываем для Joomla
Оно и сейчас так же выглядит http://shot.qip.ru/00sRPg-5NYzSwdXr/
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

laskiy

  • Новичок
  • 22
  • 0 / 0
Цитировать
Оно и сейчас так же выглядит http://shot.qip.ru/00sRPg-5NYzSwdXr/
К сожалению, картинка с чайником — единственная картинка, которая захватывается с сайта. Причем только если она где-то фигурирует на странице. Если ее нет, тогда картинка уже не вставляется.
*

zikkuratvk

  • Глобальный модератор
  • 4368
  • 310 / 2
  • Разрабатываем для Joomla
К сожалению, картинка с чайником — единственная картинка, которая захватывается с сайта. Причем только если она где-то фигурирует на странице. Если ее нет, тогда картинка уже не вставляется.
логично она у вас прописана первой в шаблоне.

<!-- You can add Google Analytics here-->  <meta property="og:image" content="http://piteronline.tv/http://piteronline.tv/images/big-logo12.png" />
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

laskiy

  • Новичок
  • 22
  • 0 / 0
логично она у вас прописана первой в шаблоне.

<!-- You can add Google Analytics here-->  <meta property="og:image" content="http://piteronline.tv/http://piteronline.tv/images/big-logo12.png" />

Не совсем эта. По ссылке идет ссылка на логотип сайта. А чайник вылазит только тогда, когда он есть на странице в новости или в рекомендованных.

Я попытался заменить шаблон, но по ходу дела проблема не в шаблоне, а в чем-то другом. В чем не знаю.
*

zikkuratvk

  • Глобальный модератор
  • 4368
  • 310 / 2
  • Разрабатываем для Joomla
логотип сделайте как беграунд... а не как картинку... и будет подхватываться нужная вам картинка. Вконтакте берет первую картинку которую ему отдает сайт..
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

laskiy

  • Новичок
  • 22
  • 0 / 0
логотип сделайте как беграунд... а не как картинку... и будет подхватываться нужная вам картинка. Вконтакте берет первую картинку которую ему отдает сайт..
У меня там ссылка на главную страницу зашита, поэтому не могу. Но я узнал, что есть определенные метатеги, по которым Вконтакте выбирает свою картинку. Сейчас изучаю.
*

laskiy

  • Новичок
  • 22
  • 0 / 0
РЕШЕНО

Оказалось, что я установил плагин по работе с социальными сетями, который перехватывает все Open Graph теги. Из-за того, что сам плагин некорректно установился, он выключил все теги и Вконтакте не мог найти где вообще на сайте находятся картинка. Поэтому он не брал картинки вообще. Теперь все работает.

Дальше буду уже разбираться с Open Graph, чтобы получать нужное изображение и нужный текст.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как убрать ссылку на плагин из шаблона?

Автор jess

Ответов: 5
Просмотров: 288
Последний ответ 29.12.2018, 11:24:03
от jess
Где включить Ссылку "А"

Автор composerr

Ответов: 1
Просмотров: 163
Последний ответ 10.12.2018, 22:49:18
от composerr
[РЕШЕНО] После апгрейда j3.6.5 на j3.9 не создает пункты меню в админке

Автор busik

Ответов: 12
Просмотров: 658
Последний ответ 24.11.2018, 09:01:51
от draff
[РЕШЕНО] Ошибка 500 в менеджере материалов

Автор RUSchief

Ответов: 24
Просмотров: 1209
Последний ответ 23.11.2018, 20:13:36
от dorffman
Редактирование шаблона админки Joomla. Формы размещения статьи [Решено]

Автор Eholov

Ответов: 8
Просмотров: 386
Последний ответ 18.10.2018, 21:16:55
от lexxbry