Проблема с редактором JCE и HTML-код YouTube!

  • 8 Ответов
  • 2354 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Алишер

  • Давно я тут
  • ****
  • 203
  • 1
  • Хочешь мира, готовься к войне!
Скажите пожалуйста почему когда в материале установишь HTML-код с YouTube и редактор будет стоять "JCE", то код теряется! Например при вставке HTML-кода нажимаешь [Toggle Editor], вставляешь, потом опять нажимаешь [Toggle Editor] и хочешь посмотреть как все смотрится, то видео с YouTube исчезается, опять нажимаешь [Toggle Editor] и там его уже нету!
Тогда, чтобы вставить HTML-код с YouTube спокойно, я пользуюсь редактором "Tiny MCE", настраиваю все как надо и потом перехожу на редактор "JCE", чтобы пользоваться им когда печатаешь другие материалы, так как он удобней при работе!
Но опять таки, забудешь поменять редактор с "JCE" на "Tiny MCE" и откроешь материал где был HTML код с YouTube, то все что я добавлял видео с YouTube исчезает(((
В чем дело подскажите пожалуйста как исправить это?

*

stendapuss

  • Живу я здесь
  • ******
  • 829
  • 19
Редактор JCE режет код.

Идем в панель редактора находим вкладку глобальная конфигурация или типа этого ( зависит от версии редактора JCE. Находим вкладочку проверки HTML кода  ставим да, даем разрешение на проверку кода. Идем далее в вкладку профили редактора. Выбираем профиль (default), если вы в нем работаете. Его настраиваем. Смотрим параметры редактора. Находим, ниже вкладку расширенные. В поле с надписью дополнительные теги пишем, то что нам надо. В данном случае видео сYouTube рассматриваем. Пишем iframe, если надо что то другое прописываем. Не забываем сохранить изменения. Теперь можно брать простой код сYouTube и ставить любым из двух редакторов, редактор код не будет резать.
Добавить видео Joomla на сайт как еще редактор TinyMCE Joomla.
http://www.mani-mani-net.ru/%D0%B2%D0%B8%D0%B4%D0%B5%D0%BE-%D0%BE%D0%BD%D0%BB%D0%B0%D0%B9%D0%BD-%D1%83%D1%87%D0%B5%D0%B1%D0%BD%D0%BE%D0%B5?start=2

*

neogeek

  • Давно я тут
  • ****
  • 203
  • 18
Все правильно выше написали, надо правильно настроить JCE, добавить разрешенные теги, которые не будут срезаться. Вообще этот редактор считаю лучшим, в нем куча возможностей и полезных настроек.

*

stendapuss

  • Живу я здесь
  • ******
  • 829
  • 19
Для noindex сразу пропишите, тоже режет.

*

warlocksp

  • Живу я здесь
  • ******
  • 927
  • 8
  • Красота и мудрость - в простоте....
У меня срезает этот тег:
  <style>
   img:hover {
      box-shadow: 0 0 10px rgba(0,0,0,0.5);
   }
  </style>

Как правильно я должен прописать в профили?
Пожалуйста подскажите...
Разработка, сопровождения, продвижение веб ресурсов...Хостинг-провайдер...
ICQ : 663021519;Skype: Warl-Uanic;Nic-Handle: Warl-Uanic.

*

neogeek

  • Давно я тут
  • ****
  • 203
  • 18
В настройках JCE в вашем профиле, вкладка Параметры редактора, там - Разрешить CSS - поставьте да, тогда не должно срезать, ну на всякий случай еще в дополнительные элементы пропишите тег - style
А вообще зачем CSS стили пихать в материал? Лучше добавьте их в CSS шаблона

*

warlocksp

  • Живу я здесь
  • ******
  • 927
  • 8
  • Красота и мудрость - в простоте....
В настройках JCE в вашем профиле, вкладка Параметры редактора, там - Разрешить CSS - поставьте да, тогда не должно срезать, ну на всякий случай еще в дополнительные элементы пропишите тег - style
А вообще зачем CSS стили пихать в материал? Лучше добавьте их в CSS шаблона

Понимаю что лучше в шаблон CSS запихнуть но нужно сюда поствить...
Я поставил как вы сказали, Разрешить CSS + прописал style в ставил:
  <style>
   img:hover {
      box-shadow: 0 0 10px rgba(0,0,0,0.5);
   }
  </style>

А он тогда добавляет комментарий и выдает:
  <style>
   img:hover <!--{
      box-shadow: 0 0 10px rgba(0,0,0,0.5);
   } -->
  </style>
Разработка, сопровождения, продвижение веб ресурсов...Хостинг-провайдер...
ICQ : 663021519;Skype: Warl-Uanic;Nic-Handle: Warl-Uanic.

*

warlocksp

  • Живу я здесь
  • ******
  • 927
  • 8
  • Красота и мудрость - в простоте....
Все проблему решил по другому:
Прописал CSS шаблоне:
.post-body img {  border: 1px solid #eee; padding: 10px; }
.post-body img:hover { -moz-box-shadow: 0 0 20px #ccc; -webkit-box-shadow: 0 0 20px #ccc; box-shadow: 0 0 20px #ccc; }

А после установил где мне нужно и все...
Спасибо, проблема решина....
Разработка, сопровождения, продвижение веб ресурсов...Хостинг-провайдер...
ICQ : 663021519;Skype: Warl-Uanic;Nic-Handle: Warl-Uanic.

*

lexrider

  • Осваиваюсь на форуме
  • ***
  • 35
  • 0
Цитировать
Все проблему решил по другому:
а есть вариант решить не по другому а методом добавления исключений?

меняет тег style все что внутри него коментит... собака