0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 1178 Просмотров
*

Vzx

  • Осваиваюсь на форуме
  • 18
  • 3 / 0
В связи с миграцией на J!3.4.8 обновил JCE до актуальной версии (пробовал 2.5.12 и 2.4.6).
В итоге в админке панель управления JCE открывается, но при переходе в любой из разделов "Общие настройки", "Профили редактора" или "Установка дополнений" отображается страница с синей полосой "Загрузка" и на этом всё заканчивается (см. картинку).
Спойлер
[свернуть]
Отключил уже все посторонние модули-компоненты с id от 10000, но это не помогло.
Шаблон админки - стандартный Isis.

Может, кто-то уже сталкивался с подобным и успешно поборол?

P.S. Тестируется всё на локалхосте под WampServer'ом, если это имеет значение.
*

Vzx

  • Осваиваюсь на форуме
  • 18
  • 3 / 0
Немного свежей информации о данной проблеме.
В то время, когда наблюдаем синий бар, в консоли JS фиксируются ошибки, связанные со стандартным скриптом "\media\system\js\mootools-more.js".
Например:
SyntaxError: missing } after property list1 mootools-more.js:7043:32
При просмотре исходника через консоль Firefox (view-source:http://site2/media/system/js/mootools-more.js), виден фрагмент кода с подсвеченной строкой:
Спойлер
[свернуть]
Однако если открыть непосредственно сам файл, то там в этой части кода содержимое другое:
Спойлер
[свернуть]
И самое непонятное (для меня) то, что если немного модифицировать исходник скрипта (отбить табами, например), потом почистить кэш и перезагрузить страницу, то всё может великолепно заработать. Но после следующей чистки кэша/обновления страницы -- уже снова ошибка с "подменой" кода.

Кто-нибудь может прояснить, что происходит такое? Нормально ли, что будто происходит замена кода?

Рядом на виртуальном хосте поднял 3.4.8 "с нуля" из дистрибутива и установил JCE -- такая же ерунда…
*

Vzx

  • Осваиваюсь на форуме
  • 18
  • 3 / 0
Похоже, что проблема разрешилась. ^-^
Установил FireBug, через него вышел на скрипт main.js, который был инъектирован в код сайта и принадлежал Kaspersky Internet Security.
Отключение защиты через настройки Касперского на этот скрипт не повлияло. Помогла только полная выгрузка программы.
В итоге ошибки пропали, всё заработало нормально. У меня не самая актуальная версия Касперского, возможно, в более новых проблема отсутствует.
Проверил на JCE 2.4.6, потом обновил до 2.5.12 -- всё в порядке.
Надеюсь, этот опыт кому-нибудь в будущем пригодится! *DRINK*
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Панель JCE 2.6.35. пролемка

Автор Игарь

Ответов: 10
Просмотров: 723
Последний ответ 23.12.2018, 22:00:19
от lexxbry
Не отображается панель ссылок в JCE

Автор korkka44

Ответов: 0
Просмотров: 613
Последний ответ 06.09.2017, 00:07:36
от korkka44
Не отображается панель JCE в редакторе материала.

Автор senseone

Ответов: 11
Просмотров: 7262
Последний ответ 30.08.2016, 17:21:57
от newkrasno
В панели управления редактора JCE отсутствует кнопка якорь

Автор Diversus

Ответов: 1
Просмотров: 986
Последний ответ 15.11.2014, 22:58:02
от AlekVolsk
Неправильно работают подписи к иконкам на панели управления

Автор nordsword

Ответов: 0
Просмотров: 722
Последний ответ 01.07.2014, 12:05:26
от nordsword