Не работающая админка после обновления до Joomla 3.6

  • 8 Ответов
  • 1371 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Rozen

После обновления до Joomla 3.6 в админке белый экран.
Смена параметра отображения ошибок на максимум показывает проблему:

Цитировать
Warning: require_once(/home/user/site/docs/components/com_community/models/community.php): failed to open stream: No such file or directory in /home/user/site/docs/components/com_community/libraries/core.php on line 672

Fatal error: require_once(): Failed opening required '/home/user/site/docs/components/com_community/models/community.php' (include_path='.:/usr/opt/php7/share/pear') in /home/user/site/docs/components/com_community/libraries/core.php on line 672

Проблема решается патчем совместимости, который доступен тем у кого действующая подписка.

https://www.jomsocial.com/forum/installation/34065-just-upgraded-from-j3-5-1-to-joomla3-6-js-backend-not-showing-anymore

*

nick200

А у кого-нибудь есть этот патч?
После обновления до Joomla 3.6 в админке белый экран.
Смена параметра отображения ошибок на максимум показывает проблему:

Проблема решается патчем совместимости, который доступен тем у кого действующая подписка.

https://www.jomsocial.com/forum/installation/34065-just-upgraded-from-j3-5-1-to-joomla3-6-js-backend-not-showing-anymore


*

Rozen

А что в файле com_community/libraries/core.php, строка 672? Что там за код? Может можно поправить.

Код
 require_once(JPATH_ROOT . '/components/com_community' . $classes[$classname]);
« Последнее редактирование: 19.07.2016, 19:02:40 от Rozen »

*

FitMe

Ничего особенного. Главное, что по данному пути вообще не должно быть файла core.php, он выше на ветку располагается.
Я конечно далеко не спец.
Вполне вероятно что немного изменена архитектура, и кто знает что еще будут менять в 3.7, 3.8, 3.9 впереди, так что подписку предается продлевать, ибо аналогичные фиксы будут наверное на постоянной основе.
P/S: Это я Вам писал на почту)

*

Rozen

Патч исправляющий "белый экран" административной панели JomSocial при работе с Joomla 3.6.
По сути - это просто недостающий файл библиотеки.
По тексту ошибки вы поймете куда положить файл.

core.php
Спойлер
[свернуть]
« Последнее редактирование: 25.07.2016, 17:39:15 от Rozen »

Патч исправляющий "белый экран" административной панели JomSocial при работе с Joomla 3.6.
По сути - это просто недостающий файл библиотеки.
По тексту ошибки вы поймете куда положить файл.

core.php
Спойлер
[свернуть]

Специально вошла чтобы поблагодарить вас, неделю мучалась, спасибо огромное вам, заработало

*

zuvast

После замены на выше указанный файл core.php выдает ошибку:
Fatal error: Class 'cobject' not found in /components/com_community/libraries/core.php on line 1622
и сайт ламается и на фронтенде. При возрате на родной файл core.php - сайт снова работает на фронтенде, но с админки таже ошибка:
 Fatal error: require_once(): Failed opening required '/components/com_community/models/community.php' (include_path='.:/usr/local/pear/php70') in /components/com_community/libraries/core.php on line 656
 !

*

XAOC

Патч исправляющий "белый экран" административной панели JomSocial при работе с Joomla 3.6.
По сути - это просто недостающий файл библиотеки.
По тексту ошибки вы поймете куда положить файл.

core.php
Спойлер
[свернуть]


наиогромаднейшее гранд мерси. Пытался обновиться на 3.6- все поломалось. Обновился сейчас на 3.6.2 (JomSocial 4.2.2) и скопировал Ваш файл- все работает.