0 Пользователей и 1 Гость просматривают эту тему.
  • 4 Ответов
  • 241 Просмотров
*

pilgrim_ua

  • Новичок
  • 8
  • 1 / 0
Коллеги, помогите решить проблему!

Перевожу сайт на https.
После выполнения всех рекомендаций с настройками в configuration.php и .htaccess (https://alex-kurteev.ru/blog/full/1342-osobennosti-ustanovki-ssl-sertifikata-na-joomla.html) протокол установился, ошибок не выдает. Но уехали стили!
Нашел, что в 2-х файлах шаблона (Zoka от Shape5) vertex/compression/top_css_and_js_compression.php и vertex/compression/bottom_css_and_js_compression.php прописан http://.
Сделал просто //.
Стили вернулись, но пропали выпадающий список в Главном меню и содержимое модуля с отзывами, и в табах немножко текст съехал. Вообщем вот пациент https://vega-impex.com

Подскажите, где и что теперь надо доделать?! Может кто сталкивался с подобным?
« Последнее редактирование: 01.04.2017, 15:29:31 от pilgrim_ua »
*

wishlight

  • Живу я здесь
  • 3813
  • 234 / 1
  • skype aqaus.com
Re: Проблема при переезде на https
« Ответ #1 : 01.04.2017, 15:36:04 »
Выпадающий список у меня работает ваш. Если бы на оригинал глянуть, как было еще.
*

pilgrim_ua

  • Новичок
  • 8
  • 1 / 0
Re: Проблема при переезде на https
« Ответ #2 : 01.04.2017, 20:07:05 »
Выпадающий список у меня работает ваш. Если бы на оригинал глянуть, как было еще.

Спасибо за отклик!

Да, уже работает. Нашел на форуме давнее обсуждение и воспользовался одним из советов.
После реализации этого совета http://joomlaforum.ru/index.php/topic,318327.msg1585420.html#msg1585420 заработало.
Вообщем, вот что мне помогло https://github.com/joomla/joomla-cms/pull/7902/files
Правда теперь на http иконки пропали, но это уже не критично.
*

flat

  • Новичок
  • 5
  • 0 / 0
Re: Проблема при переезде на https
« Ответ #3 : 04.04.2017, 11:31:46 »
что бы тем не плодить.
Тоже проблема с SSL.
Пристегнул SSL к домену. В .htaccess добавил код (выдан хостером)
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

В Joomle включил SSL.
Теперь при входе в админку вижу что соединение защищено, а вот на самом сайте нет. Куда копать?
*

ProtectYourSite

  • Завсегдатай
  • 1133
  • 67 / 4
  • Безопасность вебсайтов
Re: Проблема при переезде на https
« Ответ #4 : 04.04.2017, 15:24:51 »
В консоль браузера Ctrl+Shift+I смотреть
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема с протоколом https

Автор Olga

Ответов: 2
Просмотров: 74
Последний ответ 10.01.2018, 20:48:50
от yuri-it
Проблема с кэшем Joomla 3

Автор sarvasvova

Ответов: 2
Просмотров: 145
Последний ответ 15.12.2017, 16:26:29
от ProtectYourSite
проблема с менеджером материалов

Автор iakov25

Ответов: 35
Просмотров: 503
Последний ответ 06.12.2017, 09:35:34
от Arkadiy
Проблема с обновлением Joomla 3.x.x

Автор himyra

Ответов: 1
Просмотров: 208
Последний ответ 02.12.2017, 18:25:02
от himyra
Проблема с меню - Общая настройка

Автор DPulse

Ответов: 3
Просмотров: 175
Последний ответ 13.11.2017, 09:18:17
от draff