0 Пользователей и 1 Гость просматривают эту тему.
  • 6 Ответов
  • 1062 Просмотров
*

TopClans

  • Осваиваюсь на форуме
  • 29
  • 1 / 0
Заколебали ломать джумлу, решить обновить.
Дошёл до 3.2.7, дальше автоматический апдейт не видит новых версий (пробовал разные серверы обновлений, и чистить кеш).

Хотел вручную - выяснилось, что новые версии работают на PHP7 (у меня 5.4.16), может поэтому джумла и не видит обновлений.

Начал читать как перевести джумлу на PHP7 - выяснилось, что сначала нужно поставить 3.5 и выше. Ничего не понял, чтобы поставить 3.5 нужен PHP7, а чтобы поставить PHP7, нужно 3.5 (если текущую 3.2.7 запустить на PHP 7.0.23 с FastCGI, то лезут ошибки, то же самое с CGI, а Apache + PHP7 не получится поставить потому что ISPmanager позволяет это сделать только для всего сервера, а у меня есть и другие сайты, которые не будут работать на PHP7 + Apache).

Вручную обновить по мануалу не выходит: они пишут что нужно найти пакет и залить через сайт, но в пакетах на сайте джумлы даже нет XML файла, то есть он для ручной распаковки. Распаковывал архив вручную - вылезли ошибки.

В итоге вопросы:
- как всё же обновить 3.2.7 до текущей?
- как быть с PHP7, какую сборку поставить и как джумлу к ней приучить? не нашёл мануалов не эту тему
*

SeBun

  • Живу я здесь
  • 3632
  • 231 / 3
  • @SeBun48
Re: Обновил до 3.2.7, дальше - не идёт
« Ответ #1 : 18.10.2017, 09:12:34 »
PHP 5.6 включите, все версии 3.х с ним работают. PHP 7.х включите, когда на 3.8 обновитесь и обновите все ваши расширения, которые должны поддерживать работу с этой версией.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг
*

AveFix

  • Новичок
  • 4
  • 0 / 0
Re: Обновил до 3.2.7, дальше - не идёт
« Ответ #2 : 30.03.2018, 09:30:56 »
Бяда таварисчи. Joomla застряла 3.2.7 и дальше не двигается.
"У вас уже установлена последняя версия Joomla!, 3.2.7."
Очистка кэша не помогает.
Попробовал копировать и заменить файлы в ручную, вышла ошибка.
*

wishlight

  • Живу я здесь
  • 4236
  • 255 / 1
  • 300 руб очень быстрый хостинг в ЕС
Re: Обновил до 3.2.7, дальше - не идёт
« Ответ #3 : 30.03.2018, 11:12:25 »
https://github.com/joomla/joomla-cms/releases/download/3.8.6/Joomla_3.8.6-Stable-Update_Package.zip Вроде как через компонент обновления в админке. Замена не вносит изменений в базу. Бекап предварительно. Версию php не ниже 5.6. Руби Роуз на аватарке шикарна  ;D
*

AveFix

  • Новичок
  • 4
  • 0 / 0
Re: Обновил до 3.2.7, дальше - не идёт
« Ответ #4 : 30.03.2018, 11:57:19 »
Версию php не ниже 5.6.
Подскажите как ее включить. Искал в инете нашел типа в .htaccess надо дописать код и т.д.

Кстати при добавление ссылки в пользовательские серверы он пишет неизвестная версия Joomla и расширений.
Может у вас есть ссылки на видео или еще что как обновлять из 3.2.7

https://yadi.sk/i/iQeM--s93TuVgu
https://yadi.sk/i/ShfpbzVl3TuVjE
« Последнее редактирование: 30.03.2018, 12:02:47 от AveFix »
*

Apoca1ypto

  • Давно я тут
  • 745
  • 71 / 0
Re: Обновил до 3.2.7, дальше - не идёт
« Ответ #5 : 30.03.2018, 12:02:57 »
Подскажите как ее включить.

В панели управления хостингом.
Если у Вас все локально, то, потребуется например вот это https://www.apachefriends.org/blog/new_xampp_20180315.html
Во время спора в Интернете Ваш оппонент приводит неопровержимые доказательства своей точки зрения? Не отчаивайтесь. До...тесь до орфографии.
*

Sedoy

  • Давно я тут
  • 900
  • 87 / 10
  • Интересно,в какой кодировке пишут врачи?
Re: Обновил до 3.2.7, дальше - не идёт
« Ответ #6 : 16.05.2018, 10:52:14 »
ну что удалось обновить 327 на "выше"?
та же трабла
 
Что б правильно задать вопрос - нужно знать на него ответ!
FAQ по Joomla!
Где скачать шаблоны Joomla Статьи и обзоры Желаю Вам здоровья в личной жизни - живите долго и часто :)
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Обновил на 3, 85 ошибка

Автор horstmann

Ответов: 5
Просмотров: 213
Последний ответ 02.03.2018, 18:48:09
от Efanych
Обновил Джумлу до 3, 8 проблема

Автор horstmann

Ответов: 1
Просмотров: 261
Последний ответ 29.09.2017, 09:20:26
от b2z
Обновил движок сайта с версии 2.5.28 до 3.5.1 теперь белый экран

Автор foller10560

Ответов: 16
Просмотров: 707
Последний ответ 06.06.2017, 10:32:49
от lexxbry
Call to undefined function mysql_escape_string() Обновил до Joomla 3.7.0

Автор Alexhelp

Ответов: 25
Просмотров: 1333
Последний ответ 28.05.2017, 09:46:48
от ChaosHead
Установка Jooml'ы провисает и не идёт дальше

Автор turbo-

Ответов: 1
Просмотров: 242
Последний ответ 26.01.2017, 15:50:27
от Septdir