0 Пользователей и 1 Гость просматривают эту тему.
  • 3 Ответов
  • 273 Просмотров
*

gfn

  • Новичок
  • 6
  • 0 / 0
ошибка в версии 3.6.5
« : 03.11.2017, 11:42:04 »
Здравствуйте! Помогите пожалуйста решить проблему. в версии 3.6.5, которая сразу уже русифицирована, при загрузке админ панели, точнее при входе в админку, пишется такая ошибка-

Fatal error: Call to undefined method JApplicationAdministrator::isClient() in C:\joomla\domains\mydomain.ru\plugins\quickicon\phpversioncheck\phpversioncheck.php on line 203

вот строки из указанного файла -

c 200 по 218 строки
private function shouldDisplayMessage()
   {
      // Only on admin app
      if (!$this->app->isClient('administrator'))
      {
         return false;
      }

      // Only if authenticated
      if (JFactory::getUser()->guest)
      {
         return false;
      }

      // Only on HTML documents
      if ($this->app->getDocument()->getType()!== 'html')
      {
         return false;
      }

что мне сделать, чтобы все заработало нормально?

Устанавливалась Джумла поверх предыдущей версии, копированием с заменой файлов(предыдущая была выше,т.е. 3.7.0, но язык не ставился в админке)

PS Сервер локальный.
*

voland

  • Легенда
  • 9890
  • 546 / 107
  • Эта строка съедает место на вашем мониторе
Re: ошибка в версии 3.6.5
« Ответ #1 : 03.11.2017, 12:23:58 »
Делать заново.
На этот раз качать только с оффсайта, не обновлять копированием файлов, а только из админки
*

gfn

  • Новичок
  • 6
  • 0 / 0
Re: ошибка в версии 3.6.5
« Ответ #2 : 03.11.2017, 12:54:54 »
Делать заново.
На этот раз качать только с оффсайта, не обновлять копированием файлов, а только из админки
Ну да, это логично. Просто хотелось разобраться,почему он выдает ошибку именно на 203 строке. а так, переустановила, заработало.Но!Установленного языка обещанного нет. Устанавливать пришлось методом тыка, вручную, ибо в админке никак. При этом, пока не создала ему нужные папки ru-RU, не хотел сам устанавливать. а оффсайт это какой? а то их много развелось в сети.
*

voland

  • Легенда
  • 9890
  • 546 / 107
  • Эта строка съедает место на вашем мониторе
Re: ошибка в версии 3.6.5
« Ответ #3 : 03.11.2017, 13:25:50 »
Joomla.org конечно
русский ставится в админке, более того - при установке можно выбрать русский сразу
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Модуль, который будет отображаться только в мобильной версии сайта

Автор jolilolidoli

Ответов: 6
Просмотров: 175
Последний ответ 09.07.2018, 08:03:00
от lexxbry
Обнаружена ошибка при входе в админку

Автор Xavibeat

Ответов: 1
Просмотров: 303
Последний ответ 30.06.2018, 11:43:18
от al707
Бэкап Joomla Ошибка This extension requires FOF 3.0

Автор manm7667

Ответов: 1
Просмотров: 168
Последний ответ 26.06.2018, 23:07:04
от manm7667
Ошибка после обновления с 3.8.8 до 3.8.9

Автор skillful

Ответов: 8
Просмотров: 568
Последний ответ 26.06.2018, 21:30:40
от lexxbry
Ошибка при попытке обновить Joomla с 3.7.5 до 3.8.0

Автор m1804

Ответов: 5
Просмотров: 321
Последний ответ 30.05.2018, 13:23:54
от m1804