Новости Joomla

0 Пользователей и 1 Гость просматривают эту тему.
  • 6 Ответов
  • 563 Просмотров
*

Ebelous

  • Захожу иногда
  • 207
  • 1 / 0
  • Учиться,учиться и учиться!
Версии РНР и Joomla 3
« : 27.02.2024, 17:39:28 »
Здравствуйте! Имеется сайт на Joomla 3. Обновлен до последней версии 3.10.12. На хостинге при обновлении PHP до версии 8.1.3 никаких ошибок не выскакивает. А на локальном сервере Open Server тот же сайт  при настройке версии PHP 8.1  открывается уже с ошибками. На какую последнюю версию PHP расчитана Joomla 3.
*

sivers

  • Живу я здесь
  • 2488
  • 338 / 0
На связи в telegram @sivers
sivers @ inbox . ru
https://sivers.su/
*

Ebelous

  • Захожу иногда
  • 207
  • 1 / 0
  • Учиться,учиться и учиться!
Re: Версии РНР и Joomla 3
« Ответ #2 : 28.02.2024, 20:17:50 »
https://manual.joomla.org/docs/4.4/get-started/technical-requirements#requirements-for-joomla-3x
Ну это рекомендованные версии. Тут хостинг предупредил, что версии PHP до 8.0 включительно через 10 месяцев поддерживаться не будут.
Это что? Всем сайтам на Joomla 3 кирдык? А больше половины форума освещают темы  Joomla 1.5 и Joomla 2.5. Какой в этом смысл?
*

Vastriet

  • Захожу иногда
  • 308
  • 8 / 0
Re: Версии РНР и Joomla 3
« Ответ #3 : 28.02.2024, 21:02:50 »
тут вопрос к хостеру
а для тройки без танцев с бубном 7.4
*

SeBun

  • BanMaster
  • 4024
  • 259 / 5
  • @SeBun48
Re: Версии РНР и Joomla 3
« Ответ #4 : 28.02.2024, 23:32:09 »
Ну это рекомендованные версии. Тут хостинг предупредил, что версии PHP до 8.0 включительно через 10 месяцев поддерживаться не будут.
Это что? Всем сайтам на Joomla 3 кирдык? А больше половины форума освещают темы  Joomla 1.5 и Joomla 2.5. Какой в этом смысл?
Если нужен хостинг с поддержкой старых версий PHP, напишите мне. У нас даже совсем старые сайты работать будут.  ;)

Что касается ранних версий Joomla!, то у хостеров политика по отношению к ним в принципе правильная: не стоит использовать то, что уже не поддерживается. Много раз говорилось об этом, много было написано статей, но люди все равно наступают на одни и те же грабли. В итоге, когда к нам приходят клиенты с такими динозаврами, практически все они, которые годами не обновлялись, оказываются нашпигованы вредоносным кодом, т.к. не закрываются дыры в безопасности самой CMS, и дыры в ПО сервера, вынужденного ставить такое ПО для их работы. Кроме того, версии 2.5, и тем более 1.5 выпущены в эпоху, когда были совсем другие технологии, требования к верстке, к внешнему виду и т.п. Если вас не заботит посещаемость и визуальная привлекательность, то конечно эти вопросы можно не затрагивать.

P.S. Есть, правда, и исключения. В нашем городе есть сахарный завод с просто отвратительным сайтом. Но они отказываются на нем что либо менять, т.к. сайт им нужен только для галочки, коммуникация и продажи идут по другим каналам.
« Последнее редактирование: 28.02.2024, 23:46:13 от SeBun »
Оказываю услуги по Joomla | Миграция/Обновление | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

Ebelous

  • Захожу иногда
  • 207
  • 1 / 0
  • Учиться,учиться и учиться!
Re: Версии РНР и Joomla 3
« Ответ #5 : 29.02.2024, 10:46:07 »
Если нужен хостинг с поддержкой старых версий PHP, напишите мне. У нас даже совсем старые сайты работать будут. 
Спасибо за пояснения! Я лучше в ногу со временем предпочитаю идти.
*

web1

  • Захожу иногда
  • 254
  • 10 / 1
Re: Версии РНР и Joomla 3
« Ответ #6 : 29.02.2024, 17:50:02 »
Здравствуйте, у меня Joomla 3.10 работает на php 7, переключал на php 8 — был белый экран, а вот Joomla 5.0 работает только на php 8. Удачи, успехов всем, всех благ.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

SP polls в Joomla 3.8.2

Автор wawont

Ответов: 2
Просмотров: 1581
Последний ответ 22.02.2024, 21:03:15
от Zegeberg
Исправление уязвимости в Joomla 3.10.12

Автор Sulpher

Ответов: 8
Просмотров: 935
Последний ответ 12.01.2024, 22:15:52
от stepan39
Заявки с сайта на Joomla

Автор ivs1

Ответов: 8
Просмотров: 764
Последний ответ 18.12.2023, 12:37:45
от SeBun
Прошу помощи. Ошибка при обновлении на Joomla 4

Автор wmsonic

Ответов: 1
Просмотров: 1065
Последний ответ 29.10.2023, 22:07:23
от Kukush
Не может обновиться Joomla 3.4.8

Автор СветланаБа

Ответов: 1
Просмотров: 969
Последний ответ 26.09.2023, 08:06:22
от Vastriet