0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 414 Просмотров
*

Strelok760

  • Захожу иногда
  • 58
  • 0 / 0
Доброго времени суток. Пытаюсь реализовать легкую регистрацию для пользователя, с полями Email и Пароль. Однако, после отключения полей name и username регистрация не происходит, а только выдает ошибку "Сохранить не удалось из-за ошибки: Что-то не так". Как с этим бороться?
P.S Joomla 3.6.5 и VM 3.2.14
« Последнее редактирование: 02.11.2018, 13:54:25 от Strelok760 »
*

Strelok760

  • Захожу иногда
  • 58
  • 0 / 0
Плагин добавления групп для регистрации, регистрация в один клик
Я его пробовал юзать. Результат- нет ошибки "Поле Имя не заполнено", но есть ошибка "Что-то не так"
*

Fedor Vlasenko

  • Живу я здесь
  • 3821
  • 720 / 7
  • Все начинается с Value
Значит активные другие плагины. Требуется методом научного тыка аккуратно по отключать лишние   начиная с группы user  *suicide*
*

draff

  • Живу я здесь
  • 3976
  • 266 / 7
  • Ищу работу
А если в VM отключить все поля, что выводится ?
*

Strelok760

  • Захожу иногда
  • 58
  • 0 / 0
А если в VM отключить все поля, что выводится ?
То же самое  ;D
*

Strelok760

  • Захожу иногда
  • 58
  • 0 / 0
Активные плагины с типом "user": Пользователь - Joomla!; Выбор группы для регистрации;
Как только отключаю плагин "Выбор группы для регистрации", сразу возвращается ошибка "поле Имя не заполнено". Буду копать в эту сторону, судя по всему в каком-то из файлов что-то по прежнему блокирует регистрацию.
*

Strelok760

  • Захожу иногда
  • 58
  • 0 / 0
Попробовал удалить файл /docs/components/com_users/views/registration/tmpl/default.php - Ничего не поменялось. Если включить в панели управления поле "Имя", то даже получится зарегистрироваться. Каким образом без данного файла возможна регистрация впринципе?  *ОХ-Х-Х*
P.S Шаблона переопределения не стоит.
P.P.S Если удалить /docs/components/com_users/views/registration/tmpl/default.xml - тоже ничего не меняется. Даже на удаление папки com_user 0 реакции. А вот если я удаляю com_virtuemart - то уже появляется ошибка "компонент не найден".
« Последнее редактирование: 02.11.2018, 13:23:15 от Strelok760 »
*

Strelok760

  • Захожу иногда
  • 58
  • 0 / 0
Победа!   ::)

Перепробовал массу способов, отключал и включал разные плагины, редактировал исходные файлы но все без толку.
В итоге по счастливой случайности наткнулся на плагин VM Clean Registration, установил его и все заработало! (Плагин "Выбор групп пользователя" при этом отключил)
Также есть нюанс- в "поля заполняемые пользователем" name и username должны быть опубликованы и включены в учетной записи (Показать в учетной записи - Да).
Метод научного тыка 1:0 Joomla3
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

captcha после установки выдает ошибка: неверный ключ

Автор specifika

Ответов: 7
Просмотров: 1673
Последний ответ 16.07.2019, 20:28:39
от Lizbet111
[Решено] Вставить в код языковые константы

Автор lgmax

Ответов: 3
Просмотров: 74
Последний ответ 16.07.2019, 20:25:04
от dmitry_stas
При входе зарегистрированным пользователем, ошибка Макет default_core не найден

Автор a69

Ответов: 1
Просмотров: 89
Последний ответ 07.07.2019, 17:45:41
от draff
[решено] В панель управления сайта добавить свое меню

Автор pavel2950

Ответов: 1
Просмотров: 268
Последний ответ 04.07.2019, 22:02:47
от pavel2950
Ошибка при установке шаблона (фреймворка)

Автор fireman

Ответов: 0
Просмотров: 67
Последний ответ 04.07.2019, 21:18:53
от fireman