0 Пользователей и 1 Гость просматривают эту тему.
  • 14 Ответов
  • 330 Просмотров
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Вопрос по кодировке
« : 31.01.2019, 13:38:54 »
Друзья, прошу помощи. Столкнулся с такой проблемой (обычно создаю на Joomla и с такой проблемой не сталкивался, не знаю даже куда обратиться)
При переноса старого сайта (сайт не мой, и DB выгружал тоже не я) на новый хостинг, столкнулся с тем что вся кириллица отображается как знаки вопроса.
Dump Db по дефолту имеет шапку такого вида:

/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES binary */;
/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
/*!40103 SET TIME_ZONE='+00:00' */;
/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;
/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;
/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;
/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;
DROP TABLE IF EXISTS `access`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `access` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `username` varchar(50) DEFAULT NULL,
  `ip_address` varchar(15) DEFAULT NULL,
  `page_accessed` varchar(100) DEFAULT NULL,
  `access_time` varchar(28) DEFAULT NULL,
  PRIMARY KEY (`id`)
) ENGINE=MyISAM AUTO_INCREMENT=361 DEFAULT CHARSET=cp1251;
/*!40101 SET character_set_client = @saved_cs_client */;

Вижу что кодировка "binary" - меняю на utf8, дальше по файлу вижу, что неоднократно встречается "DEFAULT CHARSET=cp1251" - тоже всё меняю на utf8, перекодирую весь файл в utf8 без BOM, заливаю на хостинг - эффекта 0, всё те же знаки вопроса.
Подскажите пожалуйста, что и где я делаю не так? (туплю второй день уже).

p.s. а да! В phpmyadmin в таблицах, при всём при этом, кириллица отображается нормально!
*

Ragivort

  • Завсегдатай
  • 1154
  • 56 / 2
  • Такая Life
Re: Вопрос по кодировке
« Ответ #1 : 31.01.2019, 14:50:41 »
А в htacces
AddDefaultCharset utf-8
Стоит?
Дозволь мне свершить то добро, которое я способен свершить, теперь, ибо я могу более не вернуться сюда.
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #2 : 31.01.2019, 15:05:19 »
Ага
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #3 : 31.01.2019, 15:28:14 »
Даже менял на cp1251 в .htacces и базу заливал без изменений - ничего не меняется.
*

passer

  • Давно я тут
  • 961
  • 74 / 3
Re: Вопрос по кодировке
« Ответ #4 : 31.01.2019, 15:40:01 »
Так посмотрите в базе, сравнение какое у полей с кириллицей.
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #5 : 31.01.2019, 15:49:17 »
Так говорю же -  по дефолту в базе cp1251. Заливаю ее ничего не трогая, прописываю [/size].htacces[/size] [/size] - знаки вопроса.[/size]
Перелопачиваю всю базу, меняю все [/size]cp1251 на utf8, сохраняю в utf8, заливаю, прописываю .htacces - иии - знаки вопроса. [/size]
Ничего не меняется от этих моих действий.[/size]
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #6 : 31.01.2019, 15:57:13 »
Дополню немного: в первом случае (не правленая выгрузка с cp1251) в phpadmin вся кирилица отображается какими-то кроказябрами.
Во втором случае (правленая база с utf8) в phpadmin вся кириллица отображается нормально. Но на сайте, это в обоих случаях - знаки вопроса.
*

passer

  • Давно я тут
  • 961
  • 74 / 3
Re: Вопрос по кодировке
« Ответ #7 : 31.01.2019, 16:54:29 »
У файлов шаблона кодировка Utf-8 без ВОМ?
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #8 : 31.01.2019, 21:54:11 »
Ага. А разе должна быть с BOM?
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #9 : 01.02.2019, 11:46:58 »
Нашел, похоже в чем конкретно косяк, но не могу понять как его устранить.
Итак:
База - utf8
.htaccess - utf8
phpadmin - ut8 (и отображает киррилицу)

А код страницы, меж тем, выдает вот это вот:
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251" />

Где поменять?
*

voland

  • Легенда
  • 10554
  • 563 / 111
  • Эта строка съедает место на вашем мониторе
Re: Вопрос по кодировке
« Ответ #10 : 01.02.2019, 12:16:04 »
Нашел, похоже в чем конкретно косяк, но не могу понять как его устранить.
Итак:
База - utf8
.htaccess - utf8
phpadmin - ut8 (и отображает киррилицу)

А код страницы, меж тем, выдает вот это вот:
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251" />

Где поменять?
В шаблоне
*

draff

  • Живу я здесь
  • 4049
  • 270 / 7
  • Ищу работу
Re: Вопрос по кодировке
« Ответ #11 : 01.02.2019, 13:23:59 »
В шаблоне
Переключить шаблон, очистить кеш на всяку случай.
*

arma

  • Завсегдатай
  • 1523
  • 70 / 2
Re: Вопрос по кодировке
« Ответ #12 : 02.02.2019, 01:23:44 »
Разве это Joomla Не туда копаете, это волдресс , человек изначально ошибся. Читайте первый пост
Sleepwalker Дайте ссылку на сайт,Тогда точно поможем
« Последнее редактирование: 02.02.2019, 01:32:42 от arma »
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #13 : 04.02.2019, 13:34:49 »
Спасибо за ответы, друзья. Боюсь это даже и не Wordpress. Сайт 2002 года, прогонял через все сервис -определить cms так и не смог.
Обязательно предоставлю ссылку, как только хостер перезальет материалы.
*

Sleepwalker

  • Осваиваюсь на форуме
  • 30
  • 0 / 0
Re: Вопрос по кодировке
« Ответ #14 : 05.02.2019, 11:28:30 »
Проблема решена изменением кодировки в местном аналоге шаблона.
Еще раз, всем спасибо за помощь)
« Последнее редактирование: 05.02.2019, 15:52:35 от Sleepwalker »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не вставляется видео из Youtube в Joomla 3. (вопрос внутри)

Автор IamAsk YouQuestion

Ответов: 4
Просмотров: 135
Последний ответ 02.08.2019, 00:54:24
от IamAsk YouQuestion
Вопрос по модулям и расширениям сайта Joomla!

Автор Hazarin

Ответов: 6
Просмотров: 237
Последний ответ 10.06.2019, 10:06:11
от voland
Вопрос по роутингу компонента com_content

Автор voprospoj3

Ответов: 13
Просмотров: 374
Последний ответ 19.05.2019, 23:59:49
от sivers
Вопрос по компоненту добавления отзывов JoomTestimonials

Автор manexat

Ответов: 0
Просмотров: 85
Последний ответ 17.04.2019, 19:11:54
от manexat
Вопрос по выводу материалов (Блог категории)

Автор Igoritaly

Ответов: 13
Просмотров: 1933
Последний ответ 15.04.2019, 21:27:22
от sivers