0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 723 Просмотров
*

Nehed

  • Новичок
  • 1
  • 0 / 0
  • Бум!
Подскажите это обязательно обновлять сайт до последней версии. Смотрели совместимость с компонентами, так там 50% не совместимы. Как я понимаю при обновлении некоторые компоненты, плагины и модули перестанут функционировать  *ОХ-Х-Х*
« Последнее редактирование: 24.08.2021, 12:46:37 от Taatshi »
*

gartes

  • Завсегдатай
  • 1774
  • 137 / 5
  • Е = mс²
Как я понимаю при обновлении некоторые компоненты, плагины и модули перестанут функционировать
Скорее Всего Да !  - Но если сильно нужно то их можно полечить ( заставить работать )


Подскажите это обязательно обновлять сайт до последней версии.
Ни кто не принуждает это делать - Но есть очень много плюсов в этом. Это -скорость работы, -безопасность, -возможность устанавливать свежие компоненты.
К примеру я как разработчик - пишу по новым стандартам и мне побоку обратная совместимость - так как для этого есть обновления ! )
*

SeBun

  • Живу я здесь
  • 3993
  • 256 / 4
  • @SeBun48
Подскажите это обязательно обновлять сайт до последней версии. Смотрели совместимость с компонентами, так там 50% не совместимы. Как я понимаю при обновлении некоторые компоненты, плагины и модули перестанут функционировать
Взять ту же Joomla (не касаясь вопросов расширений). В последнем релизе Joomla! 3.9.26 было закрыто две уязвимости, которые имеются в версиях Joomla 3.0.0 - 3.9.25. Следовательно, при нецелевом взломе и в случае, если Joomla! ниже версии 3.9.26, эксплойт сработает и ваш сайт будет взломан. А обновлять или нет - решайте сами.
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

Taatshi

  • Глобальный модератор
  • 5257
  • 480 / 1
  • Верстаем и кодим. Обращайтесь ;)
Судя по тому, что вопрос в ветке 4 - Вы хотите обновить Joomla до 4 версии? Не надо этого делать. Она еще не готова.
ВЕРСТКА, САЙТЫ ПОД КЛЮЧ, УДАЛЕНИЕ ВИРУСОВ, МИГРАЦИЯ НА JOOMLA 3, ОБНОВЛЕНИЕ  |  ОТЗЫВЫ 
Связь: telegram - Taatshi, почта - Taatshi на яндексе, Skype - Taatshi
*

Отпад

  • Осваиваюсь на форуме
  • 29
  • 0 / 0
Привет всем!

нужна помощь при обновлении выдает
Error: Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin()

я почитал и понял что это устаревшая функция: CMSApplication :: isSite и CMSApplication :: isAdmin были удалены, поскольку добавление ConsoleApplication и ApiApplication может давать вводящие в заблуждение результаты. Пожалуйста, используйте CMSApplication :: isClient

Внешний интерфейс

JFactory :: getApplication () -> isClient ('site')
Возвращает истину, если выполняется в Joomla! веб-интерфейс.
Администратор / Бэкэнд

JFactory :: getApplication () -> isClient ('administrator')
Возвращает истину, если выполняется в Joomla! бэкэнд / администратор сайта.
Администратор / Бэкэнд

JFactory :: getApplication () -> isClient ('установка')
Возвращает истину, если выполняется в Joomla! установка

НО как это проверить я не понимаю... может кто подскажет как заменить?? ((((

*

ShopES

  • Захожу иногда
  • 285
  • 4 / 0
а может не спешить с обновлением?
большая часть компонентов еще не поддерживается.
смысл обновлять
*

Отпад

  • Осваиваюсь на форуме
  • 29
  • 0 / 0
проверить то надо какие плагины мешают. вот выяснил что не работают и эти плагины старые до версии 3.7 Joomla и там должны были поменяться
*

b2z

  • Глобальный модератор
  • 7129
  • 770 / 0
  • Разраблю понемногу
Чтобы проверить, что именно выдаёт ошибку - включаем в общих настройках отладку. Тогда вместе с ошибкой будет трейс до файла, который её генерирует.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Перенесено: Ошибка шаблона сайта «Cassiopeia» на Joomla 4

Автор b2z

Ответов: 0
Просмотров: 30
Последний ответ 17.09.2021, 09:38:55
от b2z