0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 3063 Просмотров
*

vova-focs

  • Осваиваюсь на форуме
  • 19
  • 0 / 0
Проблемы с кодировкой
« : 06.07.2008, 10:30:51 »
привет всем.

Только установил этот компонент, но к сожалению обнаружил проблему с кодировкой, а именно в списке цветов. Пока вроде все норм. и нет никаких проблем нигде. Модуль цветов я не устанавливал ...вот скрины, все станет ясно:



[вложение удалено Администратором]
*

vova-focs

  • Осваиваюсь на форуме
  • 19
  • 0 / 0
Re: Проблемы с кодировкой
« Ответ #1 : 06.07.2008, 10:32:43 »
в phpmyadmin, в базе данных так же были отображены. Я их поменял...и как вы видите на скрине все норм. Но в админке к сожалению так же.

[вложение удалено Администратором]
*

Alex Revo

  • Moderator
  • 1994
  • 109 / 0
Re: Проблемы с кодировкой
« Ответ #2 : 06.07.2008, 20:56:32 »
Посмотрите какое сопоставление стоит у таблицы и плей внутри нее.
*

vova-focs

  • Осваиваюсь на форуме
  • 19
  • 0 / 0
Re: Проблемы с кодировкой
« Ответ #3 : 06.07.2008, 23:40:55 »
Alex я новичек в этом деле, совсем не понимаю что это такое. сможете обьяснить.  очень нужно
*

dzaharov

  • Осваиваюсь на форуме
  • 43
  • 0 / 0
Re: Проблемы с кодировкой
« Ответ #4 : 06.07.2008, 23:48:59 »
Кстати, у меня такая же проблема появилась - в админке, во всех модулях вместо текста, точнее на месте только русских букв, стоят знаки вопроса (?).
Где рыть что делать?
*

Alex Revo

  • Moderator
  • 1994
  • 109 / 0
Re: Проблемы с кодировкой
« Ответ #5 : 07.07.2008, 09:15:01 »
Откройте структуру таблиц вашей БД и убедитесь что у таблицы, например, #__autobb_colors сравнение cp1251_general_ci
Потом откройте саму таблицу и убедитесь что поле title    имеет сравнение cp1251_general_ci

Если там другие значения, значит в этом и есть ваша проблема. Выберите нужный элемент и измените его параметры. В phpmyadmin это труда не составит.
*

dzaharov

  • Осваиваюсь на форуме
  • 43
  • 0 / 0
Re: Проблемы с кодировкой
« Ответ #6 : 07.07.2008, 13:37:18 »
Нет, проблема в чем-то другом.
Везде, и в таблицах и непосредственно у полей таблицы стоит кодировка cp1251_general_ci
Кодировка сайта в общих установках стоит ru_RU.CP1251
*

4uda4ka

  • Осваиваюсь на форуме
  • 13
  • 0 / 0
  • Не так страшен php, как его малюют.
Re: Проблемы с кодировкой
« Ответ #7 : 21.12.2009, 23:05:05 »
эхххххх, я уже и Sypex Dumper'ом пыталась кодировку даже менять, но все равно - сайт на utf8, а таблицы компонента на cp151. Переписываю "кракозяюры" вручную в pma, но тогда в админке, там где все по-русски отображалось,  появляются знаки вопроса....Замкнутый круг. Кто сталкивался?  или что-то неправильно сделала? Подскажите, пожалуйста!
*

MJSN1k

  • Захожу иногда
  • 114
  • 6 / 0
  • Хочу уснуть, прыгающие овцы стареют и дохнут...
Re: Проблемы с кодировкой
« Ответ #8 : 26.12.2009, 12:57:29 »
Через программу какую-нибудь типа PHP Expert Editor открыть либо файлы модуля и поменять кодировку там?
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

[FAQ] Проблемы с фото в com_autobb

Автор stin

Ответов: 145
Просмотров: 48023
Последний ответ 13.01.2013, 23:52:58
от Alex Revo
Проблемы с навигационным меню

Автор souzmd

Ответов: 1
Просмотров: 1404
Последний ответ 30.04.2010, 10:36:31
от Alex Revo
Проблемы при установке компонента

Автор astana

Ответов: 1
Просмотров: 1774
Последний ответ 18.04.2009, 19:14:49
от Alex Revo
AutoBB 2.3 проблема с кодировкой...

Автор Danko

Ответов: 1
Просмотров: 1919
Последний ответ 14.11.2008, 22:52:21
от Alex Revo
Проблемы с модулями

Автор SnakeBite

Ответов: 4
Просмотров: 2817
Последний ответ 04.05.2008, 08:12:00
от Alex Revo