0 Пользователей и 1 Гость просматривают эту тему.
  • 145 Ответов
  • 49610 Просмотров
*

sampoisk

  • Захожу иногда
  • 51
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #120 : 19.02.2011, 10:04:27 »
Спасибо огромнейшее! Заработало ^-^
*

brus69

  • Осваиваюсь на форуме
  • 14
  • 0 / 0
Не выводиться главное фото
« Ответ #121 : 17.03.2011, 10:35:55 »

не выводиться фотография
в чем может быть проблема?
Joomla 1.5.22  AutoBB REV 2.3
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #122 : 17.03.2011, 10:44:12 »
см. посты выше
*

eX

  • Захожу иногда
  • 256
  • 72 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #123 : 17.03.2011, 10:44:45 »
*

brus69

  • Осваиваюсь на форуме
  • 14
  • 0 / 0
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #125 : 17.03.2011, 11:46:15 »
См. рекомендации в первом посте, добавьте памяти через .htaccess
*

brus69

  • Осваиваюсь на форуме
  • 14
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #126 : 17.03.2011, 11:59:12 »
прочитал все посты перепробывал несколько вариановт без результатно в  .htaccess добавил
php_value memory_limit 64M всё без результатно сайт tver-am.ru
« Последнее редактирование: 17.03.2011, 12:02:31 от brus69 »
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #127 : 17.03.2011, 13:23:26 »
Включите показ ошибок и читайте логи сервера.
*

klf

  • Новичок
  • 6
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #128 : 01.05.2011, 19:32:50 »
Подскажите, пожалуйста, у меня autobb работает на Joomla 1.5.15 в режиме совместимости с Joomla 1.0.
Все работало нормально, но когда количество объявлений с фото увеличилось более 1000 (на даный момент получается более 4000) - страницы начали загружаться очень долго.
Проходит 15-20 секунд до того, когда на странице хоть что нибудь начинает появляться)
Если просто удалить фото - не помогает.
Помогает только если в таблице jos_autobb_photos удалить часть записей.
Я оставил около 1000 - началось загружаться через 10-15 секунд.
В чем может быть причина?

Вот данные загрузки (только на страницах списка объявлений):
•Информация•
Application afterLoad: 0.000 seconds, 0.52 MB
Application afterInitialise: 0.098 seconds, 4.52 MB
Application afterRoute: 0.108 seconds, 4.98 MB
Application afterDispatch: 6.397 seconds, 7.56 MB
Application afterRender: 6.742 seconds, 8.52 MB

На других страницах сайта (на autoBB) ситуация терпимая:
•Информация•
Application afterLoad: 0.001 seconds, 0.51 MB
Application afterInitialise: 0.160 seconds, 4.78 MB
Application afterRoute: 0.174 seconds, 5.20 MB
Application afterDispatch: 0.413 seconds, 8.06 MB
Application afterRender: 0.764 seconds, 8.88 MB

Это нормальная работа AutoBB или у меня что-то не так работает?
И что такое Application afterDispatch и Application afterRender?
« Последнее редактирование: 02.05.2011, 14:40:54 от klf »
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #129 : 03.05.2011, 09:54:57 »
Покажите структуру таблицы БД, интересуют какие у вас стоят индексы.
*

klf

  • Новичок
  • 6
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #130 : 03.05.2011, 11:36:00 »
jos_autobb_photos:

Код
-- phpMyAdmin SQL Dump
-- version 3.3.7deb3build0.10.10.1
-- http://www.phpmyadmin.net
--
-- Хост: localhost
-- Время создания: Май 03 2011 г., 00:03
-- Версия сервера: 5.1.49
-- Версия PHP: 5.3.3-1ubuntu9.3

SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";


/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;

--
-- База данных: `autovariant`
--

-- --------------------------------------------------------

--
-- Структура таблицы `jos_autobb_photos`
--

CREATE TABLE IF NOT EXISTS `jos_autobb_photos` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `title` varchar(100) NOT NULL DEFAULT '',
  `msgid` int(11) NOT NULL DEFAULT '0',
  PRIMARY KEY (`id`)
) ENGINE=MyISAM  DEFAULT CHARSET=cp1251 AUTO_INCREMENT=3631 ;

--
-- Дамп данных таблицы `jos_autobb_photos`
--

INSERT INTO `jos_autobb_photos` (`id`, `title`, `msgid`) VALUES
(2001, '2347/20101205220311-2347-0.jpg', 2347),
(2002, '2348/20101205220311-2348-0.jpg', 2348),
(2003, '2349/20101205220311-2349-0.jpg', 2349),
(2004, '2350/20101205220311-2350-0.jpg', 2350),


jos_autobb_messages:

Код

SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";


/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;

--
-- База данных: `autovariant`
--

-- --------------------------------------------------------

--
-- Структура таблицы `jos_autobb_messages`
--

CREATE TABLE IF NOT EXISTS `jos_autobb_messages` (
  `id` int(11) NOT NULL AUTO_INCREMENT,
  `createDate` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `modifyDate` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `expirationDate` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
  `sticked` tinyint(1) NOT NULL DEFAULT '0',
  `ordering` int(11) NOT NULL DEFAULT '0',
  `front` tinyint(1) NOT NULL DEFAULT '0',
  `published` tinyint(1) NOT NULL DEFAULT '1',
  `name` varchar(100) NOT NULL DEFAULT '',
  `company` varchar(100) NOT NULL DEFAULT '',
  `phone1` varchar(100) NOT NULL DEFAULT '',
  `since1` int(11) NOT NULL DEFAULT '0',
  `till1` int(11) NOT NULL DEFAULT '0',
  `phone2` varchar(100) NOT NULL DEFAULT '',
  `since2` int(11) NOT NULL DEFAULT '0',
  `till2` int(11) NOT NULL DEFAULT '0',
  `phone3` varchar(100) NOT NULL DEFAULT '',
  `since3` int(11) NOT NULL DEFAULT '0',
  `till3` int(11) NOT NULL DEFAULT '0',
  `email` varchar(255) NOT NULL DEFAULT '',
  `password` varchar(100) NOT NULL DEFAULT '',
  `city` int(11) NOT NULL DEFAULT '0',
  `userid` int(11) NOT NULL DEFAULT '0',
  `category` int(11) NOT NULL DEFAULT '0',
  `vendor` int(11) NOT NULL DEFAULT '0',
  `model` int(11) NOT NULL DEFAULT '0',
  `modification` varchar(100) NOT NULL DEFAULT '',
  `color` int(11) NOT NULL DEFAULT '0',
  `year` int(11) NOT NULL DEFAULT '0',
  `bodytype` int(11) NOT NULL DEFAULT '0',
  `price` int(11) NOT NULL DEFAULT '0',
  `currency` int(11) NOT NULL DEFAULT '0',
  `engine` int(11) NOT NULL DEFAULT '0',
  `fuelinputcity` decimal(4,1) NOT NULL DEFAULT '0.0',
  `fuelinputcountry` decimal(4,1) NOT NULL DEFAULT '0.0',
  `fuelinputboth` decimal(4,1) NOT NULL DEFAULT '0.0',
  `mileage` int(11) NOT NULL DEFAULT '0',
  `mileage_unit` int(11) NOT NULL DEFAULT '0',
  `drive` int(11) NOT NULL DEFAULT '0',
  `volume` int(11) NOT NULL DEFAULT '0',
  `power` int(11) NOT NULL DEFAULT '0',
  `speed` int(3) NOT NULL DEFAULT '0',
  `transmission` int(11) NOT NULL DEFAULT '0',
  `state` int(11) NOT NULL DEFAULT '1',
  `steering_wheel` tinyint(1) NOT NULL DEFAULT '0',
  `wrangle` tinyint(1) NOT NULL DEFAULT '0',
  `vin` varchar(100) NOT NULL DEFAULT '',
  `vin2` varchar(100) NOT NULL DEFAULT '',
  `customs` tinyint(1) NOT NULL DEFAULT '0',
  `additional` text,
  `views` int(11) NOT NULL DEFAULT '0',
  `en` tinyint(1) NOT NULL DEFAULT '0',
  `cr` tinyint(1) NOT NULL DEFAULT '0',
  `lastViewIP` varchar(20) DEFAULT NULL,
  `ip` varchar(20) DEFAULT NULL,
  `banned` tinyint(1) NOT NULL DEFAULT '0',
  PRIMARY KEY (`id`),
  KEY `createDate` (`createDate`),
  KEY `expirationDate` (`expirationDate`),
  KEY `vendor` (`vendor`),
  KEY `model` (`model`),
  KEY `city` (`city`),
  KEY `state` (`state`)
) ENGINE=MyISAM  DEFAULT CHARSET=cp1251 AUTO_INCREMENT=4407 ;

--
-- Дамп данных таблицы `jos_autobb_messages`
--

INSERT INTO `jos_autobb_messages` (`id`, `createDate`, `modifyDate`, `expirationDate`, `sticked`, `ordering`, `front`, `published`, `name`, `company`, `phone1`, `since1`, `till1`, `phone2`, `since2`, `till2`, `phone3`, `since3`, `till3`, `email`, `password`, `city`, `userid`, `category`, `vendor`, `model`, `modification`, `color`, `year`, `bodytype`, `price`, `currency`, `engine`, `fuelinputcity`, `fuelinputcountry`, `fuelinputboth`, `mileage`, `mileage_unit`, `drive`, `volume`, `power`, `speed`, `transmission`, `state`, `steering_wheel`, `wrangle`, `vin`, `vin2`, `customs`, `additional`, `views`, `en`, `cr`, `lastViewIP`, `ip`, `banned`) VALUES
(2001, '2010-11-29 18:37:29', '2010-11-29 18:37:29', '2012-12-21 18:37:29', 0, 0, 1, 1, 'Анатолий', '', '048-7877986', 10, 21, '', 10, 21, '', 10, 21, '', '', 1132, 0, 601, 100, 1182, '', 25, 1989, 0, 2850, 2, 2, '0.0', '0.0', '0.0', 0, 0, 0, 0, 0, 0, 0, 1, 0, 0, '', '', 0, '', 32, 0, 0, '178.74.252.119', '109.108.239.167', 0),
(2002, '2010-11-29 18:37:29', '2010-11-29 18:37:29', '2012-12-21 18:37:29', 0, 0, 1, 1, 'Игорь', '', '0939598201', 10, 21, '', 10, 21, '', 10, 21, '', '', 1132, 0, 601, 33, 332, '', 15, 1985, 0, 1600, 2, 2, '0.0', '0.0', '0.0', 100, 0, 0, 0, 0, 0, 0, 1, 0, 0, '', '', 0, 'Автомобиль в хорошем состоянии,нигде не ржавая,очень экономная,сигнализация,ксенон,хэчбек,магнитафон.', 40, 0, 0, '173.242.125.196', '109.108.239.167', 0),
(2003, '2010-12-23 18:37:29', '2010-12-23 18:37:29', '2012-12-21 18:37:29', 0, 0, 1, 1, '', '', '', 10, 21, '', 10, 21, '', 10, 21, '', '', 1132, 0, 601, 161, 5265, '', 9, 2003, 0, 2000, 0, 1, '0.0', '0.0', '0.0', 76, 0, 0, 0, 0, 0, 0, 1, 0, 0, '', '', 0, '', 19, 0, 0, '178.74.252.119', '109.108.239.167', 0),
(2004, '2010-11-29 18:37:29', '2010-11-29 18:37:29', '2012-12-21 18:37:29', 0, 0, 1, 1, 'ЮРИЙ', '', '066 34 31 355', 10, 21, '', 10, 21, '', 10, 21, '', '', 1132, 0, 601, 161, 96792, '', 9, 2003, 0, 2000, 0, 1, '0.0', '0.0', '0.0', 76, 0, 0, 0, 0, 0, 0, 1, 0, 0, '', '', 0, '', 27, 0, 0, '81.19.66.84', '109.108.239.167', 0);
« Последнее редактирование: 03.05.2011, 11:43:15 от klf »
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #131 : 03.05.2011, 13:02:24 »
Добавьте эти индексы в БД:
ALTER TABLE `jos_autobb_messages` ADD INDEX ( `published` )
ALTER TABLE `jos_autobb_photos` ADD INDEX ( `msgid` )
ALTER TABLE `jos_autobb_messages` ADD INDEX `stick_ord_modd` ( `sticked` , `ordering` , `modifyDate` )
ALTER TABLE `jos_autobb_config` ADD INDEX ( `category` )
*

legionnaire

  • Осваиваюсь на форуме
  • 20
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #132 : 03.05.2011, 16:27:43 »
Привет всем, проблема в загрузке фоток, точней в их отображении! Поставил макс кол-во фоток 50. И загрузил на одно объявление 26, высветилось же 10 фоток! Хотя написано что загружен 26! В чем может быть проблема, всё как в первом посту сделал и проверил!
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #133 : 03.05.2011, 20:35:53 »
Компонент не выводит более 11 фото в объявлении это ограничение задано в коде шаблона объявления.
*

legionnaire

  • Осваиваюсь на форуме
  • 20
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #134 : 03.05.2011, 20:58:04 »
печально) будем ковырять шаблон значит))
*

legionnaire

  • Осваиваюсь на форуме
  • 20
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #135 : 03.05.2011, 21:27:31 »
Компонент не выводит более 11 фото в объявлении это ограничение задано в коде шаблона объявления.

Спасибо, нашёл практически без труда и добавил. Кому интересно...
файл autobb.html.php, найдите строчки

Код
$gomer_1 = $gomer_1 + 1;
      if ($gomer_1 == 1 or $gomer_1 < 4) {
      echo "<div class='gomer-foto-heigt'>".$str."</div>";
}
      if ($gomer_1 == 4) {echo "</td></tr><tr><td align='center' valign='top' class='gomer-foto-width'>";}
if ($gomer_1 == 4 or $gomer_1 == 5) {echo $str;}
if ($gomer_1==5) echo '</td></tr><tr><td align="center" valign="top" class="gomer-foto-width" colspan="2">';
if ($gomer_1>=6 and $gomer_1<=8) echo $str;
if ($gomer_1==8) echo '</td></tr><tr><td align="center" valign="top" class="gomer-foto-width" colspan="2">';
if ($gomer_1>=9 and $gomer_1<=11) echo $str;


и добавьте сразу же    
   
Код
if ($gomer_1==11) echo '</td></tr><tr><td align="center" valign="top" class="gomer-foto-width" colspan="2">';
if ($gomer_1>=12 and $gomer_1<=14) echo $str;
if ($gomer_1==14) echo '</td></tr><tr><td align="center" valign="top" class="gomer-foto-width" colspan="2">';
if ($gomer_1>=15 and $gomer_1<=17) echo $str;
if ($gomer_1==17) echo '</td></tr><tr><td align="center" valign="top" class="gomer-foto-width" colspan="2">';
if ($gomer_1>=18 and $gomer_1<=20) echo $str;

думаю закономерность разглядеть будет легко, в моем тут коде макс число фоток 20, так можно ещё больше сделать=)
« Последнее редактирование: 03.05.2011, 21:33:45 от legionnaire »
*

klf

  • Новичок
  • 6
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #136 : 03.05.2011, 22:04:47 »
А что конкретнее происходит при добавлении индексов в БД?

Как в моем случае:
ALTER TABLE `jos_autobb_messages` ADD INDEX ( `published` )
ALTER TABLE `jos_autobb_photos` ADD INDEX ( `msgid` )
ALTER TABLE `jos_autobb_messages` ADD INDEX `stick_ord_modd` ( `sticked` , `ordering` , `modifyDate` )
ALTER TABLE `jos_autobb_config` ADD INDEX ( `category` )
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #137 : 03.05.2011, 22:23:53 »
Будет намного более быстрее происходить выборка данных и соотв. время загрузки страницы увеличится.
*

747

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #138 : 20.12.2011, 09:21:57 »
Посмотрел на сайт.
Проблема в выполнении скриптом:

<img alt="Продажа Toyota Harrier" src="http://www.kamen-na-obi.com/index2.php?no_html=1&amp;option=com_autobb&amp;task=photo&amp;size=middle&amp;id=17" name="largeimage" id="middle"/>

т.е. получается, что по
index2.php?no_html=1&amp;option=com_autobb&amp;task=photo&amp;size=middle&amp;id=17
не происходит генерация (по коду) изображения.

Надо смотреть более детально через FTP отследить в каком именно месте возникает трабл.

Аналогичная проблема, права стоят, гд стоит, сайт включен. exit(); прописывал. Проблема только с большой фоткой центральной. При загрузке страницы она появляется на мгновение потом исчезает. Проблема вылезла после включения кэша на сайте.
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #139 : 20.12.2011, 09:54:44 »
Скорее всего у вас проблема с CSS эффекта lightbox, его подключение нужно перенести в шаблон.
*

747

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #140 : 20.12.2011, 19:18:16 »
Решил вопрос. Проблема была не в компоненте, просто на сайт вирус прицепился, восстановил данные из бекапа.
*

amalcev

  • Новичок
  • 8
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #141 : 24.12.2011, 00:25:34 »
Доброй ночи.

Уважаемые гуру, долго борюсь уже, но решение найти не могу. Все решения проблемы, предложенные ТС - выполнил...

Проблема следующего характера:

Тестовый пользователь добавил объявление, но фото добавлено не было.

Я попробывал сделать это через админку - но "фиг"...

У меня показывается, что уже есть "основное фото" - но его нет.
После этого я пытался добавить несколько объявлений с фото, проблема неизменна...
фото даже на фтп не загружаются. Вот скрин

http://sharepix.ru/136647uo24/
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #142 : 26.12.2011, 08:47:59 »
Проверьте права на папку с фото и изучайте логи ошибок сервера
*

amalcev

  • Новичок
  • 8
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #143 : 27.12.2011, 00:30:54 »
дурак я товарищи. Большого объёма фото загружал, без предварительных настроек...
*

mariavto

  • Осваиваюсь на форуме
  • 13
  • 0 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #144 : 13.01.2013, 23:23:35 »
 в объявлении при увеличении не срабатывает lightbox и почему то кидает на оригинал фото, где копать ?)
*

Alex Revo

  • Moderator
  • 1995
  • 109 / 0
Re: [FAQ] Проблемы с фото в com_autobb
« Ответ #145 : 13.01.2013, 23:52:58 »
проверьте подключение js файла lithbox, попробуйте отключить кеширование
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

И все же, кто нибудь поможет разобраться? mod_autobb_latest = пропадают фото

Автор htmlcss

Ответов: 1
Просмотров: 2811
Последний ответ 30.10.2013, 20:23:38
от digor1
При выводе на главную обьявлений, пропадают фото

Автор htmlcss

Ответов: 4
Просмотров: 3385
Последний ответ 20.06.2013, 15:08:01
от htmlcss
Проблема с отображением фото

Автор muhammad23

Ответов: 0
Просмотров: 2601
Последний ответ 16.05.2013, 14:55:16
от muhammad23
Как сделать, что бы при нажатии на фото или добавить стрелочки, фото менялись по порядку

Автор pinkfloyd

Ответов: 25
Просмотров: 7688
Последний ответ 22.09.2012, 13:30:41
от ayrik
Ресайз фото

Автор DarkSideRnD

Ответов: 5
Просмотров: 2418
Последний ответ 18.01.2012, 20:25:11
от Alex Revo