0 Пользователей и 1 Гость просматривают эту тему.
  • 20 Ответов
  • 3524 Просмотров
*

rom73

  • Осваиваюсь на форуме
  • 34
  • 4 / 0
Прошу помощи! Вся надежда на вас! Сразу предупреждаю, что я чайник(( Суть проблемы в следующем - зашёл вчера ночью в админку, убрал несколько новостей с главной страницы. Всё работало. После этого зашёл в общие настройки в админке, прошёлся по закладкам, ничего не менял. Перед выходом нажал сохранить. После этого сайт перестал грузиться, выдавая вот такое сообщение - Parse error: syntax error, unexpected ';', expecting T_VARIABLE or '$' in /home/infosocc/public_html/configuration.php on line 72. Зашёл в configuration.php и убрал там вообще знак "$". После этого появляется сообщение, что "Сайт временно недоступен. Невозможно подключиться к базе данных". Обратился в службу поддержки, где мне посоветовали вернуть знак "$" на место. Я так и сделал, в итоге получил опять "Parse error: syntax error". После чего в службе поддержки мне сказали, что это проблемы со скриптом и что в их компетенцию не входит исправление его работы. Их понять, конечно, можно...Но мне то, что делать? В общем, надеюсь на вашу помощь!
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #1 : 29.11.2008, 16:48:45 »
Напишите мне в аску помогу !
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #2 : 29.11.2008, 16:49:59 »
или приложите файл конфига к сообщению, токо пароли к бд закройте звездочками
---
проверьте почту ;)
« Последнее редактирование: 29.11.2008, 17:07:39 от ShadowXak »
*

rom73

  • Осваиваюсь на форуме
  • 34
  • 4 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #3 : 29.11.2008, 17:07:23 »
Вот прилагаю конфиг. Спасибо, что откликнулись!

[вложение удалено Администратором]
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #4 : 29.11.2008, 17:10:23 »
так у вас половина конфигуратора просто отсутствует, видимо при сохранении произошла ошибка тайм аута и файл не дозаписался
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #5 : 29.11.2008, 17:13:06 »
сейчас сделайте слейдующее возьмите конфигуратор из установочного файла и заполните его данными из того что на хостинге лежит, затем залейте новый конфиг и проследуйте в настройку через админки и отконфигурируйте его поновой!
*

rom73

  • Осваиваюсь на форуме
  • 34
  • 4 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #6 : 29.11.2008, 17:16:16 »
Ок! Спасибо, сейчас попробую так сделать
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #7 : 29.11.2008, 17:32:12 »
напишите хоть получилось или нет
*

rom73

  • Осваиваюсь на форуме
  • 34
  • 4 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #8 : 29.11.2008, 17:44:19 »
конечно напишу, пока ничего путного не вышло(
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #9 : 29.11.2008, 18:15:48 »
ну если вообще никак, то сделайте бекап базы данных и файлов сайта, затем загрузите инсталл папку и удалите конфиг файл с хостинга - произведите поновой установку джумлы - затем загрузите файлы из бекапа (без поврежденного конфига) и залейте БД из бекапа ;)
*

rom73

  • Осваиваюсь на форуме
  • 34
  • 4 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #10 : 29.11.2008, 18:45:46 »
Так вроде бы заработало. По крайней мере и админка и сайт грузятся. Правда небольшие проблемы с кодировкой возникли, но это я сейчас разбираться буду, надо просто донатроить всё как было. Беспокоит другое - вылез один косяк. При попытке изменения через админку конфигурации, могу изменить, например название сайта, сохраняю, следо меняю локализацию -  всё сбрасывает и сайт опять не грузится после этого. Несколько раз так пробовал. Помогает только замена файла конфигурации с которого я восстанавливал всё. Пока решил ничего больше не трогать, но почему такое происходит непонятно - это же ненормально, а причины понять пока не могу. В любом случае, ShadowXak - ОГРОМНОЕ СПАСИБО! Может и я когда на что-нибудь пригожусь.
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #11 : 29.11.2008, 18:52:31 »
Возможно ;)
---
Короче у тебя через админку не происходит сохранение, потому что (как я и писал выше) тайм-аут обработки скрипта!
---
обратись к хостеру пусть подымут время с 30 секунд до 45 секунд.
---
з.ы. Не забудь восстановленный конфиг сохранить на всякий случай ;)
у меня по крайней мере на localhost-e в папке temp всегда хранятся файлы конфигурации сайтов из интернета или внутри корпоративных сайтов!
*

rom73

  • Осваиваюсь на форуме
  • 34
  • 4 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #12 : 29.11.2008, 19:37:33 »
конфиг я первым делом сохранил)) а из поддержки ответили вот что "max_execution_time = 150 - не маленькое значение. К тому же у Вас есть возможность функциями PHP увеличить время выполнения скрипта. На самом деле, в этом вряд ли проблема. Она скорее в самом скрипте. "  Даже не знаю, что и думать, до этого всё отлично работало, никаких новых компонентов, которые могли бы тормозить работу скрипта я не устанавливал в последнее время. Посмотрю как дальше себя админка вести будет...
*

ShadowXak

  • Завсегдатай
  • 1602
  • 162 / 6
  • no more programming
Re: Не грузятся ни сайт ни админка...
« Ответ #13 : 29.11.2008, 21:42:52 »
ну сказать то они все что угодно могли ;)
есть еще 1 сумашедшая идея отконфигурируйте на локалхосте, а потом просто вставте в конфиг файл пути до сайта и данные по подключению к бд из сохраненного файла ;) и залить на хостинг! (и боже упоси вам сново трогать конфиг файл), кстати поглядите что пишит лог сервера - файл error.log
*

nike

  • Захожу иногда
  • 79
  • 1 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #14 : 23.02.2009, 07:52:01 »
У меня возникла схожая проблема. На Denwer'e сделал сайт, выложил на хостинг: сервер выдает
Parse error: syntax error, unexpected T_VARIABLE in /home/сайт/public_html/auto/configuration.php on line 73
строка 73:
$mosConfig_useractivation = '1';
Может потому,  что на localhost у меня пароль к БД был пустой, а  на хостинге пришлось его (пароль) поставить, после чего в configuration.php
дописал строку $mosConfig_password = 'пароль'; и перезалил.
Помогите пож-та, третий день бьюсь уже !!!???!!!
*

MuraDweb

  • Захожу иногда
  • 267
  • 124 / 1
Re: Не грузятся ни сайт ни админка...
« Ответ #15 : 23.02.2009, 07:57:54 »
Приведи строки с 71 по 74
Яндекс.Деньги: 41001423568435
Webmoney: R 377548789269 | Z 421465848009 | E 126339514076 | U 413960261029
-
А, Вы читали ? Правила форума | FAQ J! 1.5 | FAQ J! 1.0
*

nike

  • Захожу иногда
  • 79
  • 1 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #16 : 23.02.2009, 08:35:57 »
$mosConfig_user = 'имя_пользователя';
$mosConfig_password = 'пароль'
$mosConfig_useractivation = '1';
$mosConfig_vote = '0';
*

MuraDweb

  • Захожу иногда
  • 267
  • 124 / 1
Re: Не грузятся ни сайт ни админка...
« Ответ #17 : 23.02.2009, 08:37:28 »
$mosConfig_user = 'имя_пользователя';
$mosConfig_password = 'пароль';
$mosConfig_useractivation = '1';
$mosConfig_vote = '0';

Точку с запятой забыл :)
Яндекс.Деньги: 41001423568435
Webmoney: R 377548789269 | Z 421465848009 | E 126339514076 | U 413960261029
-
А, Вы читали ? Правила форума | FAQ J! 1.5 | FAQ J! 1.0
*

nike

  • Захожу иногда
  • 79
  • 1 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #18 : 23.02.2009, 08:39:55 »
$mosConfig_password = 'пароль';
Точку с запятой забыл :)
Гениально!!! попробую перезалить. Только почему тогда ошибка в 73,а не в 72 строке?
*

MuraDweb

  • Захожу иногда
  • 267
  • 124 / 1
Re: Не грузятся ни сайт ни админка...
« Ответ #19 : 23.02.2009, 08:42:21 »
Только почему тогда ошибка в 73,а не в 72 строке?
хз, так работает интерпритатор ошибок php
Яндекс.Деньги: 41001423568435
Webmoney: R 377548789269 | Z 421465848009 | E 126339514076 | U 413960261029
-
А, Вы читали ? Правила форума | FAQ J! 1.5 | FAQ J! 1.0
*

nike

  • Захожу иногда
  • 79
  • 1 / 0
Re: Не грузятся ни сайт ни админка...
« Ответ #20 : 23.02.2009, 08:45:15 »
Спасибо *DRINK* и +1
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как переделать сайт, cозданный в Joomla Lavra Edition 2008 (1.0.15) на Joomla3x ?

Автор KrisKras

Ответов: 12
Просмотров: 2405
Последний ответ 21.02.2017, 15:15:17
от KrisKras
Нагрузка на CP (сайт маленький, <10 посетителей в сутки, <50 просмотров)

Автор silverkat

Ответов: 0
Просмотров: 2717
Последний ответ 02.04.2014, 15:00:08
от silverkat
Сломали сайт!

Автор VIGOPO

Ответов: 3
Просмотров: 6473
Последний ответ 06.12.2013, 15:46:50
от VIGOPO
Ошибки при заходе первый раз на сайт

Автор Omega

Ответов: 1
Просмотров: 2737
Последний ответ 09.04.2012, 20:13:46
от doctorgrif
Вставка счетчика Метрики на сайт

Автор MariyaM

Ответов: 2
Просмотров: 2769
Последний ответ 18.05.2011, 17:51:32
от MariyaM