0 Пользователей и 1 Гость просматривают эту тему.
  • 3 Ответов
  • 2573 Просмотров

Включаю стандартное SEO (SEF) в общих настройках и происходит следующее. На главной странице усе нормально, на страницах без категорий тоже, а вот на страницах относящихся к определенным категориям, т.е. ссылка типа site.ru/produkty/new.html, - не подключаются таблицы CSS и картинки в текстах. Причем при переходе на страницу все нормально, а при обновлении получается страница без шаблона и картинок.
Сравнил исходный код. Оказывается сперва появляется / перед сылкой

<link rel="stylesheet" href="/templates/system/css/system.css" type="text/css" />
<link rel="stylesheet" href="/templates/siteground-j15-51/css/template.css" type="text/css" />

<img src="/images/stories

А после обновления или после нажатия кнопки назад в браузере / не появляется:
<link rel="stylesheet" href="templates/system/css/system.css" type="text/css" />
<link rel="stylesheet" href="templates/siteground-j15-51/css/template.css" type="text/css" />

<img src="images/stories

И поэтому не отображается шаблон и картинки.  !!!???!!!
« Последнее редактирование: 05.04.2009, 18:37:47 от Марианна »

Забыл добавить у меня на хостинге PHP как fastCGI, а вот на локалке Денвер стоит и там PHP как модуль Apache - и этой проблемы нет.
Думал сделать на хостинге PHP как модуль Apache, но почему-то на страничке - права на папки - все папки стали не доступны на запись. Пришлось вернуть FCGI.

Нашел в чём была загвоздка.

У нас одновременно работали: стандартное кэширование (в общих настройках) и плагин cache (в плагинах). Я просто отключил плагин. Совместная работа давала ошибку.
*

Андрей777

  • Осваиваюсь на форуме
  • 10
  • 0 / 0
  • Будь проще - потянутся люди
такая же проблема, но совет не помог - появилась 404 ошибка. Еще есть идеи? или уточнения, может я неправильно правки сделал?
Было:
Код
	// Generate base tag (need to happen first)
$base = $document->getBase();
if(!empty($base)) {
  $strHtml .= $tab.'<base href="'.$document->getBase().'" />'.$lnEnd;
}

теперь:
Код
	// Generate base tag (need to happen first)
$base = $document->getBase();
if(!empty($base)) {
  $strHtml .= $tab.'<base href="'.JURI::base().'" />'.$lnEnd;
}
И еще - при включении SEF начинают повторяться index.php при выборе не главной страницы через меню :
http://www.blabla.com.ua/index.php/index.php/index.php/more-about-bla-bla
Подскажите, как исправить?
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Появилась проблема в метрике после установки sh404SEF

Автор Виктор.П.

Ответов: 6
Просмотров: 754
Последний ответ 22.04.2019, 18:00:22
от Виктор.П.
Проблема с кодировкой страницы ошибки sh404SEF

Автор vlasyukvlad

Ответов: 1
Просмотров: 762
Последний ответ 15.02.2018, 13:09:00
от capricorn
Размер тегов description и keywords при включении sh404SEF

Автор Olle

Ответов: 4
Просмотров: 2952
Последний ответ 07.02.2018, 16:12:00
от Artorius
При включении SEF ссылок некорректно отображаются страницы сайта

Автор Mari_ko

Ответов: 2
Просмотров: 843
Последний ответ 10.07.2017, 17:22:48
от Mari_ko
jEvents проблема с SEF (или не SEF ?)

Автор x1

Ответов: 0
Просмотров: 689
Последний ответ 03.10.2016, 16:08:21
от x1