0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 3218 Просмотров
*

Sanyo

  • Захожу иногда
  • 127
  • 11 / 0
Привет
При добавлении описания к фотографии, он после каждого тега сам добавляет <br />
К примеру добавляю таблицу:
Код
<table width="78%" border="1" cellspacing="0" cellpadding="0">
  <tr>
    <th>1</th>
    <th>2</th>
  </tr>
  <tr>
    <th>3</th>
    <th>4</th>
  </tr>
</table>

а при просмотре на сайте он отображает так:
<table width="78%" border="1" cellspacing="0" cellpadding="0"><br />
  <tr><br />
    <th>1</th><br />
    <th>2</th><br />
  </tr><br />
  <tr><br />
    <th>3</th><br />
    <th>4</th><br />
  </tr><br />
</table><br />

Перерыл все файлы галереи, так и не получилось убрать....  !!!???!!!
*

crazyASD

  • Давно я тут
  • 582
  • 26 / 2
Версия компонента самая свежая?
Сон разума порождает монстров
--
Фрилансом не занимаюсь. Никому ничего не должен. Отвечаю по мере знания и умения. -- JFusion - Наше всё! Joomla 1.5.23 SMF 1.1.15 JFusion 1.5.6 JComments 2.2.0 JoomGallery 1.5.6.4 JDownloads 1.8
*

gallah

  • Осваиваюсь на форуме
  • 46
  • 9 / 0
Вы, наверное, добавляете таблицу непосредственно в окошке Ассистента фото.
В этом случае действительно в конце каждой строки приписывается <br />

Например, если добавить ваш же код

Код
<table width="78%" border="1" cellspacing="0" cellpadding="0">
  <tr>
    <th>1</th>
    <th>2</th>
  </tr>
  <tr>
    <th>3</th>
    <th>4</th>
  </tr>
</table>

и просмотреть, как он выглядит в HTML-редакторе, то можно увидеть следующее:

Код
&lt;table width="78%" border="1" cellspacing="0" cellpadding="0"&gt;<br />  
&lt;tr&gt;<br />   
&lt;th&gt;1&lt;/th&gt;<br />   
&lt;th&gt;2&lt;/th&gt;<br /> 
&lt;/tr&gt;<br /> 
&lt;tr&gt;<br />   
&lt;th&gt;3&lt;/th&gt;<br />   
&lt;th&gt;4&lt;/th&gt;<br /> 
&lt;/tr&gt;<br />
&lt;/table&gt

Так что лучше вводите данные через HTML-редактор (к сведению - его кнопочка на панели так и выглядит: HTML)
« Последнее редактирование: 12.05.2009, 19:54:28 от gallah »
*

Sanyo

  • Захожу иногда
  • 127
  • 11 / 0
Version 1.0 BETA 1, BUILD 20080914

Хм.. думал и вправду из-за html редактора, отключил его вообще, написал всё вручную... всё равно на сайте <br />
Причем, захожу в БД смотрю описание фотографии, там таблица идет нормально, без <br /> :
Код
<table width="78%" border="1" cellspacing="0" cellpadding="0">
  <tr>
    <th>1</th>
    <th>2</th>
  </tr>
  <tr>
    <th>3</th>
    <th>4</th>
  </tr>
</table>

а уже когда смотрю сам сайт то к закрытому тегу добавляет <br /> не чего не пойму  :dry:
*

Sanyo

  • Захожу иногда
  • 127
  • 11 / 0
Вы, наверное, добавляете таблицу непосредственно в окошке Ассистента фото.
В этом случае действительно в конце каждой строки приписывается <br />

Да именннл, добавляю таблицу непосредственно в окошке Ассистента фото, и действительно добалвяет <br />
но я попробовал отключить полность визуальный редактор и прописал вручную, всё равно так же (
*

gallah

  • Осваиваюсь на форуме
  • 46
  • 9 / 0
Зачем отключать визуальный редактор?
Надо пройти Компоненты-JoomGallery-Ассистент фото, выбрать фото для редактирования. В открывшемся окне на панели визуального редактора выбрать HTML-редактор (кнопочка HTML) и в открывшемся окошке ввести нужный HTML-код.
Должно получиться без проблем
*

Sanyo

  • Захожу иногда
  • 127
  • 11 / 0
Неа, не получается...
Да и по сути, в БД описание фото хранится без <br /> а уже на самом frontend'e выводится с <br /> значит он где то обрабатывает содержимое "ОПИСАНИЯ" добавляя <br /> после каждого тега... Вот у меня так и не получилось найти где то в исходниках эту подстановку...
А ты у себя пробуешь и нормально вставляется?!

Версии выше вроде нету...
*

gallah

  • Осваиваюсь на форуме
  • 46
  • 9 / 0
Да и по сути, в БД описание фото хранится без <br /> а уже на самом frontend'e выводится с <br /> значит он где то обрабатывает содержимое "ОПИСАНИЯ" добавляя <br /> после каждого тега... Вот у меня так и не получилось найти где то в исходниках эту подстановку...
А ты у себя пробуешь и нормально вставляется?!

Да, без проблем. И выводится нормально.

Если в бд все верно, может выводится не из нее. Может кэш почистить?

P.s.: У меня последняя версия галереи - 1.5.0 Stable, на днях обновлялась
*

Sanyo

  • Захожу иногда
  • 127
  • 11 / 0
КЭШ вообще отлкючил :(
Попробую обновиться... что после скажет....
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

После обновления до JoomGallery 3.6 некорректно работает водяной знак

Автор Maffo

Ответов: 3
Просмотров: 129
Последний ответ 23.08.2022, 06:21:58
от marksetter
Режим отладки КАК убрать?

Автор Tanyaks

Ответов: 2
Просмотров: 1156
Последний ответ 07.12.2018, 15:32:59
от Tanyaks
JoomGallery. Как убрать сортировку

Автор Tanyaks

Ответов: 4
Просмотров: 1308
Последний ответ 06.12.2018, 16:46:48
от Tanyaks
Что за &quot;Ограниченные Категории&quot; и как убрать?

Автор Maffo

Ответов: 1
Просмотров: 1699
Последний ответ 23.08.2018, 13:46:31
от Maffo
Как убрать водяной знак с некоторых категорий JoomGallery или фото?

Автор nikaa.2009

Ответов: 0
Просмотров: 1289
Последний ответ 21.07.2018, 00:27:44
от nikaa.2009