Пропадают комментарии и исчезает форма добавления

  • 9 Ответов
  • 4270 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

taurus

  • Осваиваюсь на форуме
  • ***
  • 134
  • 4
  • Bolden.Ru
Доброй ночи.
Только что столкнулся с двумя странными проблемами.
В видеогалерее, построенной на Seyret включил поддержку Jcomments.
Добавил пару роликов, протестировал модуль последних комментариев - всё отображалось и подхватывалось нормально в течение месяца.
Сегодня подгрузил третий ролик в новую только что созданную видеокатегорию. Началось следующее.
1) Форма комментариев в новом ролике на мгновение появляется и тут же исчезает - остаётся пустое место. Это не зависит от того, в каком виде отображается форма - в свёрнутом или развёрнутом. Проблема имеет место во всех браузерах.
Вот тот самый ролик:

Ссылка удалена

2) Комментарии, ранее добавленные к одному из роликов и нормально отображавшиеся в модуле последних комментариев, теперь пропали - осталась только форма добавления комментариев. Что интересно, в данном случае она не исчезает, как в случае с новым роликом.
Вот ролик, к которому уже было несколько комментариев (они в колонке слева в модуле):

Ссылка удалена

То есть в 9 случаях из 10 я ранее добавленных комментариев не вижу. Правда форма добавления никуда не исчезает.
До этого никаких проблем не было.
Очистил и запретил всяческие кэши, убрал сжатие скриптов и CSS, но ничего не помогло. И что интересно, - раньше то с двумя роликами (без негритят) всё отображалось идеально.
« Последнее редактирование: 07.10.2009, 19:58:47 от taurus »

*

smart

  • Администратор
  • *******
  • 6843
  • 1297
  • снова дома...
Посмотрите вот этот пост: интеграция Jcomments+Seyret 0.2.7.9, это касательно первой проблемы. А по второй - посмотрю чуть попозже, когда буду ковырять этот Seyret (там оказывается еще AJAX-ом можно листать видео, я этого не учел).

*

taurus

  • Осваиваюсь на форуме
  • ***
  • 134
  • 4
  • Bolden.Ru
Благодарю за молниеносный ответ :)

*

smart

  • Администратор
  • *******
  • 6843
  • 1297
  • снова дома...
Кстати, проверь, после изменений описанных в указанном топике, не вылечилась ли вторая проблема?

*

taurus

  • Осваиваюсь на форуме
  • ***
  • 134
  • 4
  • Bolden.Ru
Спасибо, почти всё заработало!
Удивляюсь, как автор Seyret допустил такую простую ошибку и забыл дописать префикс video-.
Форма перестала исчезать, а комментарии вернулись на место.
Только последний комментарий на негритянский хор почему-то не добавился в модуль последних комментариев. Хотя уведомление почте о нём было доставлено.
Помимо описанных правок пришлось, правда, отключить Ajax, поскольку происходит клонирование форм добавления комментариев. Теперь я оценил, насколько он был удобен..

*

smart

  • Администратор
  • *******
  • 6843
  • 1297
  • снова дома...
Ну автор в принципе ничего такого не сделал - ему был удобен такой идентификатор слоя и он его использовал. А то что он совпал с таким же слоем у меня в комментариях - не его вина. Это больше камень в мой огород, я должен был это предусмотреть.

А что касается проблем с AJAX, обещаю посмотреть на днях, может быть даже завтра...

*

taurus

  • Осваиваюсь на форуме
  • ***
  • 134
  • 4
  • Bolden.Ru
ОК!
Я уже спать. Завтра вставать в 6 утра...
Опа! Комментарий, наконец, вдруг всплыл в модуле
Ну, значит жизнь продолжается.
Спокойной ночи!

*

smart

  • Администратор
  • *******
  • 6843
  • 1297
  • снова дома...
Опа! Комментарий, наконец, вдруг всплыл в модуле
вполне возможно, что в модуле включено кэширование?

*

taurus

  • Осваиваюсь на форуме
  • ***
  • 134
  • 4
  • Bolden.Ru
Да, вероятно.
Во всех модулях настройки кэширования стоят по умолчанию. А плагин System-Cache включен, хотя в глобальных настройках кэширование отключено (до сих пор не могу понять, правда, каким образом они связаны - плагин System-Cache, и опция Включить кэширование в Глобальных настройках).

*

votalif

  • Новичок
  • *
  • 7
  • 0
Други, читаю ваши комментарии и ответы и прихожу в ужас, в сети нет ничего по проблеме... пропала форма добавления комментариев. на сайте все  по умолчанию... все было и бац... не ставили ни компоненты ни модули ни ни ни - что подскажете! Заранее спасибо!
Речь идет о компоненте: administrator/index.php?option=com_jcomments