0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 1740 Просмотров
*

nikitagon

  • Новичок
  • 6
  • 1 / 0
Добрый день!

У меня такая проблема:
когда включаю стандартный SEF в joomla RE, появляются проблемы с кодировкой. Вот такой код:
urlencode($row->title)
где $row -- параметр входной функции мамбота, $row->title содержит заголовок статьи

Так вот такой код
- при выключенном SEF дает такую строку: %C2%E2%E5%F0%F5+3D
- при ВКЛюченном дает такую: %D0%92%D0%B2%D0%B5%D1%80%D1%85+3D

Декодер говорит, что первая -- в cp1251, а вторая в utf8

Как с этим бороться? У меня из-за этого не работает запрос к БД, т.к. не понимает разных кодировок.

Спасибо заранее.
*

Mitrich

  • Захожу иногда
  • 289
  • 524 / 13
  • Все можно. Но сначала учиться, учиться и учиться.
Если ты только начинаешь вникать в Joomla - темы, советую начать с Joomla 1.5
т.к. линейка 1.0 поддерживается еще месяц и в июне поддержка будет закончена
*

nikitagon

  • Новичок
  • 6
  • 1 / 0
Если ты только начинаешь вникать в Joomla - темы, советую начать с Joomla 1.5

Нет, есть уже существующий и функционирующий сайт с большим потоком посетителей, на котором решили вкрутить ЧПУ, поэтому сменить платформу не получится.

Все равно, спасибо за ответ!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

После включения SEF ссылки не до конца становятся красивыми

Автор borro

Ответов: 3
Просмотров: 1021
Последний ответ 19.04.2020, 13:48:12
от robert
Кодировка в url joomla3.9

Автор suic

Ответов: 3
Просмотров: 479
Последний ответ 17.03.2020, 18:36:27
от gartes
Появилась проблема в метрике после установки sh404SEF

Автор Виктор.П.

Ответов: 6
Просмотров: 613
Последний ответ 22.04.2019, 18:00:22
от Виктор.П.
После переноса материалов из Joomla 1.5 в Joomla 3.8 появились вопросы по работе

Автор WeX

Ответов: 0
Просмотров: 701
Последний ответ 20.11.2017, 11:42:16
от WeX
слетело ЧПУ после переноса. Нужна помощь

Автор romerfak

Ответов: 4
Просмотров: 773
Последний ответ 24.09.2016, 23:20:41
от romerfak