0 Пользователей и 1 Гость просматривают эту тему.
  • 99 Ответов
  • 71348 Просмотров
*

jem777

  • Завсегдатай
  • 1643
  • 118 / 2
У меня тоже обнаружилась эта проблема. Joomla 1.5.22. htaccess не помог.
Решил так - в Общих настройках указал Обработчик сессий - Нет.
Пока работает нормально, но модуль кто на сайте пришлось отключить.

Но это конечно полумера - проблему не решил.
*

Yavich

  • Захожу иногда
  • 133
  • 3 / 1
Модеры, уберите из названия темы слово Решено, тут нифига не решено

а я сделал так:
общие настройки - обработчик сессий - вместо "файл" поставил "нет"
*

Aleks_El_Dia

  • Moderator
  • 3672
  • 353 / 0
  • AEDStudio Joomla! Direction
У меня тоже обнаружилась эта проблема. Joomla 1.5.22. htaccess не помог.
Решил так - в Общих настройках указал Обработчик сессий - Нет.
Пока работает нормально, но модуль кто на сайте пришлось отключить.

Но это конечно полумера - проблему не решил.
а я сделал так:
общие настройки - обработчик сессий - вместо "файл" поставил "нет"
В чем разница?
Спам придумали боги в отместку за наши молитвы (с) Рома Воронежский
На молоко: Z369038872422 || R210017695494 || U247040729215 || ЯД 410011288250383
Мигрирую сайты, переношу расширения J!1.0->J!1.5->J!2.5. Более 50 успешных миграций.
*

jem777

  • Завсегдатай
  • 1643
  • 118 / 2
Надпись исчезает и попытка залогиниться происходит нормально. Только online модуль начинает сходить с ума. При каждом обновлении страницы прибавляет по 1 посетителю и в итоге показывает сумасшедшее число юзеров онлайн. Приходиться выключать.
*

Yavich

  • Захожу иногда
  • 133
  • 3 / 1
а я сделал так:
общие настройки - обработчик сессий - вместо "файл" поставил "нет"

Ты хотел сказать вместо "База данных"?
*

Malory

  • Захожу иногда
  • 85
  • 6 / 0
Столкнулась с этой проблемой, когда начала делать новый сайт на новом шаблоне ja_teline_iv с предустановленным К2.
До этого Joomla_1.5.22 вела себя прилично.
Похоже, дело в совместимости Joomla с различными расширениями.
Вылечила так:
либо работа только из админки, с выключенной авторизацией на фронтэнде,
либо только из фронтэнда, с выключенным бэкэндом.
По-другому - случаются глюки.
*

Morh

  • Захожу иногда
  • 118
  • 11 / 0
Разве же это "вылечила"? Это "приспособилась".
В configuration.php переменную live site пропишите жёстко, типа http://www.site.ru, затем в .htaccess добавить строки (сразу после RewriteEngine On)

RewriteCond %{HTTP_HOST} ^site.ru$ [NC]
RewriteRule ^(.*)$  http://www.site.ru/$1 [R=301,L]

данными строками мы не "фиксим invalid token", как кто-то упоминал ранее, а делаем перенаправление с site.ru на www.site.ru

после этого почистить кэш ссылок SEF и пройтись по всем ссылкам. Должно заработать нормально.

Та же проблема invalid token при регистрации, после переноса на другой хостинг,(на первом всё работает на другом нет,компоненты теже самые  Joomla_1.5.22 +VirtueMart1.1.6 , пробовал жёстко прописывать в стоке var $live_site = ' http://www......'; не помогло
а в.htaccess нет строки RewriteEngine on -файл вообще пустой 0кб

походу проблема решилась ,но ещё нужно потестировать подольше, проблема была в файле VirtueMart.cfg.php
в начале темы говорилось об этом ,в строках
define( 'URL', 'http://xxxxxxx.ru/' );
define( 'SECUREURL', 'http://xxxxxx.ru/' );
остался старый url сайта ,после исправления на новый url (я переносил с другого хостинга) заработало
*

Aleks_El_Dia

  • Moderator
  • 3672
  • 353 / 0
  • AEDStudio Joomla! Direction
Та же проблема invalid token при регистрации, после переноса на другой хостинг,(на первом всё работает на другом нет,компоненты теже самые  Joomla_1.5.22 +VirtueMart1.1.6 , пробовал жёстко прописывать в стоке var $live_site = ' http://www......'; не помогло
а в.htaccess нет строки RewriteEngine on -файл вообще пустой 0кб
Если у вас используется ЧПУ и включен mod_rewrite то htaccess не должен быть пустой. Возьмите содержание из установочного архива.
Спам придумали боги в отместку за наши молитвы (с) Рома Воронежский
На молоко: Z369038872422 || R210017695494 || U247040729215 || ЯД 410011288250383
Мигрирую сайты, переношу расширения J!1.0->J!1.5->J!2.5. Более 50 успешных миграций.

Спасибо за совет но у меня регистрация заработала без этого ,а по поводу mod_rewrite то htaccess  нехочу пока заморачиваться.
*

58Vovan

  • Осваиваюсь на форуме
  • 32
  • 0 / 1
Между прочим, так и не могу решить эту проблему. Ещё один диагноз - вводя site.com/index.php я авторизован, а просто site.com - нет, плюс еще с www не понятны дела. В общем, под разными именами сайт живет разными жизнями. Уже замучил этот баг, помогите кто-нибудь  :O
появляется надпись
Время сесси истекло, пожалуйста, авторизуйтесь на сайте заново.
потом Invalid Token
htaccess правил, configuration.php тоже эффект "0" ошибка все ровно вылезает
нашел бекап от 03,01,11 все снес пере установил тот же результат, на форума 3 дня лазил многие пишут обращаться к хостеру .
тех хостера
Это случаем на аутентификация через googleAccounts?
а казалось гугол хром гючил, в мазиле все нормально
Лучше получать по 1% от усилий 100 человек,
чем 100% только от своих собственных усилий.
*

mxa

  • Новичок
  • 23
  • 4 / 5
После переноса на сервер сразу после ввода логина и пароля в админку стало выскакивать Invalid Token.
Нашел в инете рецепт как можно попасть в админку: в адресной строке http://www.vashsite.ru/administrator/index.php надо вытереть index.php и зайти по оставшемуся адресу. Таким образом в админку почему-то заходит.
А затем почистить кеш и сделать разблокировку. Мне помогло.
*

eddy333

  • Новичок
  • 8
  • 1 / 0
Спасибо большое! Строчки помогли!)))

## fix invalid token
RewriteCond %{HTTP_HOST} ^site.com [NC]
RewriteRule (.*) http://www.site.com/$1 [L,R=301]
*

_EBGEN_

  • Захожу иногда
  • 148
  • 1 / 0
Появляется такая ошибка именно после выхода по времени сессии. Добавление строчек
Код
RewriteCond %{HTTP_HOST} ^вашсайт.зона(например com) [NC]
RewriteRule (.*) http://www.вашсайт.зона(например com)/$1 [L,R=301]
вроде бы как не помогает.
*

Perla

  • Новичок
  • 8
  • 1 / 0
Столкнулась с invalid token еще когда тестила сайта на localhost. Возникал он, если пытаться регистрироваться с главной страницы, нажав кнопку Войти. Если жать кнопку Регистрация - то все нормально, сайт дает Зарегистрироваться. А вот с входом для Зарегистрированных пользователей возникала проблема. Перерыла весь инте, все предложенные решения, коих несусветное множество, мне не подходили.
Пришлось думать самой.
Решение нашлось, когда я обратила внимание на ссылку, которая должна была вызвать форму регистрации. Выглядела она вот так:
http://localhost/witeangel/index.php?option=com_user&task=login. Генерилась она кодом, который у меня находился в index.php:
<?php if($this->params->get("show_login", 1)  == 1) : ?>
   <a href="<?php echo JRoute::_( 'index.php?option=com_user&amp;task=login' ); ?>" id="login_btn" class="first"><?php echo ($userID == 0)? JText::_('LOGIN') : JText::_('LOGOUT'); ?></a>
<?php endif; ?>

Введя эту ссылку в поисковик, получила ответ Яндекса, из которого стало ясно, что правильно эта ссылка должна выглядеть так:

http://localhost/witeangel/index.php?option=com_user&view=login

Изменив в своем index.php только одно слово task на view, получила работающую регистрацию:
<?php if($this->params->get("show_login", 1)  == 1) : ?>
   <a href="<?php echo JRoute::_( 'index.php?option=com_user&amp;view=login' ); ?>" id="login_btn" class="first"><?php echo ($userID == 0)? JText::_('LOGIN') : JText::_('LOGOUT'); ?></a>
<?php endif; ?>

И вуаля, проблема с Invalid Token решена для моего случая.

К сожалению, я так и не поняла, почему не работала ссылка с task... Ведь такой же по смыслу код со ссылкой на страницы Регистрации прекрасно работал и не вызывал ошибку Invalid Token: http://localhost/witeangel/index.php?option=com_user&task=register.

Удивительная эта Joomla. Живет своей жизнью...

Надеюсь, кому-то мое решение проблемы поможет.
*

kysin

  • Захожу иногда
  • 187
  • 2 / 0
В configuration.php переменную live site пропишите жёстко, типа http://www.site.ru, затем в .htaccess добавить строки (сразу после RewriteEngine On)

RewriteCond %{HTTP_HOST} ^site.ru$ [NC]
RewriteRule ^(.*)$  http://www.site.ru/$1 [R=301,L]

данными строками мы не "фиксим invalid token", как кто-то упоминал ранее, а делаем перенаправление с site.ru на www.site.ru
Мне помогло это. Заметил, что эта ошибка выскакивает, если пытаться логиниться с адреса без www. Перенаправление на www.site.ru решило проблему. +1
*

dimetrius

  • Захожу иногда
  • 164
  • 8 / 1
А ещё в некоторых шаблонах всунут не стандартный модуль mod_login...
*

321

  • Захожу иногда
  • 364
  • 3 / 8
если сайт не в сети, а localhost ??
прошу ответить, если кто знает, как исправить данную ошибку, а именно Invalid Token
*

web_abuser

  • Новичок
  • 9
  • 0 / 0
Проблему решил странным способом
« Ответ #50 : 24.05.2011, 14:02:21 »
Привет Все. Я тут сделал для себя маленькое открытие, прошу знающих людей прокомментить. Оставил пустым в файле configuration.php  параметр live_site = '';  и в Виртуемарте в настройках заместо жесткой прописки урла поставил просто слеш. И вобщем то все работает и без шаманства в файле htaccess. Кто нить может что либо сказать по этому поводу? Правильно ли вообще такие настройки? Не влияет ли на безопасность? ну и т.д
*

Сергеич

  • Захожу иногда
  • 87
  • 2 / 0
если сайт не в сети, а localhost ??
...
Решение нашлось, когда я обратила внимание на ссылку, которая должна была вызвать форму регистрации. Выглядела она вот так:
http://localhost/witeangel/index.php?option=com_user&task=login. Генерилась она кодом, который у меня находился в index.php:
<?php if($this->params->get("show_login", 1)  == 1) : ?>
   <a href="<?php echo JRoute::_( 'index.php?option=com_user&amp;task=login' ); ?>" id="login_btn" class="first"><?php echo ($userID == 0)? JText::_('LOGIN') : JText::_('LOGOUT'); ?></a>
<?php endif; ?>
Какой именно index.php Вы имеете в виду? Поиск кода через Total Commander результата не принес, ошибка продолжает появляться на localhost...
Делай, что должен и будь, что будет!
*

Perla

  • Новичок
  • 8
  • 1 / 0
Какой именно index.php Вы имеете в виду? Поиск кода через Total Commander результата не принес, ошибка продолжает появляться на localhost...

Сергеич, чтобы ответить на Ваш вопрос, нужно хотя бы понимать в чем у Вас проблема.

Joomla код основного шаблона сайта (его еще называют template) хранит в файле index.php Вы этот файл не смогли найти? А где искали?
*

Сергеич

  • Захожу иногда
  • 87
  • 2 / 0
Joomla код основного шаблона сайта (его еще называют template) хранит в файле index.php Вы этот файл не смогли найти? А где искали?
Файл то я нашел, но в нем нет фрагмента кода, который Вы правили.
Делай, что должен и будь, что будет!
*

CubaJas

  • Осваиваюсь на форуме
  • 27
  • 3 / 0
отключил плагин system-cache и все заработало. За что отвечает данный плагин?
*

Сергеич

  • Захожу иногда
  • 87
  • 2 / 0
отключил плагин system-cache и все заработало. За что отвечает данный плагин?
Плагин отвечает за кэширование страниц. Его отключение снизит нагрузку на сервер, но замедлит скорость загрузки сайта. По моему так.
Делай, что должен и будь, что будет!
*

Skifka

  • Новичок
  • 5
  • 0 / 0
Уважаемые господа, здравствуйте! =)

Имею: Joomla 1.5.22, шаблон gk_postnote (сайт НЕ виртуал-маркет), не на локал-хосте (на "живом" хостинге)

Проблема, в общем, та же - при регистрации выдает Invalid Token.

Перепробовала все описанные варианты фикса:
1). сделала перенаправление с мой-сайт.ru на www.мой-сайт.ru - перенаправляется, но регисться не дает (перенаправление решила не убирать, говорят, полезно для оптимизации)
2). меняла в  файле configuration.php  параметр live_site = ''; на "мой-сайт.ru" - привело к ошибке 500 (вернула к исходному)
3). очистила таблицу сессий в БД - нулевой эффект
4). выключала кэш-плагин - ничего
5). в админке обработчику сессий вместо "БД" ставила "нет" = 0
6). выключала модуль "кто на сайте" = 0
и т. д. ...
короче, не помогло ничего  >:(
Добилась только того, что и авторизация с главной страницы перестала работать (ну хоть с других страниц работает)  :o
У меня нет большой надежды, что мне кто-нибудь поможет тут решить эту проблему, но все же.... а вдруг?  ::)
Я не веб-мастер, я только учусь!
*

Aleks_El_Dia

  • Moderator
  • 3672
  • 353 / 0
  • AEDStudio Joomla! Direction
Skifka, если вы имеете ввиду сайт который у вас в профиле, то попробуйте включить mod_rewrite в общих настройках сайта.
Спам придумали боги в отместку за наши молитвы (с) Рома Воронежский
На молоко: Z369038872422 || R210017695494 || U247040729215 || ЯД 410011288250383
Мигрирую сайты, переношу расширения J!1.0->J!1.5->J!2.5. Более 50 успешных миграций.
*

Skifka

  • Новичок
  • 5
  • 0 / 0
спасибо больше! сейчас попробую =) да, сайт именно этот
Я не веб-мастер, я только учусь!
*

Skifka

  • Новичок
  • 5
  • 0 / 0
включила, увы - не помогло =((
Я не веб-мастер, я только учусь!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Переход на PHP 7, не пускает в админку Invalid Token

Автор murzuk

Ответов: 37
Просмотров: 1995
Последний ответ 07.04.2018, 05:52:09
от capricorn
Проблема c MobileJoomla

Автор alexmishka

Ответов: 0
Просмотров: 388
Последний ответ 25.02.2018, 20:32:10
от alexmishka
Вопрос при переходе на https/ Проблема с внутренними ссылками

Автор krot

Ответов: 4
Просмотров: 659
Последний ответ 06.02.2018, 09:21:33
от krot
Проблема при переносе Joomla на xampp

Автор sbabaev

Ответов: 6
Просмотров: 5951
Последний ответ 28.07.2017, 09:06:10
от pro100skill
Как проверить форму обратной связи [Решено]

Автор mafiozzzza

Ответов: 8
Просмотров: 4735
Последний ответ 30.05.2017, 11:34:11
от darkghost