0 Пользователей и 1 Гость просматривают эту тему.
  • 677 Ответов
  • 114771 Просмотров
*

Dorfman

  • Завсегдатай
  • 1174
  • 78 / 4
  • Почти влез...
Re: Тестирование smfaq
« Ответ #30 : 02.03.2012, 10:51:42 »
тю... Я думал, это или Жумла, или у меня хостер выбрыкивается... Присоединяюсь к вопросу!

зы А я свой support терзаю...  :o
*

admix72

  • Новичок
  • 18
  • 0 / 0
Re: Тестирование smfaq
« Ответ #31 : 09.03.2012, 15:50:44 »
 Можно как то копирайт убрать? тк жесткий контроль за внешними ссылками
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #32 : 11.03.2012, 16:53:47 »
Неужели проект забросили? Последние изменения был месяц назад и ошибки как я понял не поправили... :(
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #33 : 11.03.2012, 17:22:20 »
Неужели проект забросили? Последние изменения был месяц назад и ошибки как я понял не поправили... :(
не забросил, не до этого как-то было.
Скоро работа продолжится.
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #34 : 16.03.2012, 02:31:13 »
Доступно новое обновление. Обновиться можно как через менеджер расширений - поиск обновлений так и вручную через github.
Что нового:
  • Добавлен дополнительный параметр в категорию, для обработки контент плагинов в ответе на вопрос.
  • Добавлена конфигурация компонента, можно выставлять доступ для админки.
  • Внесены небольшие изменения в форму добавления вопроса на фронте для улучешния работы с плагинами. Теперь добавить дополнительные поля можно плагином, не внося изменения в саму форму. Подробнее смотрите тестовый плагин
  • Исправлена ошибка с почтой.
Внимание!
При неправильных установки почты возможно некорректная работы формы оправки вопроса на фронте. Ошибки эти могут возникнуть в основном на локалхосте. Чтобы избежать данной ошибки можно отключить уведомления в настройках категории.
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #35 : 16.03.2012, 16:00:37 »
Обновился. Всё равно проблема с почтой.
При ответе на вопрос выдает "Не удалось вызвать функцию mail.".

При создании вопроса также не приходит уведомление редактору.
Настроено в настройках Joomla на SMTP с авторизацией. Почтовый сервер хостится не на том же сервере, что и сайт. Настройки правильные, приходят сообщения от других компонентов.
*

NeoKS

  • Новичок
  • 5
  • 1 / 0
  • I LIKE JOOMLA
Re: Тестирование smfaq
« Ответ #36 : 18.03.2012, 08:34:22 »
Проблему подтверждаю. Joomla 2.5.3 + SM FAQ beta 2. не работает функция по отправке уведомления почтой для редакторов и гл.администраторов.
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #37 : 18.03.2012, 22:02:35 »
Проблему подтверждаю. Joomla 2.5.3 + SM FAQ beta 2. не работает функция по отправке уведомления почтой для редакторов и гл.администраторов.
А уведомление автору работает?
*

Dorfman

  • Завсегдатай
  • 1174
  • 78 / 4
  • Почти влез...
Re: Тестирование smfaq
« Ответ #38 : 19.03.2012, 10:05:23 »
ни фига не работает: ни автору, ни админу. Всё те же "Не удалось вызвать функцию mail."
*

catalonez

  • Новичок
  • 3
  • 0 / 0
Re: Тестирование smfaq
« Ответ #39 : 19.03.2012, 13:32:29 »
Спасибо, у меня заработало, уведомление админу приходит Joomla 2.5.3. У кого не работает вы в категории вопросов Управление настройками прав доступа для групп пользователей меняли на разрешено, а не унаследовано?
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #40 : 19.03.2012, 13:36:15 »
Уведомления в форме сделал, а про функции администратора забыл))
В общем сегодня постараюсь выложить новый билд.
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #41 : 19.03.2012, 20:27:41 »
Выложил новый релиз. Вроде проблемы с почтой должны исправиться.
Так же желательно проверить функции администрирования на фронте, т.к. там было внесено довольно много изменений.
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #42 : 19.03.2012, 21:14:11 »
Уже значительно лучше, автору пришло письмо об ответе. :)
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #43 : 19.03.2012, 21:18:00 »
Заметил баг:
При ответе поле времени ответа выводит такое: 30.11.-0001 00:00
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #44 : 19.03.2012, 21:23:39 »
Заметил баг:
При ответе поле времени ответа выводит такое: 30.11.-0001 00:00
Да видел я такое. С датами там тоже шаманил. Это на фронте или где происходит?
Попробуйте создать новый вопрос вроде там проблемы не должно быть. Или в это же вопросе просто установить дату ответа нужную календариком.
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #45 : 20.03.2012, 01:23:54 »
Да видел я такое. С датами там тоже шаманил. Это на фронте или где происходит?
Попробуйте создать новый вопрос вроде там проблемы не должно быть. Или в это же вопросе просто установить дату ответа нужную календариком.
На фронте. Новый вопрос создавал, при создании дата нормально текущая распознается. Когда-же редактор заходит в неопубликованные вопросы - дата ответа распознается кривая. И если щелкнуть на календарик - вылазит 2001 год и дата неправильная. По-нормальному сразу бы в текстовом поле нормальная дата бы была - было бы совсем хорошо.
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #46 : 20.03.2012, 11:25:15 »
На фронте. Новый вопрос создавал, при создании дата нормально текущая распознается. Когда-же редактор заходит в неопубликованные вопросы - дата ответа распознается кривая. И если щелкнуть на календарик - вылазит 2001 год и дата неправильная. По-нормальному сразу бы в текстовом поле нормальная дата бы была - было бы совсем хорошо.
хм не понимал чего так происходит, сейчас вроде понял))
Удалите файл components/com_smfaq/models/fields/smcalendar.php
Он был перенесен в административную часть, а Joomla при обновлении копирует новые файлы, а старые остаются на месте.
Т.е. если устанавливать компонент с нуля такой ошибки не должно быть.
*

4ertenok13

  • Осваиваюсь на форуме
  • 42
  • 1 / 0
Re: Тестирование smfaq
« Ответ #47 : 20.03.2012, 11:57:50 »
Joomla 1.7, последний Denwer и smfaq релиз 1.7 beta 3

При установке компонента не создаёт меню управления, а при попытке поставить плагин релиз 1.1 пишет
Table 'planetaludei.jjd51_smfaq' doesn't exist SQL=ALTER TABLE jjd51_smfaq ADD `my_field` VARCHAR(100) NOT NULL

что можно  сделать?

*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #48 : 20.03.2012, 12:06:58 »
4ertenok13
по какой-то причине у вас не создается таблицы в БД для компонента. Почему так происходит я не знаю.
Сначала устанавливается компонент, потом соответственно плагин к нему.
Опишите порядок установки. И выдает ли какое-нибудь сообщение при установки компонента.
*

4ertenok13

  • Осваиваюсь на форуме
  • 42
  • 1 / 0
Re: Тестирование smfaq
« Ответ #49 : 20.03.2012, 12:17:20 »
4ertenok13
по какой-то причине у вас не создается таблицы в БД для компонента. Почему так происходит я не знаю.
Сначала устанавливается компонент, потом соответственно плагин к нему.
Опишите порядок установки. И выдает ли какое-нибудь сообщение при установки компонента.

Так.., да таблицы действительно нет. Деинсталлировала через менеджер расширений, была надпись "Компонент успешно удалён (синим) и Нельзя удалять меню управлений (красным)"

Установка: скачала репозиторий, открыла, зазиповала компонент и плагин, через менеджера установки в Джу инсталлировала компонент.

Появилась надпись "Компонент успешно установлен" (синим) и "Ошибка при создании меню панели управления" (красным)"
внизу:Расширение для организации системы Вопрос-Ответ на Joomla!", но не было привычного "общего вида" с информацией о лицензии и всём таком.

Переставила плагин, он встал, но меню управления компонента по прежнему нет.

*

4ertenok13

  • Осваиваюсь на форуме
  • 42
  • 1 / 0
Re: Тестирование smfaq
« Ответ #50 : 20.03.2012, 12:23:53 »
появились базы smfaq, smfaq_comments, smfaq_votes меню управлению не появилось((
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #51 : 20.03.2012, 12:30:49 »
ясно.
Зайдите в phpMyAdmin и выполните SQL запрос
Код
DELETE FROM `#__menu` WHERE `link` LIKE '%com_smfaq%'
#_ - замените на свой префикс
Затем удалите компонент через менеджер расширений и установите заново.
*

4ertenok13

  • Осваиваюсь на форуме
  • 42
  • 1 / 0
Re: Тестирование smfaq
« Ответ #52 : 20.03.2012, 12:41:56 »
SmokerMan

вот тут обнажаются пределы моего "разума") правильно я поняла, что мне надо перейти на вкладку SQL и там в большом окошке вбить вышеназванную фразу? Правильно я поняла, что префикс - это пять знаков до _? Если всё так, то была вот такая надпись "#1146 - Table 'planetaludei.jjd51__menu' doesn't exist" с жёлтым значком перед ней.

Вообще-то я уже перед этим один раз обновлялась с бекапа, то есть перед очередной попыткой установки база была чистой и хорошо работающей. Но это так на всякий случай) Могу ещё раз попробовать обновить базу с бекапа, который я делала ещё до того, как начала даже смотреть на ваш компонент.
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #53 : 20.03.2012, 12:53:26 »
поняли правильно только лишний прочерк поставили. В вашем случае запрос будет такой
Код
DELETE FROM `planetaludei.jjd51_menu` WHERE `link` LIKE '%com_smfaq%'
*

4ertenok13

  • Осваиваюсь на форуме
  • 42
  • 1 / 0
Re: Тестирование smfaq
« Ответ #54 : 20.03.2012, 13:15:32 »
скопипастила ваш код, получила

#1146 - Table 'planetaludei.planetaludei.jjd51_menu' doesn't exist
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #55 : 20.03.2012, 13:18:19 »
хм не понимал чего так происходит, сейчас вроде понял))
Удалите файл components/com_smfaq/models/fields/smcalendar.php
Он был перенесен в административную часть, а Joomla при обновлении копирует новые файлы, а старые остаются на месте.
Т.е. если устанавливать компонент с нуля такой ошибки не должно быть.
Ага, помогло. Теперь поле даты ответа пустое, хотелось бы всё-таки видеть там дату ответа сразу заполненную текущую. Логически то это правильно.
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #56 : 20.03.2012, 13:24:45 »
скопипастила ваш код, получила

#1146 - Table 'planetaludei.planetaludei.jjd51_menu' doesn't exist
))
попробуйте так, вы просто видимо зашли в эту базу уже.
Код
DELETE FROM `jjd51_menu` WHERE `link` LIKE '%com_smfaq%'
*

adenter

  • Новичок
  • 12
  • 0 / 0
Re: Тестирование smfaq
« Ответ #57 : 20.03.2012, 14:07:28 »
Еще интересная штука. Уведомление автору об ответе пришло при помещении вопроса в корзину. Это нормально?
*

SmokerMan

  • Гуру
  • 5293
  • 720 / 26
Re: Тестирование smfaq
« Ответ #58 : 20.03.2012, 14:12:37 »
Еще интересная штука. Уведомление автору об ответе пришло при помещении вопроса в корзину. Это нормально?
не нормально видимо))
ок посмотрю.
*

4ertenok13

  • Осваиваюсь на форуме
  • 42
  • 1 / 0
Re: Тестирование smfaq
« Ответ #59 : 20.03.2012, 14:37:03 »
))
попробуйте так, вы просто видимо зашли в эту базу уже.
Код
DELETE FROM `jjd51_menu` WHERE `link` LIKE '%com_smfaq%'

получилось))плагин удалять? или он сам отвалился? сейчас поставлю заново компонент и отпишусь..
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

SW JProjects - Менеджер цифровых проектов для Joomla! CMS™

Автор Septdir

Ответов: 11
Просмотров: 747
Последний ответ 15.08.2019, 19:02:43
от Septdir
JAtomS - Система дистрибуции экскурсионных туров Атом-С для Joomla! cms™

Автор Septdir

Ответов: 3
Просмотров: 280
Последний ответ 13.08.2019, 17:04:30
от Septdir
JL Like - Социальные кнопки для Joomla (новый взгляд)

Автор zikkuratvk

Ответов: 610
Просмотров: 75872
Последний ответ 12.08.2019, 17:39:31
от zikkuratvk
Плагин для закрытия ссылок в Joomla 3 - noExternalLinks

Автор buyanov

Ответов: 44
Просмотров: 8523
Последний ответ 16.07.2019, 18:26:19
от Lix
[Разработка, нужны советы] Компонент для УО (УК и тсж)

Автор rsa_m

Ответов: 190
Просмотров: 22120
Последний ответ 15.07.2019, 16:34:02
от spro1