Новости Joomla

0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 1680 Просмотров
*

bugmenot

  • Захожу иногда
  • 230
  • 11 / 2
  • za3.by
Хочу выпустить пару плагинов для Joomla.
Какие версии стоит поддерживать?
С одной стороны 2.5 и 3.0 - это 100% нужно. С другой есть неподдерживаемый Joomla.org хлам в виде 1.5, 1.6 и 1.7
Много ли пользователей ещё не перешло на 2.5? Есть ли статистика процентного соотношения всех версий? На кого стоит ориентироваться?
*

voland

  • Легенда
  • 11030
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
*

ecolora

  • Завсегдатай
  • 1527
  • 171 / 2
  • творец
Re: Какие версии Joomla поддерживать?
« Ответ #2 : 09.11.2012, 11:23:54 »
1.5 (еще какое-то время, как минимум год), а также 2.5, 3.0.

Тем более, это плагины... а не компоненты, где больше траблов.

Сам разработчик расширений и до сих пор руководствуюсь этим правилом.

Сказанное выше - субъективно.

Если кому интересно: у меня до сих пор 2 сайта на 1.5 стоят. Блоги. Не вижу необходимости их обновлять, а смысл? Там стоит RSFirewall, так что за безопасность я почти не беспокоюсь.
Я рифме друг словесной. Тут
Свой упражняю словоблуд:
Блог Ecolora
*

voland

  • Легенда
  • 11030
  • 588 / 112
  • Эта строка съедает место на вашем мониторе
Re: Какие версии Joomla поддерживать?
« Ответ #3 : 09.11.2012, 11:51:48 »
1.5 - если поддерживать написанное - то да, а если писать новый функционал - под 1.5 сейчас нет уже смысла.
*

ecolora

  • Завсегдатай
  • 1527
  • 171 / 2
  • творец
Re: Какие версии Joomla поддерживать?
« Ответ #4 : 09.11.2012, 12:19:32 »
1.5 - если поддерживать написанное - то да, а если писать новый функционал - под 1.5 сейчас нет уже смысла.

Не понял из Вашего предложения что имеется в виду все-таки. :-) Честно. Это аксиома по-моему... новый функционал под 1.5 не может быть, потому что система старая.

А я говорил о том, что очень много сайтов все еще на Joomla 1.5, по моим прикидкам не менее 20%, говорю это как разработчик расширений.

Поэтому каждый разработчик волен сам решать, стоит ли ему писать расширение, которое можно будет установить лишь на 4х сайтах из 5и или такой, который установят на 5 из 5 возможных, пусть даже на одном из них функционал будет чуть урезан.

Пришло вдруг в голову... а скоро вообще можно будет вводить плату за такое расширение. Есть категория разработчиков, которые никогда не перейдут с 1.5 (по разным причинам) и они с руками оторвут расширение, которое им нужно и при этом еще и на данный момент обновляется. Мысль понятна? Могу раскрыть, если надо. :-))
« Последнее редактирование: 09.11.2012, 12:27:04 от ecolora »
Я рифме друг словесной. Тут
Свой упражняю словоблуд:
Блог Ecolora
*

bugmenot

  • Захожу иногда
  • 230
  • 11 / 2
  • za3.by
Re: Какие версии Joomla поддерживать?
« Ответ #5 : 09.11.2012, 22:49:59 »
Плагины в любом случае будут иметь FREE & PRO версии.
Просто непонятно, купят ли что-то для Joomla 1.5 или это ***но мамонта присутствует в статистике только как уже созданные сайты, которые не модернизируют без апгрейда? Тогда да, не купят под 1.5.

Если написать плагин под 1.5, он точно будет работать под 1.6 и 1.7? Мне не придётся проверять ещё на двух тестовых окружениях?
*

ecolora

  • Завсегдатай
  • 1527
  • 171 / 2
  • творец
Re: Какие версии Joomla поддерживать?
« Ответ #6 : 10.11.2012, 03:24:35 »
Забудьте про 1.6 и 1.7, с них переход на 2.5, можно сказать безболезенный и те кто не перешли, в 99% случаев перейдут со временем.

Никогда не считал 1.5 гавном мамонта. В свое время она была неплоха и со своими задачами справилась. На ней и сейчас можно сделать нормальный сайт. С таким подходом Вам лучше вообще ничего не писать. :-)))

На остальные Ваши вопросы сами найдете ответ. Я проверяю на данный момент в 3х "тестовых окружениях" )) 1.5, 2.5 и 3.0. Возможно, спустя время у меня останется 1.5 и 3.0.
Я рифме друг словесной. Тут
Свой упражняю словоблуд:
Блог Ecolora
*

bugmenot

  • Захожу иногда
  • 230
  • 11 / 2
  • za3.by
Re: Какие версии Joomla поддерживать?
« Ответ #7 : 10.11.2012, 05:09:38 »
Вы выпускаете одну версию расширения на все три версии Joomla, или же три версии расширения?
Я видел, что некоторые плагины идут под каждую версию Joomla. Articles Anywhere, к примеру.
Интересно, не будет ли проблем с 1.6 и 1.7 при тестировании на 1.5, 2.5 и 3.0?

*

ecolora

  • Завсегдатай
  • 1527
  • 171 / 2
  • творец
Re: Какие версии Joomla поддерживать?
« Ответ #8 : 10.11.2012, 05:13:40 »
Я на данный момент выпускаю 2 версии: для Joomla 1.5 и 2.5-3.0. Надеюсь что так и будет в дальнейшем. 1.5 скрестить с 3.0 уже почти невозможно. Хотя можно наверное, но смысл? :-) Кучу лишних условий в код добавлять? :-) А если делать 2 дистриба в одном, то то же самое и получается, что 2 дистриба сразу.

Articles Anywhere вообще сейчас по 2.5 только идет. Но в данном случае понять разработчика можно, он непосредственно в команде Joomla, и линию партии (отказ от 1.5, чтобы пользователи быстрее перешли на 2.5-3.0) нарушать не будет. Это субъективное мнение.

Забудьте про 1.6 и 1.7.

Вы эту тему создали, чтобы убедить себя в чем-то или действительно разобраться?

У меня складывается мнение, что мы просто трепемся, а не ищем "истину".
« Последнее редактирование: 10.11.2012, 05:17:52 от ecolora »
Я рифме друг словесной. Тут
Свой упражняю словоблуд:
Блог Ecolora
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как и чем можно обращаться с запросами из Joomla к GraphQL?

Автор bmf1982

Ответов: 0
Просмотров: 625
Последний ответ 03.10.2019, 15:46:00
от bmf1982
Joomla как система авторизации

Автор kav

Ответов: 23
Просмотров: 2303
Последний ответ 29.04.2018, 11:10:30
от Aleks.Denezh
Нужна помощь в доработке модуля под Joomla 3

Автор kik84

Ответов: 5
Просмотров: 2285
Последний ответ 30.01.2018, 22:40:30
от Елeна
Как отучить Joomla стартовать session для гостей?

Автор commeta

Ответов: 8
Просмотров: 2920
Последний ответ 20.08.2015, 14:06:38
от acyp
Модуль отправки сообщений для Joomla 1.5 и 2.5 (ajax)

Автор gaalferov

Ответов: 7
Просмотров: 5725
Последний ответ 02.06.2015, 18:05:52
от gaalferov