Новости Joomla

Вышли релизы безопасности Joomla 6.1.4 и Joomla 5.4.9

Релиз безопасности Joomla 6.1.4 и Joomla 5.4.9

Проект Joomla! рад сообщить о выходе Joomla 6.1.4 и Joomla 5.4.9. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 8 Ответов
  • 2090 Просмотров
*

levwa

  • Новичок
  • 5
  • 0 / 0
После удаления меню демо-данных браузер выдает ошибку,что не может найти index.php в папке www/joomla,но он там есть!Что можно сделать кроме переустановки joomla!
*

vagkrsk

  • Давно я тут
  • 731
  • 125 / 0
  • Дорогу осилит идущий
Создать новый пункт меню в mainmenu и поставить его первым.
Если все меню удалили, нужно создать mainmenu обязательно, с него начинается сайт
*

levwa

  • Новичок
  • 5
  • 0 / 0
Спосибо,что отозвались!Вам мелочь,а мне приятно!
Попробую,а то уже лихорадит!
*

vagkrsk

  • Давно я тут
  • 731
  • 125 / 0
  • Дорогу осилит идущий
Не надо пробовать, нужно это сделать.
На будущее, не удаляйте демоданные на первом этапе, их просто можно снять с публикации (отключить)
Оставив демоданные, Вы всегда будете иметь подсказку под рукой.
А как там делали? Посмотрел(а), проанализировал(а) и сделал(а) по образу и подобию   ^-^
« Последнее редактирование: 06.08.2009, 14:00:13 от vagkrsk »
*

levwa

  • Новичок
  • 5
  • 0 / 0
Запустила сервер заново,теперь вообще при входе на сайт и в админку выдает ошибку 404. Кроме как лезть в БД ,нет другого способа реанимации Joomla? !!!???!!!
*

cor_ar

  • Захожу иногда
  • 137
  • 27 / 1
Запустила сервер заново,теперь вообще при входе на сайт и в админку выдает ошибку 404. Кроме как лезть в БД ,нет другого способа реанимации Joomla? !!!???!!!
да, так как проблема в бд.
Восстановите бд. А если нет БД то возьмите чистую  с пакета установки
*

levwa

  • Новичок
  • 5
  • 0 / 0
*

vagkrsk

  • Давно я тут
  • 731
  • 125 / 0
  • Дорогу осилит идущий
Установите Joomla заново с демо-данными, а так можете долго бродить в поисках решения.
Причины могут быть очень разными, как и советы.
Но тот кто дает советы не видит, что и как делает тот, кто их спрашивает ^-^  
*

levwa

  • Новичок
  • 5
  • 0 / 0
Черт,интуиция не подвела...Переустановка forever!Спасибо,теперь немного лучше разбираюсь в Joomla
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

при входе в админ часть перебрасывает на /installation/index.php

Автор kostass

Ответов: 8
Просмотров: 31180
Последний ответ 13.11.2025, 10:13:13
от sivers
Не работает страница XML выдает ошибку: This page contains the following errors

Автор vitaliywolf

Ответов: 20
Просмотров: 31816
Последний ответ 07.05.2020, 22:24:16
от sivers
Ошибка #1050 при переносе базы данных на хостинг

Автор Ksen

Ответов: 7
Просмотров: 29343
Последний ответ 16.03.2020, 17:47:29
от Petrovich
Проблема со входом в Админ панель после переноса сайта

Автор Vlad Ermolaev

Ответов: 11
Просмотров: 10284
Последний ответ 12.12.2019, 15:48:25
от SeBun
не работает главная без index.php

Автор Mary Poppins

Ответов: 11
Просмотров: 11433
Последний ответ 11.12.2018, 18:28:30
от all_zer