Новости Joomla

0 Пользователей и 1 Гость просматривают эту тему.
  • 9 Ответов
  • 5056 Просмотров

хелп люди..

проблема такая поставил галерею 1.8.4 на J1.5, админка работает без проблем всё как положено, но когда открываеш страницу на сайте то выдаёт ошибку
Цитировать
Parse error: parse error, unexpected T_OBJECT_OPERATOR in ....\http\components\com_datsogallery\datsogallery.php on line 491

код из этого файла
Код
        case "send2friend":
          $Itemid = JRequest::getVar('Itemid', '', 'get', 'int');
          $send2friendname = JRequest::getVar('send2friendname', '', 'post', 'string');
          $send2friendemail = JRequest::getVar('send2friendemail', '', 'post', 'string');
          $from2friendname = JRequest::getVar('from2friendname', '', 'post', 'string');
          $from2friendemail = JRequest::getVar('from2friendemail', '', 'post', 'string');
          $id = JRequest::getVar('id', 0, 'post', 'int');
          =эта строка==== >>>>  $siteurl = JFactory::getURI()->toString(array('scheme', 'host'));
          $text = $from2friendname . " (" . $from2friendemail . ")" . " " . _DG_INVITE_VIEW_PIC . " \r \n";
          $link = JRoute::_("index.php?option=com_datsogallery&func=detail&catid=" . $catid . "&id=" . $id . "&Itemid=" . $Itemid);
          $text .= $siteurl . $link . "\r\n";
          $subject = $mainframe->getCfg('sitename'). ' - ' . _DG_RECCOMEND_PIC_FROM_FREND;
          JUtility::sendMail($from2friendemail, $from2friendname, $send2friendemail, $subject, $text);
          $mainframe->redirect(JRoute::_("index.php?option=com_datsogallery&func=detail&catid=" . $catid . "&id=" . $id . "&Itemid=" . $Itemid), _DG_MAIL_SENT);
          break;
        default:

*

malkoruslan

  • Новичок
  • 5
  • 0 / 0
Re: Админка работает а на сайте нет
« Ответ #1 : 31.01.2010, 12:04:09 »
Все тоже самое. При запуске галереи-  ошибка Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /var/www/cakuPZ/caku.biz/components/com_datsogallery/datsogallery.php on line 491, подскажите варианты выхода из ситуации.
*

Peroon

  • Захожу иногда
  • 247
  • 11 / 1
  • http://textonix.ru
Re: Админка работает а на сайте нет
« Ответ #2 : 31.01.2010, 16:50:09 »
просто комментируйте эту строку...
*

malkoruslan

  • Новичок
  • 5
  • 0 / 0
Re: Админка работает а на сайте нет
« Ответ #3 : 31.01.2010, 17:44:05 »
Спасибо огромное! Запустилось! Буду тестить дольше! Интересно, почему это происходит, есть ли этому объяснение?
*

malkoruslan

  • Новичок
  • 5
  • 0 / 0
Re: Админка работает а на сайте нет
« Ответ #4 : 31.01.2010, 18:05:28 »
после остановки слайдшоу выбивает на http://www......../undefined
из-за чего такое могет быть?
*

Peroon

  • Захожу иногда
  • 247
  • 11 / 1
  • http://textonix.ru
Re: Админка работает а на сайте нет
« Ответ #5 : 31.01.2010, 19:17:42 »
Спасибо огромное! Запустилось! Буду тестить дольше! Интересно, почему это происходит, есть ли этому объяснение?

Да есть, если не поленитесь то найдете множество веток на эту тему...

после остановки слайдшоу выбивает на http://www......../undefined
из-за чего такое могет быть?

А подробнее?
*

malkoruslan

  • Новичок
  • 5
  • 0 / 0
Re: Админка работает а на сайте нет
« Ответ #6 : 01.02.2010, 21:30:31 »
я уверен, что самая главная закавыка здесь, это ошибка в сохранении конфигурационного файла. Или точнее в невозможности этого! Тем на эту тему много, а ответов нет.
При сохранении измененной конфигурации выдает сообщение - Конфигурационный файл недоступен для записи!
*

Peroon

  • Захожу иногда
  • 247
  • 11 / 1
  • http://textonix.ru
Re: Админка работает а на сайте нет
« Ответ #7 : 02.02.2010, 01:20:41 »
так дай ему эти права))))
*

artrush

  • Захожу иногда
  • 99
  • 0 / 0
Re: Админка работает а на сайте нет
« Ответ #8 : 06.07.2010, 09:58:50 »
так дай ему эти права))))
А где именно и как называется файл конфигурации для галереи?
*

Duremarr

  • Новичок
  • 1
  • 0 / 0
Re: Админка работает а на сайте нет
« Ответ #9 : 23.07.2010, 17:22:29 »
Решение проблемы с отображением галере в пользовательском режиме:

код с 485 по 496 строку заменяем на

Код
$Itemid = JRequest::getVar('Itemid', '', 'get', 'int');
$send2friendname = JRequest::getVar('send2friendname', '', 'post', 'string');
$send2friendemail = JRequest::getVar('send2friendemail', '', 'post', 'string');
$from2friendname = JRequest::getVar('from2friendname', '', 'post', 'string');
$from2friendemail = JRequest::getVar('from2friendemail', '', 'post', 'string');
$id = JRequest::getVar('id', 0, 'post', 'int');
$text = $from2friendname . " (" . $from2friendemail . ")" . " " . _DG_INVITE_VIEW_PIC . " \r \n";
$link = JURI::base()."index.php?option=com_datsogallery&func=detail&catid=" . $catid . "&id=" . $id . "&Itemid=" . $Itemid;
$text .= $link . "\r\n";
$subject = $mainframe->getCfg('sitename'). ' - ' . _DG_RECCOMEND_PIC_FROM_FREND;
JUtility::sendMail($from2friendemail, $from2friendname, $send2friendemail, $subject, $text);
$mainframe->redirect(JRoute::_("index.php?option=com_datsogallery&func=detail&catid=" . $catid . "&id=" . $id . "&Itemid=" . $Itemid), _DG_MAIL_SENT);
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Как скачать компонент на официально сайте?

Автор archer1981

Ответов: 1
Просмотров: 2527
Последний ответ 16.08.2017, 09:56:35
от archer1981
[Решено] Не работает голосовалка Datso

Автор metiss

Ответов: 8
Просмотров: 4108
Последний ответ 18.12.2016, 17:39:30
от dmitry_stas
SlimBox не работает в IE

Автор vladislav1977

Ответов: 18
Просмотров: 11602
Последний ответ 02.09.2016, 19:39:22
от beliyadm
Как сделать вывод категорий/подкатегорий на сайте в алфавитном порядке?

Автор Yonakano

Ответов: 0
Просмотров: 2427
Последний ответ 24.01.2014, 16:35:22
от Yonakano
Не работает shadowbox в DatsoGallery

Автор d.i.m.k.e.r.

Ответов: 2
Просмотров: 2466
Последний ответ 29.04.2013, 12:54:44
от katerina_il