0 Пользователей и 1 Гость просматривают эту тему.
  • 11 Ответов
  • 1857 Просмотров
*

Drunk

  • Осваиваюсь на форуме
  • 38
  • 3 / 10
Подскажите, пожалуйста, как сделать, что бы заголовки (Title) категорий и материалов(Items) ZOO 2.5.10 отображались на русском языке?

Пол недели мучаюсь с данным вопросом. Перерыл половину php и CSS, но так ничего и не нашел. Дело в том, что при создании заголовка на русском языке ZOO показывает его в виде знаков вопроса "?".

Если кто сталкивался с данным вопросом, буду благодарен любым советам)
*

MetaSpirit

  • Завсегдатай
  • 1370
  • 106 / 0
  • R.A.S.Lab[.org]
Тут проблема с кодировкой базы данных
R.A.S.Lab[.org]: ZOOvirtue - корзина для ZOO, Яндекс.Карты для ZOO, ItemPanes - табы для ZOO, ZOOlendar - календарь для ZOO  и др.
Создание расширений для YOOtheme ZOO на заказ. Становитесь в очередь.
*

Drunk

  • Осваиваюсь на форуме
  • 38
  • 3 / 10
Я в Бд не очень разбираюсь. Сайт у меня пока на локальном сервере использую MAMP. Зашел в phpMyAdmin там стоит кодировка utf8_general_ci.

Дело в том, что все отлично работает, на этой недели сайт на хост буду ставить, а заголовки категорий и материалов созданных на ZOO не отображает...

*

Drunk

  • Осваиваюсь на форуме
  • 38
  • 3 / 10
Тут проблема с кодировкой базы данных


Я думаю если это была бы проблема с кодировкой, то все заголовки независимо от компонента(К2, ZOO) или просто Joomla не отображались на русском языке. А у меня данная проблема только на ZOO. Предполагаю, что это проблема в самом ZOO...
*

Drunk

  • Осваиваюсь на форуме
  • 38
  • 3 / 10
Хлопци, разве никто не знает?? Видел на куче сайтов каталог продуктов от Zoo на русском... только там версия пораньше.
*

-Dima-

  • Захожу иногда
  • 85
  • 14 / 0
Я тоже склоняюсь, что проблема в кодировке таблиц. попробуйте unicode

А в самой базе заголовки нормально прописаны?
*

Drunk

  • Осваиваюсь на форуме
  • 38
  • 3 / 10
Я тоже склоняюсь, что проблема в кодировке таблиц. попробуйте unicode

А в самой базе заголовки нормально прописаны?







Точно) зашел в Бд а там на Зуу стоит latin1_swedish_ci ) сейчас попробую исправить - отпишусь=)
*

Drunk

  • Осваиваюсь на форуме
  • 38
  • 3 / 10
Спасибо! Проблема решена. Дело было в кодировке бд=)
*

antom

  • Захожу иногда
  • 58
  • 0 / 0
Такая же проблема, но с кодировками все в порядке.... utf8_general_ci
*

antom

  • Захожу иногда
  • 58
  • 0 / 0
Может кто-то сталкивался, только ZOO 3.0.10 и Joomla 3
*

capricorn

  • Завсегдатай
  • 1949
  • 118 / 3
Цитировать
Может кто-то сталкивался, только ZOO 3.0.10 и Joomla 3

AddDefaultCharset utf-8 в .htaccess не помогло?
*

Ingener

  • Давно я тут
  • 547
  • 10 / 5
нет, та же проблема последний зоо и Joomla 2.5

AddDefaultCharset utf-8 в .htaccess не помогло
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема с отображением каталога на zoo2.2 В IE 6

Автор Kitokedoki

Ответов: 4
Просмотров: 1077
Последний ответ 20.08.2018, 10:07:35
от raketa2000
Заголовки на странице подачи

Автор Mick_20

Ответов: 1
Просмотров: 696
Последний ответ 13.06.2016, 16:02:38
от Mick_20
Проблема с импорт большого количества итемов, с помощью JSON

Автор tarkasha

Ответов: 1
Просмотров: 840
Последний ответ 17.12.2014, 12:56:55
от voland
Zoo Проблема с каталогом

Автор yoshkin

Ответов: 12
Просмотров: 2140
Последний ответ 03.06.2014, 23:59:38
от kozhenevsky
Подача материала через фронт в Зуу - проблема форматирования

Автор SemiLex

Ответов: 21
Просмотров: 2404
Последний ответ 20.01.2014, 17:58:30
от Дмитрий_76