0 Пользователей и 1 Гость просматривают эту тему.
  • 342 Ответов
  • 157037 Просмотров
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #240 : 09.03.2010, 19:04:59 »
@strizhenkov,

или помогайте нам разбираться с проблемой автора этой темы или сделайте отдолжение и откройте свою личную. захватывать чужую тему на форуме - и плохие манеры и нарушение правил форума.
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

strizhenkov

  • Новичок
  • 6
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #241 : 09.03.2010, 23:50:23 »
Прочитал ветку и заметил много ответов со схожими вопросами, поэтому подумал, что это здесь нормально. Больше не буду. Поначалу казалось что проблема в кодировке, оказалось в самом компоненте.

Re: Проблемы с кодировкой в 1.5
« Ответ #242 : 18.03.2010, 15:45:20 »
При редактировании сайта всплывают информационные окна в непонятной кодировке. Как переделать на их русский язык?  Может где-то я ошибся в установке?
Почему-то сайт phpMyAdmin загружается на английском. как его переделать на русский?

Re: Проблемы с кодировкой в 1.5
« Ответ #243 : 05.04.2010, 22:39:40 »
Версии MySQL и PHP?

Кодировка базы данных?
*

v4vitaliy

  • Осваиваюсь на форуме
  • 34
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #244 : 11.04.2010, 18:21:12 »
Всем привет!

Установил Яндекс карту на сайт - русский текст на балуне (подписи на карте) отображается вопросиками. В Яндексе мне сказали, что JavaScript, который выводится на странице находится в кодироке windows-1251. Как это можно поменять и где, подскажите, пожалуйста?
Индексная страница (в которой скрипт стоит) - в utf-8, дамп тоже.

Ссылка на страницу: http://www.restoran.graffiti-film.ru/index.php?option=com_contact&view=contact&id=1&Itemid=61
*

v4vitaliy

  • Осваиваюсь на форуме
  • 34
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #245 : 13.04.2010, 10:57:57 »
Мастера, помогите, пожалуйста.

Re: Проблемы с кодировкой в 1.5
« Ответ #246 : 13.04.2010, 15:25:37 »
Люди у меня тоже проблема с бесплатным хостом. Зарегистрировался на forsite.org установил Joomla 1.5.15, потом ее русифицировал, но когда пытаюсь создать материал на русском выдает его вот такими знаками "?". В файле .htaccess ставил AddDefaultCharset utf-8 не помогает, что может быть, как исправить?
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #247 : 14.04.2010, 14:59:14 »
Люди у меня тоже проблема с бесплатным хостом. Зарегистрировался на forsite.org установил Joomla 1.5.15, потом ее русифицировал, но когда пытаюсь создать материал на русском выдает его вот такими знаками "?". В файле .htaccess ставил AddDefaultCharset utf-8 не помогает, что может быть, как исправить?
Что Вы еще попробовали сделать из того что написано на 9-ти страницах этой темы?
Не бойся спрашивать, без этого ни как! -)
*

VB14

  • Новичок
  • 3
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #248 : 16.04.2010, 02:16:05 »
Привет всем. Столкнулся с проблемой кодировки сразу при установки Joomla.
Скачал joomla1.5.15_rus
распаковал файлы на ftp и сразу вижу такую картину с русским языком:


Как это можно решить подскажите, чтобы был нормальный русский язык?
*

Alldar

  • Завсегдатай
  • 1450
  • 187 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #249 : 16.04.2010, 02:27:02 »
В файле .htaccess добавить AddDefaultCharset utf-8 пробовали?
Пожалуйста не дублируйте сообщения в личку/skype/google+. Все вопросы задавайте на форуме! Спасибо!

Клуб шаблонов для Joomla - NorrTheme
*

VB14

  • Новичок
  • 3
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #250 : 16.04.2010, 02:38:15 »
Я может в этом плохо разбираюсь, но сделал следующее:
На ftp переименовал файл htaccess.txt в .htaccess открыл для редактирования и просто в конце дописал AddDefaultCharset utf-8
- с отображение всё так же
*

danik.html

  • Живу я здесь
  • 2650
  • 353 / 4
Re: Проблемы с кодировкой в 1.5
« Ответ #251 : 16.04.2010, 03:48:53 »
Не уверен, есть ли в этом толк, но попробовать - не лишнее.

AddDefaultCharset utf-8
AddCharset utf-8 *
<IfModule mod_charset.c>
    CharsetSourceEnc utf-8
    CharsetDefault utf-8
</IfModule>
【Мегапак Virtuemart:
 • метатеги (description,keywords)
 • заголовки (title)
 • красивые алиасы (чпу) без тормозов и дублей!
*

VB14

  • Новичок
  • 3
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #252 : 16.04.2010, 12:04:40 »
danik.html - Помогло! Спасибо!
По крайней мере инсталлятор стал русским.
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #253 : 16.04.2010, 12:14:43 »
Прежде чем писать свой вопрос - читайте тему!
Например последний совет и решение последнего вопроса, задавался и решался в теме уже раз 5 точно. Автору топика, - конечно респект, но само решение в теме есть в том или ином виде, уже написанное и опробованное не одной сотней людей.
Не бойся спрашивать, без этого ни как! -)
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #254 : 28.04.2010, 23:11:47 »
Строим шаблон
Код
<?php echo '<?xml version="1.0" encoding="utf-8"?' .'>'; ?>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="{LANG_TAG}" lang="{LANG_TAG}" dir="{LANG_DIR}" >
<head>
<jdoc:include type="head" />
<link rel="stylesheet" href="templates/{TEMPLATE}/css/template.css" type="text/css" />
</head>
<body>  
Русский язык
</body>
</html>  

Получаем это
Код
<?xml version="1.0" encoding="utf-8"?><!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="{LANG_TAG}" lang="{LANG_TAG}" dir="{LANG_DIR}" >
<head>
  <base href="http://era.in.ua/" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="robots" content="index, follow" />
  <meta name="keywords" content="joomla, Joomla" />
  <meta name="description" content="Joomla! - the dynamic portal engine and content management system" />
  <meta name="generator" content="Joomla! 1.5 - Open Source Content Management" />
  <title>Главная страница</title>

  <link href="/index.php?format=feed&amp;type=rss" rel="alternate" type="application/rss+xml" title="RSS 2.0" />
  <link href="/index.php?format=feed&amp;type=atom" rel="alternate" type="application/atom+xml" title="Atom 1.0" />
  <link href="/templates/rhuk_milkyway/favicon.ico" rel="shortcut icon" type="image/x-icon" />
  <script type="text/javascript" src="/media/system/js/mootools.js"></script>
  <script type="text/javascript" src="/media/system/js/caption.js"></script>

<link rel="stylesheet" href="/templates/{TEMPLATE}/css/template.css" type="text/css" />
</head>
<body>  
������� ����

</body>
</html>  

Как с этим бороться?

Установка на локале
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #255 : 28.04.2010, 23:20:56 »
Вы не поверите, - все дело в кодировке!!

Вы зачем вставляете в <body>...</body>  текст на русском языке?
Не бойся спрашивать, без этого ни как! -)
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #256 : 28.04.2010, 23:25:19 »
Скорей всего мне потребуется вставить информацию в индексовую страницу шаблона
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #257 : 28.04.2010, 23:31:57 »
Скорей всего мне потребуется вставить информацию в индексовую страницу шаблона
вы еще в этом не уверены?
а что мешает создать стиль наподобие вывода копирайтов через модуль на русском языке? 
Не бойся спрашивать, без этого ни как! -)
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #258 : 28.04.2010, 23:37:06 »
Я буду в этом уверен, когда решится проблема.
Я прекрасно понимаю, что можно задействовать модули, да ещё их и наклонировать.
Вопрос, зачем?
Выходит так, что если бы писать сайт на английском языке, то написание шаблона развязывают руки.
У меня сейчас пока стоит версия 1.0.11, собственно сайт в аваторе, как бы хотелось не потерять наработки
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #259 : 28.04.2010, 23:47:34 »
Я прекрасно понимаю, что можно задействовать модули, да ещё их и наклонировать.
Вопрос, зачем?
т.к. это единственное правильное решение.
Не бойся спрашивать, без этого ни как! -)
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #260 : 28.04.2010, 23:49:55 »
Единственно правильное решение?
С каких пор?
Я так понимаю, что решения задачи пока нет
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #261 : 28.04.2010, 23:56:36 »
Я так понимаю, что решения задачи пока нет
есть, и оно озвучено!
Если у вас есть альтернативное, - поделитесь .... буду признателен.
Не бойся спрашивать, без этого ни как! -)
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #262 : 29.04.2010, 00:01:26 »
Время для этого надо, получится, поделюсь.
Joomla скоро будет узнаваема, шаблонизация-модуляция ^-^
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #263 : 02.05.2010, 19:58:23 »
Для пробы попробовал в код обычного шаблона rhuk_milkyway
Прописать: <table class="nopad"><tr valign="top"><td><index>лысый слон<jdoc:include type="modules" name="top" style="xhtml"/>
Результат получил в нормальной кодировке. http://help.hi-hik.net/index.php?option=com_content&view=frontpage&Itemid=1
Сравните этот шаблон и ваш и найдете в чем ошибка.
Мне лень :))
А конечно самое очевидное что у вас может быть это то, что файл index.php у вас имеет кодировку отличную от utf-8.
« Последнее редактирование: 02.05.2010, 20:43:57 от evlebedev »
*

Ремесленник

  • Новичок
  • 19
  • 2 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #264 : 02.05.2010, 21:15:23 »
Я поставил обновление с 1.5.15 до 1.5.17 на 2 сайта на своем компьютере. На одном все прошло успешно, а на втором (на нем установлены были демоданные) на главной странице в панели управления все в кодировке 1251 и одним текстом. Кодировку можно поменять в браузере, но остается отображение сплошным текстом. Все ссылки работают и можно перейти на другие страницы и все они отображаются правильно. Перезаписывал обновление и отдельные языковые пакеты для админпанели, но результат тот же. В чем может быть проблема? Как лечить? Сайт этот не нужен и можно его просто удалить, но хочу понять причину.
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #265 : 03.05.2010, 19:04:30 »
не понял что значит  
отображение сплошным текстом.
Если кодировку надо менять в браузере это обычно означает что кодировка сайта по умолчанию 1251 - надо смотреть настройки сервера или хотя бы .htaccess
*

Ремесленник

  • Новичок
  • 19
  • 2 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #266 : 03.05.2010, 20:49:02 »
Проблема только на одной странице. Это и удивительно. С кодировкой и "сплошным текстом". Кодировку можно в браузере изменить, но все остается "сплошным текстом". Что значит "сплошным текстом"? Выше есть скриншот с неверной кодировкой, но при этом все в рамках и на своих местах. На этой странице есть только текст. Все ссылки с этой страницы работают и везде все нормально, но при переходе на эту страницу опять все отображается неверно. И это на одном из двух обновленных сайтов. На нем ничего кроме демоматериалов нет.
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #267 : 04.05.2010, 18:46:39 »
Шаблон у кривой страницы тот же что и у нормальных? Как насчет кешей?
*

Ремесленник

  • Новичок
  • 19
  • 2 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #268 : 04.05.2010, 21:08:45 »
Шаблон тот же что и на других и это панель управления, первая страница на которую попадаешь при входе в админпанель. До обновления все работало нормально.
Кэши очистил в первую очередь. Без результатов.
« Последнее редактирование: 05.05.2010, 21:43:39 от Ремесленник »

Re: Проблемы с кодировкой в 1.5
« Ответ #269 : 05.05.2010, 10:12:04 »
Без установки сразу залил бекап с локалхоста - заработало с 1 раза
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблемы после переноса с хостинга на денвер

Автор qweqweqwe

Ответов: 6
Просмотров: 2522
Последний ответ 17.07.2014, 09:28:38
от AlekVolsk
Частичная проблема с кодировкой после переноса на новый хостинг

Автор Lem625

Ответов: 0
Просмотров: 1042
Последний ответ 01.07.2014, 12:42:44
от Lem625
Проблемы с загрузкой файлов в RS MediaGallery

Автор AnastaSea

Ответов: 0
Просмотров: 1127
Последний ответ 12.02.2014, 13:07:14
от AnastaSea
Требуется помощь, проблемы с доступом на сайт после установки на хостинг

Автор lekraft

Ответов: 1
Просмотров: 860
Последний ответ 22.10.2013, 10:53:11
от lekraft
Проблемы с Joomla 1,5,22 и PHP 5,3,3....

Автор Spics

Ответов: 10
Просмотров: 7906
Последний ответ 27.12.2012, 12:02:00
от gluck1966