0 Пользователей и 1 Гость просматривают эту тему.
  • 342 Ответов
  • 157208 Просмотров

Re: Проблемы с кодировкой в 1.5
« Ответ #270 : 05.05.2010, 10:13:28 »
 произошел такой глюк,
помогите разобраться пожалуйста! модуль глючный, закидываю верхнее меню в модуль "mainmenu" как только жму сохранить вылетает шаблон с модуля "logo"
Че делать не знаю, если кто нибудь знает, подскажите!
*

Greycat

  • Захожу иногда
  • 298
  • 63 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #271 : 05.05.2010, 20:52:06 »
произошел такой глюк,
помогите разобраться пожалуйста! модуль глючный, закидываю верхнее меню в модуль "mainmenu" как только жму сохранить вылетает шаблон с модуля "logo"
Че делать не знаю, если кто нибудь знает, подскажите!

Из описания ничего не понятно. Опишите подробнее, приложите снимки экрана.

И вряд ли это имеет отношение к кодировке, создайте новую тему.
Я.д.=41001239962471  |  WMR=R271925495206  |  WMZ=Z144922023512
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #272 : 05.05.2010, 22:04:51 »
произошел такой глюк,
помогите разобраться пожалуйста! модуль глючный, закидываю верхнее меню в модуль "mainmenu" как только жму сохранить вылетает шаблон с модуля "logo"
Че делать не знаю, если кто нибудь знает, подскажите!

это к теме кодировки не относится. Ваша проблема скорее всего в конфликте двух модулей (если лого действительно вписано в произвольный модуль), прописанных на одну и ту же позицию и дерущихся за место
на экране.

рекомендуемая практика для лого - вплетать лого в код файла index.php шаблона.  
« Последнее редактирование: 06.05.2010, 02:52:36 от 4webspot »
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #273 : 06.05.2010, 02:56:33 »
люди, извините но у меня кароче такая фигня что на русский не переходит, а что делать не заню, да и на даругие колировки тоже не переходит. я уже и версии  Joomla! различные ставила но никакого эффекта. подскажите что делать?

вернитесь к самому началу этой темы, составьте список предложенных и сработанных решений и начните их по-одному тестировать на Вашей системе.

не забудьте возвращаться к начальной системе прежде чем переходить к новому тесту.
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #274 : 11.05.2010, 23:36:58 »
М-да, жаль, что нет решения моей задачи (смотреть ранние посты).
Доходит до смешного, альты даже не прописать.
Наклонировал модулей и смеюсь с этого.
В тело индексовой не получается прописывать русские буквы.
Гуру, неужели нет решения? :'(
*

sholban

  • Осваиваюсь на форуме
  • 31
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #275 : 12.05.2010, 00:09:58 »
Пытался найти решение проблемы по другим веткам форума, - не нашел. Видимо просить о помощи следует здесь.
Суть проблемы: После перехода с Joomla 1.0.15 на Joomla 1.5.15 и смены кодировки 1251 на utf-8 (БД и настройки у хостера) начались проблемы с кодировкой сообщений и писем отправляемых с сайта на русском языке. Сам сайт и админка работают нормально. Вот пример сообщения:
Тема сообщения:
Mail delivery failed: returning message to sender
Само письмо:
Код
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  name@mail.ru
    SMTP error from remote mail server after MAIL FROM:<postmaster@name.host.ru> SIZE=2184:
    host mail.mail.ru [95.220.240.55]: 550 postmaster@name.nichost.ru is in my BlackList. You re spammer?

------ This is a copy of the message, including all the headers. ------

Return-path: <postmaster@name.host.ru>
Received: from [95.1.4.24] (port=49370 helo=web40.host.ru)
by web-relay.mail.ru with esmtp (Exim 4.66 (FreeBSD))
(envelope-from <postmaster@name.nichost.ru>)
id 1OBss6-0005TI-4r
for name@mail.ru; Tue, 11 May 2010 21:03:54 +0400
Received: from name by web40.ru with local (Exim 4.66 (FreeBSD))
(envelope-from <postmaster@name.host.ru>)
id 1OBss5-000Kpz-UJ
for name@mail.ru; Tue, 11 May 2010 21:03:53 +0400
To: name@mail.ru
Subject: =?utf-8?B?0KHQsNC50YIg0JzQntCvINCi0KPQktCQOiB0ZXN0dGVzdA==?=
Date: Tue, 11 May 2010 21:03:53 +0400
From: =?utf-8?B?0J/RgNC+0LLQtdGA0Y/Qu9GM0YnQuNC6?= <postmaster@name.host.ru>
Message-ID: <cb3d45c23fe26ebefaca28333f5d8c51@www.name.ru>
X-Priority: 3
X-Mailer: PHPMailer (phpmailer.sourceforge.net) [version 2.0.4]
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset="utf-8"

пґя-пЎ я¦пЎпЎп¦я+п¦пҐпTп¦ п¦я-п¦пЎ пЎя-п©я-п¦п¦п¦п¦пҐпЎ я+п¦я-п¦пЇ я-п¦пЇпЄп¦п¦ п пЎпҐя-п¦п¦я-я- я¦п¦п¦я-п¦ http://www.name.ru/:
п?я-пЎп¦п¦я-я¦п¦я-я+пTп¦ <name@mail.ru>

test for test, english
я-п¦п©п¦я-я- я-п¦п¦я¦я- пҐп¦ я-я¬я¦я¦п¦пЎп+ я¦пЇя-п¦п¦
Хостер утверждает, что проблемы в самой джуумле, в его корявых скриптах, которые формируют неправильные заголовки писем.
Обновление Joomla до версии 1.5.17 и языковых файлов проблему не решило. Посетители перестали регистрироваться, видимо проблема в не читаемых сообщениях... адрес сайта http://www.sholban.ru
Как можно решить проблему c почтой и регистрацией? Куда, в каком направлении копать?

Заранее благодарю.
жмаю клаву, устал уже...
*

vital_s1

  • Захожу иногда
  • 267
  • 26 / 0
  • Joomla магия
Re: Проблемы с кодировкой в 1.5
« Ответ #276 : 12.05.2010, 00:21:38 »
sholban
Создайте отдельную тему в соответствующем разделе - Общие вопросы. Больше вероятность получить помощь.
Не бойся спрашивать, без этого ни как! -)
*

evlebedev

  • Захожу иногда
  • 56
  • 3 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #277 : 15.05.2010, 13:36:53 »
М-да, жаль, что нет решения моей задачи (смотреть ранние посты).
Доходит до смешного, альты даже не прописать.
Наклонировал модулей и смеюсь с этого.
В тело индексовой не получается прописывать русские буквы.
Гуру, неужели нет решения? :'(
Ну я же писал?(см выше) у меня в шаблон текст прописывается без проблем с кодировкой, и альты тоже.
В какой кодировке у вас создан файл index.php? Сохраняете его в utf-8 без BOM. Должно помочь.
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #278 : 16.05.2010, 10:09:29 »
Редактирую в блокноте.
Тупейший вопрос, что значит BOM?
*

danik.html

  • Живу я здесь
  • 2650
  • 353 / 4
Re: Проблемы с кодировкой в 1.5
« Ответ #279 : 16.05.2010, 11:03:08 »
Введите в Google тупейший запрос: что значит BOM .
Развернутый ответ будет по первой же ссылке.
【Мегапак Virtuemart:
 • метатеги (description,keywords)
 • заголовки (title)
 • красивые алиасы (чпу) без тормозов и дублей!
*

4853

  • Захожу иногда
  • 170
  • 20 / 11
Re: Проблемы с кодировкой в 1.5
« Ответ #280 : 16.05.2010, 12:06:47 »
М-да, работает.
Спасибо

Re: Проблемы с кодировкой в 1.5
« Ответ #281 : 27.05.2010, 20:43:52 »
Вот такая проблема. Перенес сайт с Denvera на хост. База данных в кодировке utf-8 и таблицы тоже, все как надо, однако, при написании русского текста появляются вопросы. Подскажите где копать?
configuration.php в UTF8 без BOM

Re: Проблемы с кодировкой в 1.5
« Ответ #282 : 27.05.2010, 23:48:23 »
Здравствуйте,
вот и у меня проблема, вместо русского языка выводятся вопросики. Когда я смотрю на это, у меня в голове у самого только вопросики мелькают. Через Гуглю нашел этот форум, но после прочтения здесь решения этой проблемы, ...вопросики так с головы и не исчезли, да и с сайта тоже. Короче, я не понял.

Вот что там у меня. Все кнопочки показываются на русском, а то что я пишу на странице нет, т.е. вопросики.
Залез в htaccess.txt, но там бардак какой-то, если так должно быть, то куда там вставить AddDefaultCharset UTF-8. А может кто покажет, что в этом файле должно находиться?
*

Trampypys

  • Захожу иногда
  • 126
  • 3 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #283 : 29.05.2010, 20:09:06 »
У меня на сайте тоже проблема с кодировкой очень интересная. Иногда захожу на сайт все хорошо открывается все буквы правильные все как надо, тут же перезанружаю страницу все буквы поехали, перехожу на другую страницу все хорошо, на третью опять могут быть кривые буквы а могут быть нормальные. Подскажите что можно сделать адрес сайта www.tamimc.info
Спасибо всем кто помогает в начинаниях веб разработки!
*

mayday74

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #284 : 30.05.2010, 00:44:01 »
Здравствуйте
проблема с сообщениями Joomla 1.5.14
все сообщения(Уведомления) содержат, например:
�нформация: Ваш браузер не принимает cookies.
Остальное, вроде по-русски.(в теме был вопрос, но ответ не выложили).
« Последнее редактирование: 30.05.2010, 22:29:46 от mayday74 »
*

tenai

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #285 : 14.06.2010, 21:15:07 »
Помогите с проблемой кодировки, установил сайт на вэбсервер и кодировка полетела, одни каракули. При установке были нюансы:
через phpmyadmin залить БД на сервер никак не получалось у меня (все время ошибку выдавал, мол нет таблиц и все), поэтому я воспользовался dumperом, сделал бэкап базы данных, но! на сервере установить бд через dumper тоже не получилось, просто не мог залогиниться к БД (выдает ошибку), в итоге все вышло уродливым методом (как я подозреваю), а именно файл БД, созданный с помощью dumper.php на локальном сервере, я загрузил через phpmyadmin на сайт.... в общем заработало вроде, но кодировка кривая, что теперь делать не знаю, опыта катастрофически мало, нужен дельный совет
в файле .htaccess строчку AddDefaultCharset utf-8 по советам на форуме я прописывал и в начале файла и после RewriteEngine On , не помогает....! попа полная
В админку Joomla зайти не могу (там тоже все в каракулях), как то такое у меня уже было на локальной машине, намудрил с файлом конфигкрации и полетела и кодировка и вообще много чего, в админку тоже зайти не мог, логин и пароль вводишь, а ничего не происходит, опять страница авторизации, но я тогда переустановил Joomla и сайт почти по новой сделал....
а щас то что делать?
« Последнее редактирование: 14.06.2010, 21:19:08 от tenai »
*

tenai

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #286 : 14.06.2010, 21:25:37 »
ОПА! обнаружил что в IE с кодировкой все ок, однако сайт "поехал", т.е. центральное поле съехало кудато вниз. а в мозиле все на своем месте но в с кодировкой все криво! чего делать?
В администраторскую часть Joomla не могу зайти и через IE, хоть и с кодировкой тут проблем нет, наверное это уже новая проблема..... пипец


ЖДУ ПОМОЩИ!
« Последнее редактирование: 14.06.2010, 21:56:26 от tenai »
*

tenai

  • Новичок
  • 7
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #287 : 15.06.2010, 22:28:12 »
поменял кодировку на сайте! все заработало! вот ламмер)))
*

keks20

  • Захожу иногда
  • 75
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #288 : 31.07.2010, 12:07:15 »
Ребята помогите. Сделал сайт на версии 1.5.17. Все работает. С кодировкой на всех страницах нормально, кроме родного компонента голосования и CommunityBuilder. Заходя на страницах этих компонентов русский текст который выводят не эти коммпоненты превращается в знаки вопроса. Скрин прилагаю. Подскажите , что именно, в таком случае, нужно пересохранить в кодировке ЮТФ-8?
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #289 : 31.07.2010, 14:39:05 »
@keks20,

стоит проверить кодировку таблиц этих двух компонентов.

# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

keks20

  • Захожу иногда
  • 75
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #290 : 31.07.2010, 15:07:04 »
Т
@keks20,

стоит проверить кодировку таблиц этих двух компонентов.


@keks20,

стоит проверить кодировку таблиц этих двух компонентов.


Ты имеешь ввиду таблицы в Mysql? Если да, то каким макаром это сделать, опыта не было. Спасибо за помощь.
*

keks20

  • Захожу иногда
  • 75
  • 0 / 0
Re: Проблемы с кодировкой в 1.5
« Ответ #291 : 31.07.2010, 15:12:01 »
Проверил phpmyadmin. Все в ютф-8.
*

Kverde3

  • Захожу иногда
  • 239
  • 19 / 3
Re: Проблемы с кодировкой в 1.5
« Ответ #292 : 23.08.2010, 18:46:00 »
Попробуйте найти файлы локализации этого плагина и пересохранить их в UTF8 без BOM.
Way23.ru - блог о программировании.
*

guliwer

  • Захожу иногда
  • 96
  • 1 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #293 : 12.10.2010, 00:14:37 »
установил Joomla 1.5.20 c файлами рус перевода :всё робит хорошо!
НО не смог разобраться с шаблоном и установил ту же Joomla но с квик стартом от шаблона,уст рус перевод,начал править шаблон :изменяя текст кнопок на рус яз и вот тут проблема:вместо рус букв появилось вот это:?(знаки вопроса)
Подскажите кто знает где и вкаком файле править кодировку(если проблема в ней)?
познаю не опознанное!
*

guliwer

  • Захожу иногда
  • 96
  • 1 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #294 : 12.10.2010, 11:51:45 »
в новых таблицах было отличие от старых то что кодировка сравнения не utf8 я исправил но всёравно не помогло
познаю не опознанное!
*

guliwer

  • Захожу иногда
  • 96
  • 1 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #295 : 12.10.2010, 11:56:01 »
ставлю любой другой шаблон из пакета квик стар всё равно название кнопки пункта меню знаками вопроса
познаю не опознанное!
*

guliwer

  • Захожу иногда
  • 96
  • 1 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #296 : 12.10.2010, 12:02:58 »
перенёс файл htacess.txt с версии которая работала нормально ни помогло,подскажите что сделать?
познаю не опознанное!
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #297 : 12.10.2010, 13:57:43 »
установил Joomla 1.5.20 c файлами рус перевода :всё робит хорошо!
НО не смог разобраться с шаблоном и установил ту же Joomla но с квик стартом от шаблона,уст рус перевод,начал править шаблон :изменяя текст кнопок на рус яз и вот тут проблема:вместо рус букв появилось вот это:?(знаки вопроса)
Подскажите кто знает где и вкаком файле править кодировку(если проблема в ней)?

какой именно шаблон и откуда Вы его скачали?
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
*

guliwer

  • Захожу иногда
  • 96
  • 1 / 1
Re: Проблемы с кодировкой в 1.5
« Ответ #298 : 12.10.2010, 14:41:42 »
шаблон ja_portfolio_v1.1.0 а скачивал не помню от куда там всёравно ссылкой на deposit files вроде было
познаю не опознанное!
*

AlexSmirnov

  • Завсегдатай
  • 1862
  • 272 / 16
  • Ищите и найдете
Re: Проблемы с кодировкой в 1.5
« Ответ #299 : 12.10.2010, 22:16:40 »
шаблон ja_portfolio_v1.1.0 а скачивал не помню от куда там всёравно ссылкой на deposit files вроде было

Ваш шаблон, и в его последней и стабильной версии (весрия 1.1.2, октябрь 2010), и в Вашей Бета версии 1.1.0 - клубный, а наш форум не поддерживает безлицензионные коммерческие шаблоны.

для законного приобретения лицензии этого шаблона со скидкой и поддержкой, настоятельно рекомендую связаться с нашим диллером этого клуба Денисом Панщинским, ака _ib_
# Back the fufalo (особенно ту самую столкершу)! #
# ВАЖНО! Кайфую от удаления присланного в личку спама, почти как от любви (особенно по выходным). #
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблемы после переноса с хостинга на денвер

Автор qweqweqwe

Ответов: 6
Просмотров: 2537
Последний ответ 17.07.2014, 09:28:38
от AlekVolsk
Частичная проблема с кодировкой после переноса на новый хостинг

Автор Lem625

Ответов: 0
Просмотров: 1054
Последний ответ 01.07.2014, 12:42:44
от Lem625
Проблемы с загрузкой файлов в RS MediaGallery

Автор AnastaSea

Ответов: 0
Просмотров: 1150
Последний ответ 12.02.2014, 13:07:14
от AnastaSea
Требуется помощь, проблемы с доступом на сайт после установки на хостинг

Автор lekraft

Ответов: 1
Просмотров: 879
Последний ответ 22.10.2013, 10:53:11
от lekraft
Проблемы с Joomla 1,5,22 и PHP 5,3,3....

Автор Spics

Ответов: 10
Просмотров: 7927
Последний ответ 27.12.2012, 12:02:00
от gluck1966