Новости Joomla

Вышли релизы безопасности Joomla 6.1.3 и Joomla 5.4.8

Релиз безопасности Joomla 6.1.3 и Joomla 5.4.8

Проект Joomla! рад сообщить о выходе Joomla 6.1.3 и Joomla 5.4.8. Это релизы безопасности и исправления ошибок для серий 5.x и 6.x.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

👩‍💻 WT Otpravkapochtaru - библиотека сервиса Отправка Почты России для Joomla-разработчиков.

Joomla 5+ пакет для интеграции с API Почты России: нормализация данных, расчёт доставки, создание отправлений, партии, документы, возвраты, поиск отделений, справочники и SOAP-отслеживание.

v.3.0.0. Что нового?
Это дальнейшее развитие ранее закрытой Joomla-библиотеки для работы с API сервиса Отправка (для бизнеса) Почты России. Поэтому версия не 1.0.0, а 3.0.0.

Сейчас эта библиотека ушла от собственных реализаций и стала Joomla-обёрткой известного PHP SDK от Lapay Group.

Возможности библиотеки.
- получение настроек аккаунта, точек сдачи и текущего остатка запросов к API;
- нормализация адресов, ФИО и телефонов перед созданием отправления;
- расчёт тарифа и срока доставки;
- создание, поиск, изменение, удаление и возврат заказов в состояние «Новые»;
- проверка надёжности получателя;
- создание партий, просмотр партий и заказов внутри партии;
- генерация пакета печатных документов и формы Ф103;
- создание, изменение и удаление возвратных отправлений;
- поиск отделений по индексу, адресу и координатам, получение сервисов отделения;
- локальный список стран;
- SOAP-отслеживание операций по РПО и работа с билетами пакетного трекинга.

👩‍💻 Joomla-возможности.
В пакете библиотеки WT Otpravkapochtaru есть поля Joomla Form для расширений. Они позволяют работать в интерфейсе Joomla с некоторыми типами данных, получаемых по API из вашего личного кабинета в ЛК Почты России для бизнеса.
На данный момент в библиотеке доступны 3 поля списков, которые отображают доступные в аккаунте ОПС, типы и категории отправлений.
Поддерживаются зависимые списки: значение одного поля обновляется при изменении другого.

Системные требования.
Системные требования в основном связаны с системными требованиями апстрима библиотеки - LapayGroup PHP SDK.
- Joomla 5+
- PHP 8.3+
- Расширения PHP:
-- ext-mbstring
-- ext-simplexml
-- ext-soap (опционально, для трекинга)
-- ext-zip

Ссылки:
- Страница расширения
- GitHub библиотеки и документация

@joomlafeed

0 Пользователей и 1 Гость просматривают эту тему.
  • 5 Ответов
  • 1990 Просмотров
*

kogtehvost

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Приветствую форумчан!
Установил Joomla! 3.1.4 и последний K2, благополучно настраивал сайт, но когда дело дошло до дополнительных полей, вяснилось, что они не работают: В админке при нажатии на пункты "Extra fields" и "Extra fields froups" выдается следующее: "Обнаружена ошибка. 500 Макет default не найден".
Удалил K2, скачал с офсайта последнюю версию, установил - все то же самое, все работает кроме этих двух разделов, касающихся полей.
Кто-нибудь может пролить свет, в чем может крыться причина?
Спасибо заранее!
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
Откатите Joomla до версии 3.1.1 Там все работает корректно.Надо ждать исправления разработчиков К2 теперь.
Мне сегодня пришлось так заново сайт накатывать, выясняя опытным путем, отчего такой баг. Да, и после установки не стоит пока что обновляться до 3.1.4
Слетят точно так же, как и при установке на чистую.
*

Очередной вебмастер

  • Давно я тут
  • 768
  • 55 / 0
  • лысый умный дядя
Патч поставьте и все заработает - http://docs.joomla.org/J3.1:Extensions_Broken_in_3.1.4
Сайты на Joomla, разработка и поддержка
----------
Помог ответ - жми плюс!
*

kogtehvost

  • Осваиваюсь на форуме
  • 24
  • 0 / 0
Огромное спасибо! Все в порядке теперь!  :D
странно, что я ничего не нагуглил по этому вопросу, раз это известная проблема.
*

paternoster

  • Давно я тут
  • 506
  • 24 / 1
И не нагуглите.Проблеме 2 дня от роду.От обновления дистрибутива Joomla с 3.1.1 до 3.1.4 27 июля.Не поспевает Google так быстро.Проверяйте оф.сайт.
http://www.joomla.org/
*

kik84

  • Завсегдатай
  • 1350
  • 64 / 4
у меня версия 3.1.1, поставил на нее последний k2. сразу же сайт ушел в ошибку 500. если отключить родное SEO, то работает. ни патч, ни обновления пока не помогли
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

K2 ошибка при переносе на SQL

Автор Vekach

Ответов: 1
Просмотров: 8441
Последний ответ 21.08.2025, 16:49:01
от wishlight
Additional Categories for K2 в админке в материалах выводить все категории

Автор NIKOLY

Ответов: 0
Просмотров: 5502
Последний ответ 26.10.2024, 16:03:57
от NIKOLY
K2 + Falang при переходе по переведенному тегу ошибка 404

Автор Slava77

Ответов: 2
Просмотров: 5355
Последний ответ 09.02.2022, 15:53:00
от Slava77
Ошибка ПРИ создании материала В К2 - РЕШЕНО

Автор korchaga

Ответов: 1
Просмотров: 3423
Последний ответ 28.12.2020, 03:21:46
от korchaga
Ошибка components\com_k2\views\itemlist\view.html.php on line 485

Автор NIKOLY

Ответов: 5
Просмотров: 3839
Последний ответ 09.12.2020, 16:56:01
от NIKOLY