0 Пользователей и 1 Гость просматривают эту тему.
  • 469 Ответов
  • 41833 Просмотров
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@jeanzzz
Вопрос с новой версией разрешился?
*

St@lker

  • Захожу иногда
  • 79
  • 0 / 0
Цитировать
304 Not Modified не найден!

Как быть?
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@St@lker
Если это версия 1.0.7 и выдает для поддерживаемых расширений, то напомню, что для проверки на сервисе last-modified нужно отключить опцию "Только для ботов" в настройках плагина.
*

bgg87

  • Захожу иногда
  • 164
  • 2 / 0
  • Истина где-то рядом...

Есть 4 сайта:
Joomla 1.5.26 + VirtueMart 1.1.6
Joomla 2.5.27 + VirtueMart 2.6.12
Joomla 3.3.6 + JoomShopping 4.6.0
Joomla 3.3

Ни где должным образом не заработало. :(
Помимо плагина перепробовал ещё кучу других вариантов.
При проверке, то конечно отдает заголовок, но вот дату показывал либо текущую, либо, например такую и на всех страницах одну и ту же:
Код
Last-Modified: Wed, 12 Jan 2011 15:04:36 GMT
Помощи или совету буду крайне рад!
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@bgg87
Для Joomla 1.5 я плагин не выкладывал здесь (предоставляю индвидуально), но уверяю, что работает. Для третьей версии нужно делать хак ядра (читать здесь). Для версии 2.5 при проверке вручную (на сервисе last-modified.com) необходимо отключать опцию плагина "Только для ботов". Так что из перечисленного Вами должно работать как минимум на втором сайте.

Однако стоит заметить, что некоторые "продвинутые" компоненты вставляют свои 5 коп. в формирование заголовка, например, com_sh404sef. Решение для него и VirtueMart у меня есть, но платно.
*

gravitapok

  • Новичок
  • 1
  • 0 / 0
А могли бы Вы поделиться плагином для Joomla 1.5?
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@All
Сегодня закончил новую версию плагина для Joomla! 3.3+. Этот вариант платный - 5$.
v.1.0.8
+ добавлена полная поддержка Joomla! версий 3.3+, теперь идет пакетная установка (сам плагин и дополнительный патч платформы)

Как всегда проверить можно здесь: http://last-modified.com/ru/ для теста укажите: http://j3.yunoshev.com/news/3-article-1-title
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
Вышла новая версия плагина для Joomla 3.x
v.1.0.8.01
+ добавлена поддержка Cobalt CCK 8+ для Joomla! версий 3.3+
(только в платной версии; тестировался на версии Joomla 3.x, форум, блог; поддержка страниц статьи и категории (секции)

Ссылка на демо Cobalt с поддержкой плагина Last-Modified: http://j3.yunoshev.com/cobalt-forum
« Последнее редактирование: 12.11.2014, 17:25:59 от yunoshev »
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
Цитировать
+ добавлена полная поддержка Joomla! версий 3.3+, теперь идет пакетная установка (сам плагин и дополнительный патч платформы)
Что за патч и зачем он нужен? вносит изменение в ядро системы?
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
Что за патч и зачем он нужен? вносит изменение в ядро системы?
Да, для корректной отдачи Last-Modified, т.к. ядро системы перекрывает своим, даже если вешать триггер плагина на любое системное (и не системное) событие.
Патч нужен, чтобы пользователи не пытались самостоятельно внести необходимые изменения во избежание неверных правок.
После долгих мучений я нашел только такое решение.
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
Может стоит отправить предложение разработчикам Joomla включить изменение в следующий дистрибутив?
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
Новая версия плагина Last-Modified Any Content (платный вариант для платных расширений):
v.1.0.8.02
+ форум EasyDiscuss (J2.5 & J3.x)
+ магазин цифровых товаров MediaStore (J3.x)

В следующей общедоступной версии сделаю поддержку FLEXIcontent.
Какие еще из бесплатных компонентов внедрить в поддержку?
*

Hol1killer

  • Захожу иногда
  • 224
  • 3 / 0
Приветствую, не много не пойму а в чем соль платной версии ? У меня стандартный com_content работает и с версией 1.07 в Joomla 3.3.6 - или я ошибаюсь ? Вроде все правильно выдает и в категории и в материалах. Я так понимаю речь в платной версии идет о совместимости других расширений, я прав или нет ?

Приобрести можно у вас в ЛС ? Спасибо
*

malavka

  • Осваиваюсь на форуме
  • 48
  • 1 / 0
Может стоит отправить предложение разработчикам Joomla включить изменение в следующий дистрибутив?
Было бы очень здорово. очень мало CMS это делают из коробки.
*

malavka

  • Осваиваюсь на форуме
  • 48
  • 1 / 0
Новая версия плагина Last-Modified Any Content (платный вариант для платных расширений):
v.1.0.8.02
+ форум EasyDiscuss (J2.5 & J3.x)
+ магазин цифровых товаров MediaStore (J3.x)  

В следующей общедоступной версии сделаю поддержку FLEXIcontent.
Какие еще из бесплатных компонентов внедрить в поддержку?
Как можно купить Ваш плагин? Дайте ссылочку или инструкции по оплате и скачиванию, пожалуйста. И огромное спасибо за проделанную работу. Правильная отдача ласт модифайд имеет огромную важность для SEO, сайты будут впуливаться в выдачу моментально.
« Последнее редактирование: 18.11.2014, 23:43:42 от malavka »
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
У меня стоит Admin tools, защищающий от атак.

Ставлю плагин 1.0.8.02, получаю в админке:
Цитировать
Предупреждение
Удаление библиотеки: Попытка удалить библиотеку ядра
Это как раз попытка заменить файлик. Как будет работать плагин, если не менять файл ядра? И где находится папка application чтобы вручную можно было заменить?

lmac - не очень удобное название... по привычке поиском среди установленных расширений ищу по ключу lm, а тут изменилось название. но это так, мелочи.
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
У меня стоит Admin tools, защищающий от атак.

Ставлю плагин 1.0.8.02, получаю в админке:Это как раз попытка заменить файлик. Как будет работать плагин, если не менять файл ядра? И где находится папка application чтобы вручную можно было заменить?

lmac - не очень удобное название... по привычке поиском среди установленных расширений ищу по ключу lm, а тут изменилось название. но это так, мелочи.
lmac - Last-Modified Any Content :)

К сожалению, другим фиксам Joomla не поддавалась, поэтому пришлось придумать патч при установке плагина.
Если у кого-то стоит похожее расширение для защиты файлов платформы Joomla, то вручную можно файл из комплекта положить сюда:
libraries\joomla\application\

Без него корректной отдачи Last-Modified не будет!
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
Как можно купить Ваш плагин? Дайте ссылочку или инструкции по оплате и скачиванию, пожалуйста. И огромное спасибо за проделанную работу. Правильная отдача ласт модифайд имеет огромную важность для SEO, сайты будут впуливаться в выдачу моментально.
Конечно, сегодня сделаю обновление на своем сайте и тогда сможете скачать после покупки.
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
К сожалению, другим фиксам Joomla не поддавалась, поэтому пришлось придумать патч при установке плагина.
А если пропатчить Joomla, а потом твой плагин отключить, Joomla не сломается? (гипотетически)

Установил плагин, заменил файл с патчем, на выхлопе: Last-Modified не найден! (Joomla 3.3 + ZOO)

Я тоже не понял, зачем нужна версия с патчем, если на Joomla 3 предыдущая версия с ZOO работала нормально...
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Sulpher, All
ЕЩЕ РАЗ НАСТОЯТЕЛЬНО ВСЕМ РЕКОМЕНДУЮ ВНИМАТЕЛЬНО СМОТРЕТЬ НАСТРОЙКИ ПЛАГИНА, начиная с версии 1.0.7!
Все прекрасно работает.

Joomla ни после отключения, ни после удаления плагина НЕ СЛОМАЕТСЯ.
*

malavka

  • Осваиваюсь на форуме
  • 48
  • 1 / 0
@yunoshev @all
Понимаю, что отбираю отчасти своим предложением хлеб @yunoshev (возможно), но всё таки хотел вернуться к предложению попросить разработчиков Джу включить патч Виктора в коробку. Чтобы потом плагин не патчил ядро, а работал поверх. Про реализацию Last-Modified на уровне ядра из коробки даже не мечтаю, хотя очень хотелось бы. Может ли кто-то из уважаемой общественности отправить такой коммит самым главным Joomlaмейкерам? Я просто не очень в теме пока, как это правильно делается.
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
Да, был включен параметр "Только для ботов". может его по умолчанию отключить?


@yunoshev @all
Понимаю, что отбираю отчасти своим предложением хлеб @yunoshev (возможно), но всё таки хотел вернуться к предложению попросить разработчиков Джу включить патч Виктора в коробку. Чтобы потом плагин не патчил ядро, а работал поверх. Про реализацию Last-Modified на уровне ядра из коробки даже не мечтаю, хотя очень хотелось бы. Может ли кто-то из уважаемой общественности отправить такой коммит самым главным Joomlaмейкерам? Я просто не очень в теме пока, как это правильно делается.
это хорошая мысль. не думаю, что это отберет хлеб - плагин все равно нужно купить, а патч Виктор сделал из-за отсутствия альтернатив.
чтобы подать request, нужно правильно сформулировать вопрос и пояснть, что и где патчить и зачем...
*

Art2

  • Новичок
  • 1
  • 0 / 0
yunoshev, уточните пожалуйста:
1. Версия плагина 1.0.7 - подходит ли для Joomla 3.3? При условии, что я не использую сторонние компоненты типа K2, VM, ZOO и тп ?
2. В чем принципиальное отличие бесплатной версии от платной? (Я так понял - это пакетная установка и поддержка популярных компонентов. Верно?)

 p/s: Добавьте ссылку в шапке на покупку плагина. На вашем сайте не нашел..
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
Да, был включен параметр "Только для ботов". может его по умолчанию отключить?
Ага, и тогда те, кто никогда не заглядывает в настройки плагинов будут жаловаться на то, что браузер якобы кеширует страницы и все-такое... :)
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Art2
1. Сам плагин работать на 3-ей версии будет, но без патча платформы правильные заголовки отдаваться поисковикам не будут.
2. Все верно. Еще включается защита патча от удаления, чтобы не поломать ядро системы.

Через пару часов будет ссылка на платную версию.
*

rubystar

  • Захожу иногда
  • 60
  • 1 / 0
Joomla! 2.5.20
sh404SEF 4.4.0.1725

установил плагин 1.0.7

пробовал изменять категорию и  материал. очистил весь кеш на сайте.

В изменённой категории дата изменения стоит Last-Modified: Sun, 31 Aug 2014 19:54:05 GMT, т.е. как я понял ничего не произошло(снимок)
В изменённом материале дата создания и изменения стали одинаковыми, т.е дата изменения изменилась, но почему изменилась дата создания ?(снимок2)

подскажите в чём проблема ?
« Последнее редактирование: 19.11.2014, 20:29:05 от rubystar »
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Art2, malavka
Скачать плагин можно отсюда
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@rubystar
Я сталкивался с тем, что sh404SEF в одном из своих файлов отдает свой заголовок для любой страницы, перекрывая работу плагина. Возможно, у вас как раз этот случай.
*

rubystar

  • Захожу иногда
  • 60
  • 1 / 0
@rubystar
Я сталкивался с тем, что sh404SEF в одном из своих файлов отдает свой заголовок для любой страницы, перекрывая работу плагина. Возможно, у вас как раз этот случай.

это можно как то исправить ? и почему плагин на категорию (время модификации описания категории) как я понял отказывается работать ? опять sh404 ?
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@rubystar
Можно. Напишу в личку.
Со стандартными материалами было принято решение принимать во внимание не дату модификации категории, а списка статей для данной категории во фронте, и это мы считаем правильным.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Готовый плагин для генерации мета тегов по шаблону

Автор zloi_genii

Ответов: 9
Просмотров: 308
Последний ответ 06.09.2021, 16:43:36
от musstudent
JL NO DOUBLES - плагин борьбы с дублями

Автор zikkuratvk

Ответов: 301
Просмотров: 41626
Последний ответ 25.06.2021, 11:47:01
от effrit
WT SEO Meta templates плагин сео-шаблонов для Joomla

Автор musstudent

Ответов: 0
Просмотров: 147
Последний ответ 29.05.2021, 09:42:49
от musstudent
last-modified и if-modified-since для Joomla 1.5/2.5

Автор Antosha

Ответов: 365
Просмотров: 68578
Последний ответ 18.02.2017, 06:48:11
от User82
плагин Advanced Google analytics код не в том месте

Автор DeniTornado

Ответов: 0
Просмотров: 802
Последний ответ 04.01.2017, 14:01:35
от DeniTornado