0 Пользователей и 1 Гость просматривают эту тему.
  • 469 Ответов
  • 41864 Просмотров
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@romagromov
На момент написания анонса была поддержка только обычных статей.
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
Кстати, для поддержки в плагине FLEXIcontent внес свой вклад (пожертвования на кофе:) ) форумчанин Sulpher.
« Последнее редактирование: 05.08.2015, 13:33:22 от yunoshev »
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@All
Готова для скачивания новая версия плагина v.1.2.2 для Joomla v.3.3+ (платная).
Внедрена поддержка Last-Modified в комментариях на страницах разных компонентов, организованных с помощью компонентов комментариев JComments.

Для JComments сейчас имеется поддержка следующих страниц:
  • Cobalt Record
  • Content article; учитывается параметр разрешенных для комментирования категорий
  • EasyBlog Entry
  • FlexiContent article
  • JDownloads Download Page
  • K2 Item Page
  • MosetsTree Link Page
  • Virtuemart Product Details Page
  • yvCommodity Product Details Page
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@All, Hol1killer
Для платной версии внедрена поддержка обновления с сервера, начиная с версии 1.2.2.
Для правильной работы обновления Вам необходимо заново скачать и установить плагин этой версии (или старше), зайти в раздел "Мои закачки" на сайте, получить Download ID (идентификатор загрузки) и ввести его в настройках плагина!
*

Hol1killer

  • Захожу иногда
  • 224
  • 3 / 0
Виктор приветствую.

Спасибо за проделанную работу, мы это ценим. Но обновиться не получилось, установил по новой плагин откатил в файле манифеста до версии 1.2.1 но все равно проблема осталась при обновлении пишет что не возможно выполнить пакетную загрузку и все так же. Подскажите в чем может быть проблема.

Download ID вставил в плагин, но это не помогло.

Буду ждать вашего ответа.
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Hol1killer
Версия 1.2.1 еще не поддерживает процедуру live update. Этот код внедрен лишь в версии 1.2.2. Можно разве что изменить код 1.2.1, если это критично и нужно проверить уже. Но это обсуждается уже в личке.
*

Hol1killer

  • Захожу иногда
  • 224
  • 3 / 0
@Hol1killer
Версия 1.2.1 еще не поддерживает процедуру live update. Этот код внедрен лишь в версии 1.2.2. Можно разве что изменить код 1.2.1, если это критично и нужно проверить уже. Но это обсуждается уже в личке.

Впринципе нет я просто хотел проверить, а если 1.2.3 поставлю :)) будет работать ?)
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Sulpher
Для проверки работоспособности плагина на сайтах с HTTPS необходимо использовать сервис redbot.org , т.к. сервис last-modified.com видимо некорректно обрабатывает запросы/ответы для HTTPS.
Спойлер
[свернуть]
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
@yunoshev,
проверил - с https работает, спасибо :-)
Единственное, что не понял - сервис redbot.org ругается на eTag. Эту настройку просто нужно отключить или нужна доработка? (сайт на ZOO CCK)
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Sulpher
Ругается на то, что одна и та же страница в разные моменты времени отдает одинаковый ETag. Видимо, что-то не дочитал в стандартах и нужна доработка.
*

rixter

  • Захожу иногда
  • 93
  • 9 / 0
  • Кто юзал мой писи?
@yunoshev
Спасибо за плагин!

Немного отчетности и вопрос.
Установил плагин на тестовый сайт (J2.5.4). Т.к. сайт закрыт через .htaccess, могу смотреть http заголовки с помощью плагина для FF.
Last-Modified добавился и изменяется при редактировании статьи (com_content).

Увидел, что в платной версии есть поддержка Jcomments. Я правильно понимаю, что при добавлении комментария, Last-Modified также будет менятся?
Можно ли добавить такую возможность (платно) для J2.5?

От вкл/выкл модуля на странице Last-Modified должен меняться или только по изменению материала?
Last-Modified страницы измениться если добавится новая статья в модуле последних новостей?
« Последнее редактирование: 28.08.2015, 16:25:42 от rixter »
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@rixter
Да, в зависимости от даты комментария будет меняться и Last-Modified. Индивидуально можно добавить для 2.5. Оформите и оплатите заказ для версии под 3-ку -- будете иметь "два в одном".
От модулей работа плагина не зависит.
*

rixter

  • Захожу иногда
  • 93
  • 9 / 0
  • Кто юзал мой писи?
Установил я плагин на основной сайт (J2.5). Проверку в http://last-modified.com/ru/ проходит и на дату модификации, и на код 304.
Также проверку можно провести через Я.вебмастер. Но только для зарегистрированных сайтов и для проиндексированных страниц, зато с указанием даты в заголовке If-Modified-Since. Это позволило проверить работу плагина для страниц с комментариями.

Виктор доработал плагин (поддержка Jcomments) под "мою старушку" 2.5 версии. Помог по настройкам. Рекомендую как отличного специалиста!
Спасибо!
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@rixter
Вам спасибо за покупку!
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
@Sulpher
Ругается на то, что одна и та же страница в разные моменты времени отдает одинаковый ETag. Видимо, что-то не дочитал в стандартах и нужна доработка.
Ориентировочно когда планируется внесение этого исправление? Не срочно, но хотелось бы понимать, когда выйдет фикс.
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Sulpher
Пардон, забыл за него. Думаю, в понедельник.
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@All
Готова для скачивания новая версия плагина v.1.2.3 для Joomla v.3.3+ (платная).
Изменен алгоритм вычисления параметра ETag (обсуждалось с Sulpher).
*

Hol1killer

  • Захожу иногда
  • 224
  • 3 / 0
Виктор приветствую, опять проблема с обновлением через админку.... Ошибка аналогичная...
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Hol1killer
Ясно. Разбираюсь.
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@Hol1killer
Похоже, что проблема в моем хостинге, с библиотекой cURL. В тех.поддержку написал, жду ответа.
*

Hol1killer

  • Захожу иногда
  • 224
  • 3 / 0
@Hol1killer
Похоже, что проблема в моем хостинге, с библиотекой cURL. В тех.поддержку написал, жду ответа.
Скорее всего, буду ждать ответа !
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
пакет для Joomla 3.3+ удалять нельзя![/b] можно только отключить в управлении расширениями, либо только плагин
На одном сайте было три вариации плагина за много лет, удалил все и рухнула система. Нашел в топике это предупреждение только :-)
Что теперь можно сделать? Сайт Joomla 3.4.4, плагин - последняя версия (pro). Можно руками какие-то файлы перезаписать из дистрибутива Joomla чтобы запустить сайт и повторно установить дистрибутив?

*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@All
Необходимо перезалить всю папку libraries\joomla\application\
Ядро Joomla почему-то удаляет не один пропатченный файл, а всю папку с этим файлом. :(

Я после установки вообще выставляю параметр LOCKED для расширения. Сам плагин удалять можно, а пакет расширения -- НЕЛЬЗЯ!
*

ViktorMah

  • Захожу иногда
  • 254
  • 30 / 0
Доброго времени суток.
Столкнулся с проблемой избыточного кэширования на Вашем сайте. Без Ctrl+F5 ничего делать не мог. Плюс система оплаты некорректно отработала. А точнее прислала неправильный код подтверждения. В итоге пришлось отложить покупку, а жаль.
*

yunoshev

  • Завсегдатай
  • 1271
  • 179 / 1
@ViktorMah
Завтра исправлю.
*

Garun

  • Захожу иногда
  • 305
  • 17 / 3
Ничего не понимаю...
На куче сайтов работает, а на одном ни в какую!
http://dashatours.com/
Last-Modified не найден! - и хоть убейся (((
Готов к труду и обороне!
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
Garun, а там есть какие-то сторонние плагины? Вдруг потенциальный конфликт...
*

ViktorMah

  • Захожу иногда
  • 254
  • 30 / 0
...
Похоже Вы не одиноки. Имел наглость посмотреть ответ сервера, да простит меня @Sulpher, на сайте redbot.org. Так там тоже ничего не найдено
*

Sulpher

  • Живу я здесь
  • 2058
  • 393 / 15
  • Шаблоны и расширения Joomla
Господа, тогда укажите версию плагина и Joomla. У меня есть вот какое подозрение:
Как известно, плагин вносит патч core файла в Joomla. И есть разные версии плагина под разные версии Joomla. Я могу предположить, что вы когда-то поставили плагин, затем обновили Joomla, файлик перезатерся и поэтому функционал отвалился.
Я сам обычно делаю так: когда приходит время обновить Joomla, смотрю вышла ли новая версия плагина Виктора и накатываю последнюю версию плагина. Это гарантировано означает, что патч будет присутствовать. Ну и все работает на проектах (тьфу-тьфу) ;-)
*

Garun

  • Захожу иногда
  • 305
  • 17 / 3
В том то и дело, что накатил свежачок - пофиг вьюга ((
Готов к труду и обороне!
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Готовый плагин для генерации мета тегов по шаблону

Автор zloi_genii

Ответов: 9
Просмотров: 309
Последний ответ 06.09.2021, 16:43:36
от musstudent
JL NO DOUBLES - плагин борьбы с дублями

Автор zikkuratvk

Ответов: 301
Просмотров: 41670
Последний ответ 25.06.2021, 11:47:01
от effrit
WT SEO Meta templates плагин сео-шаблонов для Joomla

Автор musstudent

Ответов: 0
Просмотров: 149
Последний ответ 29.05.2021, 09:42:49
от musstudent
last-modified и if-modified-since для Joomla 1.5/2.5

Автор Antosha

Ответов: 365
Просмотров: 68601
Последний ответ 18.02.2017, 06:48:11
от User82
плагин Advanced Google analytics код не в том месте

Автор DeniTornado

Ответов: 0
Просмотров: 803
Последний ответ 04.01.2017, 14:01:35
от DeniTornado