0 Пользователей и 1 Гость просматривают эту тему.
  • 28 Ответов
  • 6228 Просмотров
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Установил Joomla  2.5.6 c панели управления хостера.
Все нормально работает.Тем более что  последние 4 года устанавливал все версии Joomla
и все работало.
Попытался обновить Joomla  2.5.6 на Joomla  3.3.1 - но, выскакивает ошибка
и обновление естественно не происходит.
Написал хостеру, пришел ответ что это не их вина пишите в службу поддержки Joomla.
Прилагаю 2 скрина что бы понятна была причина.Может кто сталкивался с подобным
или может подскажите что делать?

1 - http://prntscr.com/3tojst
2 - http://prntscr.com/3tokco
« Последнее редактирование: 25.06.2014, 13:20:17 от b2z »
*

x1

  • Захожу иногда
  • 412
  • 14 / 0
  • Linux — это Windows для бытовой техники
Установил Joomla  2.5.6 c панели управления хостера.
Все нормально работает.Тем более что  последние 4 года устанавливал все версии Joomla
и все работало.
Попытался обновить Joomla  2.5.6 на Joomla  3.3.1 - но, выскакивает ошибка
и обновление естественно не происходит.
Написал хостеру, пришел ответ что это не их вина пишите в службу поддержки Joomla.
Прилагаю 2 скрина что бы понятна была причина.Может кто сталкивался с подобным
или может подскажите что делать?

1 - http://prntscr.com/3tojst
2 - http://prntscr.com/3tokco


Эксперименты с сайтом надо делать на локалке, на Денвере например, потом протестировать и только затем заливать на хостинг, и версии php кажется разные нужны...
*

nikservise

  • Новичок
  • 19
  • 0 / 0
О каких экспериментах вы говорите?
Установил как обычно Joomla, решил просто обновить до новой версии.
Вы Неправильно истолковали текст.

А сама Joomla уже залита у хостера вместе с остальными скриптами
*

b2z

  • Глобальный модератор
  • 6941
  • 754 / 0
  • Разраблю понемногу
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Сегодня уже 4 часа как идет загрузка на обновление но ничего не загружается.
Это продолжается уже 2 день.
До вечера включен компьютер и сколько работаю наблюдаю за баром - но все стоит на месте
Загрузка не идет


Еще появляется вот такое сообщение

http://prntscr.com/3towm3
« Последнее редактирование: 17.06.2014, 17:47:41 от nikservise »
*

x1

  • Захожу иногда
  • 412
  • 14 / 0
  • Linux — это Windows для бытовой техники
О каких экспериментах вы говорите?
Установил как обычно Joomla, решил просто обновить до новой версии.
Вы Неправильно истолковали текст.

А сама Joomla уже залита у хостера вместе с остальными скриптами
Вот это я и имел ввиду, я понял, что вы обновляете на хостере, а надо на локалке: скачать дистрибутив 3.3.1 на комп в произвольную папку и обновиться.
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Вот это я и имел ввиду, я понял, что вы обновляете на хостере, а надо на локалке: скачать дистрибутив 3.3.1 на комп в произвольную папку и обновиться.
А потом все паковать и опять загружать на  хост - что за ерунду вы говорите.
Посмотрите кучу роликов где обновления происходят без локалки.
*

b2z

  • Глобальный модератор
  • 6941
  • 754 / 0
  • Разраблю понемногу
Сегодня уже 4 часа как идет загрузка на обновление но ничего не загружается.
Это продолжается уже 2 день.
До вечера включен компьютер и сколько работаю наблюдаю за баром - но все стоит на месте
Загрузка не идет


Еще появляется вот такое сообщение

http://prntscr.com/3towm3
У Вас похоже не включена поддержка gzinflate на хостинге.

Кстати, Вы же сначала до последней 2.5.22 обновиться пытаетесь?
*

nikservise

  • Новичок
  • 19
  • 0 / 0
У Вас похоже не включена поддержка gzinflate на хостинге.

Кстати, Вы же сначала до последней 2.5.22 обновиться пытаетесь?
Каким образом до 2.5.22 -  высвечивается сразу обновления до  3.3.1
Система сама определила до которой версии обновится.
А что это за функция gzinflate?
Напишу хостеру спрошу.
*

b2z

  • Глобальный модератор
  • 6941
  • 754 / 0
  • Разраблю понемногу
Каким образом до 2.5.22 -  высвечивается сразу обновления до  3.3.1
Странно. Зайдите в Компоненты - Обновления Joomla - Настройки -  Сервер обновления. Должно быть "Дистрибутивы Joomla с длительным периодом поддержки"
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Странно. Зайдите в Компоненты - Обновления Joomla - Настройки -  Сервер обновления. Должно быть "Дистрибутивы Joomla с длительным периодом поддержки"

Вы знаете, у меня нет в компонентах пункта обновления.
На панели управления есть значек обновить и там в настройках можно выставить период
Я пробовал ставить и краткосрочный период и длительный период - ничего не помогает
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Странно =) Ну да ладно.
Только что обновил в ручную до версии 2.5.22.
Ситуация не меняется  - правда большой список исчез а при обновлении выскакивает
все таже  функция gzinflate
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Только что получил ответ от службы поддержки хостера.
( Возможно ошибка возникает по той причини что для более новой версии Joomla не подходит php 5.2 http://exquisite.com.ua/pi.php )

Вопрос решился таким образом:
стояла версия php 5.4 я ее поменял на 5.3 и обновление сработало
*

AlekVolsk

  • Гуру
  • 6399
  • 360 / 4
Вопрос решился таким образом:
стояла версия php 5.4 я ее поменял на 5.3 и обновление сработало
Причина не в этом: более новая версия php имеет функционал предыдущей версии. Возможно, в 5.4 хостером были отключены некоторые функции, включенные им в 5.3, либо J2.5 использует функции php, доступные в 5.3, но объявленные как deprecated в 5.4, но тогда бы она (J) вообще не запускалась бы, имхо.
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Причина не в этом: более новая версия php имеет функционал предыдущей версии. Возможно, в 5.4 хостером были отключены некоторые функции, включенные им в 5.3, либо J2.5 использует функции php, доступные в 5.3, но объявленные как deprecated в 5.4, но тогда бы она (J) вообще не запускалась бы, имхо.

Хочу разочаровать, вчера обновил не посмотрел и ушел спать было уже поздно.
Сейчас включил не работает, ни панель управления ни сайт.
Теперь понятно что все дело в том пакете Joomla который находится у хостера в скриптах.
http://www.tsn.exquisite.com.ua/
*

AlekVolsk

  • Гуру
  • 6399
  • 360 / 4
Проблема с базой?
*

SK

  • Живу я здесь
  • 2126
  • 161 / 0
nikservise, а зчем вы мучаетесь с обновление Joomla 2.5 до 3?
Вы же ставите голый движок.
Поставьте сразу версию 3.3.1
*

nikservise

  • Новичок
  • 19
  • 0 / 0
nikservise, а зчем вы мучаетесь с обновление Joomla 2.5 до 3?
Вы же ставите голый движок.
Поставьте сразу версию 3.3.1

Да вот как раз скачал только что  - приеду с работы попробую установить - самый приемлемый вариант.
А там посмотрим.
*

AlekVolsk

  • Гуру
  • 6399
  • 360 / 4
Что-то Вы, сори, сразу-то начали как-то через...
Ставьте в настройках ПУ хостера последнюю версию php, которая только доступна (5.4, 5.5 - без разницы, J работает с 5.3.10 и выше без проблем), очищайте корневую папку сайта, бейте старую базу (она же пустая, я правильно понял?) и заивайте инсталляшку J3.3.1 - и будет Вам счастье!
*

b2z

  • Глобальный модератор
  • 6941
  • 754 / 0
  • Разраблю понемногу
Да вот как раз скачал только что  - приеду с работы попробую установить - самый приемлемый вариант.
А там посмотрим.
Мдаа =)
*

x1

  • Захожу иногда
  • 412
  • 14 / 0
  • Linux — это Windows для бытовой техники
А потом все паковать и опять загружать на  хост - что за ерунду вы говорите.
Посмотрите кучу роликов где обновления происходят без локалки.
Это не ерунда, а аксиома - сначала все тестируется на локалке, а только потом заливается на хостинг. Тем более в вашем случае апдейт с 2.5 на 3.3 делать прямо на хостинге - даже не смешно!
и в первом посте я вам написал, проверьте версию PHP на хостинге
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Что-то Вы, сори, сразу-то начали как-то через...
Ставьте в настройках ПУ хостера последнюю версию php, которая только доступна (5.4, 5.5 - без разницы, J работает с 5.3.10 и выше без проблем), очищайте корневую папку сайта, бейте старую базу (она же пустая, я правильно понял?) и заивайте инсталляшку J3.3.1 - и будет Вам счастье!

Поставил сначала версию php5.4 -  не работает, все вышеописанное в самом начале и скрины с этой версии
Когда изменил на php5.3 заработало, появилась закачка бара.
Получается что не подходит php5.4.


« Последнее редактирование: 18.06.2014, 18:56:13 от nikservise »
*

AlekVolsk

  • Гуру
  • 6399
  • 360 / 4
Для J3 прекрасно подходит php и 5.4 и 5.5, скорее всего это проблемы у вашего хостера, я бы поменял его.
*

nikservise

  • Новичок
  • 19
  • 0 / 0
Для J3 прекрасно подходит php и 5.4 и 5.5, скорее всего это проблемы у вашего хостера, я бы поменял его.
Палка о двух концах.
Когда выставляю  php 5.3 то проблема с Magic Quotes GPC Off - перепробовал все что можно.
Если выставляю   php 5.4 то проблема с поддержкой Zlib - пока ничего не нашел, ищу.
*

AlekVolsk

  • Гуру
  • 6399
  • 360 / 4
И опять же - это проблемы хостера. Если он для вас не может включить поддержку необходимых библиотек в php, то зачем такой хостер?
*

nikservise

  • Новичок
  • 19
  • 0 / 0
И опять же - это проблемы хостера. Если он для вас не может включить поддержку необходимых библиотек в php, то зачем такой хостер?

В обшем то сегодня к вечеру проблема решена.
Поднял всех хостеров на ноги.
Только что решили этот вопрос.
Спасибо и вам всем за советы. :)
*

AlekVolsk

  • Гуру
  • 6399
  • 360 / 4
И каково решение, если не секрет?
*

nikservise

  • Новичок
  • 19
  • 0 / 0
И каково решение, если не секрет?
Joomla  установилась, была проблема с localhost при установке, но потом выяснили
что изменился адрес - прописал другой  и все заработало.
Попросил их установить поддержку всех библиотек php.
Написали с поддержки что можете пробовать, все работает.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

JL No Doubles дает циклический редирект после обновления до Joomla 3.8.7

Автор kik84

Ответов: 2
Просмотров: 81
Последний ответ 22.04.2018, 12:56:45
от kik84
Вышло обновление Joomla! до 3.8.7

Автор Raven23

Ответов: 42
Просмотров: 1165
Последний ответ 20.04.2018, 18:17:26
от Efanych
Не отображаются настройки модулей Joomla 3.6.5

Автор AnatolyS

Ответов: 0
Просмотров: 36
Последний ответ 20.04.2018, 00:58:12
от AnatolyS
Вышел релиз Joomla! 3.6.3

Автор b2z

Ответов: 136
Просмотров: 11260
Последний ответ 19.04.2018, 14:53:59
от dmitry_stas
Вышло обновление Joomla! до 3.8.6

Автор Olg

Ответов: 26
Просмотров: 4083
Последний ответ 18.04.2018, 19:20:46
от zikkuratvk